Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Cydia problems - need help please!

  1. #1
    Default Cydia problems - need help please!
    I have ultrasn0w installed strictly to fix the one signal strength bar issue on my ip4 (on AT&T with 4.3.3 & 1.59.00 bb) and I had to reboot my phone after making a change to help with choppy animations. My signal strength was at one bar again and I needed to uninstall and then reinstall ultrasn0w again (I swear this program is way more trouble than it's worth). Anyway, when I tried to uninstall it I got an error message that said "Sub-process /usr/bin/dpkg returned an error code (2)".

    I did some research and thought I found a fix, which was the following:

    Solution:
    1- Get your way to the file and directory structure of your iPhone (through SSH or iFile or Mobile Terminal ...)
    2- Look for the /var/lib/dpkg/ directory
    3- You should be able to find the following files: available, availble-old, status, status-old
    4- Rename "available" to "available-bak"
    5- Rename "status" to "status-bak"
    6- Rename "available-old" to "available"
    7- Rename "status-old" to "status"
    8- Start Cydia , make sure that you allow Cydia to load completely first (just to be on the safe side ), try to install some apps.

    That worked temporarily but now I'm right back to the same error after reinstalling ultrasn0w and a couple other apps. Any ideas how I can fix this permanently? I'm away from my computer right now so I can't do anything via ssh, but I can do stuff via ifile if that's an option. Thanks.

  2. #2
    I really think ultrasn0w may be part of the problem here and this is why. I did the procedure from my 2nd post above again and got Cydia working. There was an app that needed updating (Snappy) so I went to update it and somehow ultrasn0w got involved (keep in mind that ultrasn0w was already installed and working at this point). Once Cydia finished doing its update I uninstalled and reinstalled ultrasn0w and when I rebooted my phone after that, Cydia wasn't working again. Why would ultrasn0w need to be updated when all I was trying to do was update Snappy? It's not like ultrasn0w was in the queue or anything and like I said, it was already completely installed and working. Same thing just happened again when I tried to update BiteSMS (see attached). I'm removing ultrasn0w for now because it seems to be causing a huge problem here but I'd really like to be able to install it since it fixes my signal strength bars. Please help!!!
    Attached Thumbnails Attached Thumbnails -photo.png   -photo1.png  

  3. #3
    Anyone? At this point I really don't think ultrasn0w is the culprit since I removed it (and the repo). I really need to get this fixed though because it seems to keep happening every time I try to update an app in Cydia.

  4. #4
    Can I just run the latest redsn0w right over the top of my jb and select the
    "Install Cydia" option? Will that just reinstall Cydia for me and "re-jb" my phone? Any reason I can't do that?

  5. #5
    Come on guys - someone has to be able to help me with this. I can't seem to get this figured out but there's got to be a fix for it, right?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •