I have this repo: Index of /cydia

But when I install the MobileTerminal package, Cydia will always say that there is a newer version available even though there isn't.

Here is some screenshot of it: 1, 2 & 3

I have tried to re-create and reload the repo multiple times and also refreshing the cydia interface without any fix.

Deb is located here and the Packages, Packages.gz and Release files can be found here.