Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Mobile Substrate update b0nkx?

  1. #1
    Default Mobile Substrate update b0nkx?
    iphone 3gs @ ios4.1 via limerain
    updated to the new mobilesubstrate this morning, and i can no longer get past the apple boot logo, did a restore, worked, restored backup, worked, restored via aptbackup to get my cydia apps back, back to the endless apple logo any ideas? anyone else having problems?

  2. #2
    My iPhone is a Part of Me
    Join Date
    Feb 2010
    Location
    Austin, Tx
    Posts
    812
    Thanks
    60
    Thanked 34 Times in 32 Posts

    Don't restore from your iTunes backup

  3. #3
    is there another way? that's how i've always done it, i use windows xp 64 so i go through hell since itunes has to be hacked into working, so i do the iOS restore on my laptop, then jailbreak it on my laptop, then restore my cydia saved info through iphonebrowser (metadata and sources.d), then update my cydia important packages and download aptbackup, then do an itunes restore, then aptbackup restore, and normally it winds up right where i was before the issue, but with this issue it's a no go but i'm just assuming it's because the mobilesubstrate update is still causing problems. so i figured i'll just wait until after work to try it again, maybe the bad update will be fixed or reverted

  4. #4
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    ssh into your phone to /library/mobilesubstrate/dynamiclibraries and rename dynamiclibraries to something else and then reboot

  5. The Following User Says Thank You to StealthBravo For This Useful Post:

    zap1027 (2010-11-23)

  6. #5
    but it doesn't load at all, just sticks on the apple logo, is the ssh daemon loaded at that point? and if so is the wireless interface even loaded by then? i'll give it a shot though

  7. #6
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    Yes you should be able to SSH just fine

  8. #7
    nope, no go, the phone doesn't get past the apple logo, and i tried to ssh to the default ip for my network, so either it doesn't load ssh or it doesn't enable network interfaces in the middle of another restore though, so hopefully when i do aptbackup's restore it'll work, if i knew where mobilesubstrate's entry into aptbackup's backup file were entered i could comment it out or something and just not update it.. but in that case i could only assume that it just wouldn't install it at all

    waited and did meh usual, now back to normal, except for the sborganizer data gonna have to spend 4 more days organizing apps again =/
    Last edited by uebergod; 2010-11-24 at 04:08 AM. Reason: Automerged Doublepost

  9. #8
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    oh that sucks

  10. #9
    OK, I had this same problem last night. Upgraded my iPhone 4 w/ 4.1 via Cydia. Let it update Mobile Substrate and Grooveshark. (I do not have Music Controller installed so it wasn't the culprit for me). Cydia required a reboot device and from then on it was hours of spinning circles and four letter expletives. I did not have SSH enabled and lost my saved SHSH in TinyUmbrella due to a clean install.

    I was just about to reformat the iPhone which would have sucked in itself, but I was pi$$ed about losing dozens of pix and family movies taken over the last couple days on a Holiday roadtrip.

    This is what I found worked after trying multiple workarounds and reading multiple threads of similar disasters last night:

    1. Manually went into Recovery mode 1st. (held sleep/home till reboot. Remove finger from home while still holding sleep till screen went black.)

    2. RE-jailbroke with Greenpois0n (this iPhone was originally jailbroke with limera1n, not that it matters)

    3. Followed Greenpois0n instructions...... jailbreak took much longer than I remember before from other iPhone/GP breaks.

    4. Phone finally completed jailbreak and booted into 'safe mode'

    5. AMEN

    I kept it in safemode.....went to Cydia and DEINSTALLED Grooveshark in case that caused the problem initially. I then made sure SSH was installed and activated just in case. I use PhoneView to access the file system. I went in and backed up my photos and app data. I then went and did both a synch and backup in iTunes after transferring all recent apps purchases

    I prayed and then did a respring......the gods smiled upon me.

    I then prayed again and did a reboot...... the gods smiled once again.

    All is back to normal.

    As much as I love Jailbreaking and have been an avid jailbreaker since iPhone 1 and Installer days..... it sux so bad when this stuff happens (like the Rock issue earlier in the year), It makes me envious of the normal folks who dont know the love/hate of what a good jailbreak can do.

    good Luck. No more Mobile Substrate updates for me until a week after release. Minimum.

  11. #10
    Quote Originally Posted by StealthBravo View Post
    ssh into your phone to /library/mobilesubstrate/dynamiclibraries and rename dynamiclibraries to something else and then reboot
    I forgot passwd for ssh and terminal?

  12. #11
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    user=root
    pass=alpine

  13. #12
    Default Thanks Man
    Here is the problem.

    I know you have read this before but I have continued to try new things.
    First, i am not sure what I would do if I were to be able to get into the ssh. But it doesn't matter because I changed the password from Alpine and I don't remember what I changed it to. But even if I could remember then I wouldn'tknow what to do.

    Also, I managed to JB again with GP just enough to mess up the entire folder system I had customized for the phone. But it STILL didn't load the Cydia app again. I wonder if I went to limera1n or redsn0w and JB it would give me Cydia back. Problem is I don't know the version of the software to use for 4.1 that will allow an untethered JB or I would try. What do you think?

  14. #13
    Can anyone tell me if the problems with Mobile Substrate have been fixed?? I have version 0.9.3367-1 available together with SBSettings and sbsettingsdtoggle update, are there any issues regarding these updates??
    I'm on a 3gs with 4.1

    Many thanks in advance

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •