Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: SBSettings Airplane Toggle

  1. #1
    iPhoneaholic reddawg's Avatar
    Join Date
    Sep 2008
    Location
    Massachusetts, USA
    Posts
    430
    Thanks
    39
    Thanked 71 Times in 59 Posts

    Default SBSettings Airplane Toggle
    I have noticed a problem in SBSettings concerning the Airplane mode toggle that occurs with both iOS 4.0 and 4.0.1. I have an iPhone 3GS JB and unlocked by Ultrasn0w.

    When I turn on Airplane mode in SBSettings, my carrier and bars changes to "Searching..." and then "No Service". It does not appear to go into airplane mode correctly. It is not turning off the radio and leaves WiFi running.

    If I go into Settings -> Airplane Mode and turn it off, it works properly. I am guessing that this must be a bug in SBSettings with iOS 4.0 & iOS 4.0.1.

    Has anyone noticed this or has an update on when SBSettings will be fixed?
    "When I die, I want to go peacefully in my sleep like my grandfather did...not kicking and screaming like the passengers in his car." -- Unknown

  2. #2
    iPhoneaholic patoons's Avatar
    Join Date
    Feb 2010
    Location
    Long Island
    Posts
    392
    Thanks
    9
    Thanked 34 Times in 23 Posts

    mine does this as well. but airplane mode always kept wifi running regardless. you'd have to disable wifi even while in airplane mode.

    but yes, airplane mode doesn't seem to work on 4.0

  3. #3
    Yep, same here.

  4. #4
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,824
    Thanks
    553
    Thanked 515 Times in 427 Posts

    It says in bigboss's notes that he is looking into it.

  5. The Following 2 Users Say Thank You to CaptainChaos For This Useful Post:

    LastSonOfKrypton (2010-08-06), reddawg (2010-08-07)

  6. #5
    Quote Originally Posted by CaptainChaos View Post
    It says in bigboss's notes that he is looking into it.
    Good to know. I was wondering if this was an iPhone 4 issue or an iOS issue. I just haven't bothered looking into it. I'm glad I saw this thread

  7. #6
    iPhoneaholic patoons's Avatar
    Join Date
    Feb 2010
    Location
    Long Island
    Posts
    392
    Thanks
    9
    Thanked 34 Times in 23 Posts

    Quote Originally Posted by LastSonOfKrypton View Post
    Good to know. I was wondering if this was an iPhone 4 issue or an iOS issue. I just haven't bothered looking into it. I'm glad I saw this thread
    iOS issue.

  8. #7
    iPhoneaholic patoons's Avatar
    Join Date
    Feb 2010
    Location
    Long Island
    Posts
    392
    Thanks
    9
    Thanked 34 Times in 23 Posts

    any word on a fix for this?

  9. #8
    Well sbsettings isn't using documented APIs by Apple so it will take sometime to figure it out but I'm sure it's being worked on as we speak. Regular airplane mode works for now

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •