Results 1 to 1 of 1

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Munmap?

  1. #1
    Default Munmap?
    So earlier today, I was downloading something from Cydia. Then all of a sudden the app crashes and my phone reboots itself.

    After it booted, I started up Cydia only to have it crash and revert back to the springboard. Having had this happen before, I searched the internet to find fixes.
    I deleted the files in as was told from another topic posted:
    /private/var/lib/apt/lists

    That didn't seem to work either because then I got some message about the /private/var/lib/dpkg/lock wasn't working because it didn't exist.
    I tried another fix for that and would up with /private/var/lib/dpkg/status wasn't working because it didn't exist.

    Once again, I tried to fix that and wound up with "couldn't make mmap of 68 bytes - mmap (22: Invalid argument).

    I can't make heads or tails of this because nobody else seems to have this problem or error. The error log of the cydia.log file from the tmp folder reads:

    2010-05-29 19:25:44.573 Cydia_[52:613] Setting Language: en
    2010-05-29 19:25:46.085 Cydia_[52:613] WB:Notice: WinterBoard
    cache_.Open():[Couldn't make mmap of 68 bytes - mmap (22: Invalid argument)]
    W:[Unable to munmap]
    E:[The package lists or status file could not be parsed or opened.]


    So am I basically ******** and have to restore or is there a fix?

    UPDATE:

    Now it just says "Could not open file /var/lib/dpkg/status - open (2: No such file or directory)"
    Packages/sources do not show up in cydia>manage either. They're blank when I choose em. I also tried to install another source but to no avail.

    UPDATE 2:

    LOL. I have no idea what I did, but the only problems now are:

    A giant red block saying "your copy of Cydia does now know what version it is, iself, running" and it goes on about redsn0w and how icy + cydia = bad

    The packages section is still blank, BUT the sources are back.
    Last edited by windalgo; 2010-05-30 at 05:05 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •