Page 1 of 8 123 ... LastLast
Results 1 to 20 of 159

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Cydia Updates

  1. #1
    Default Cydia Updates
    I installed the updates but the cydia updated failed and now my phone will power on for about 4 secs then black screens anyone having this issue also?

    The only thing the phone will do is go into recovery.

    3G 16G 3.1.2

    Last edited by Roush00; 2010-05-03 at 06:49 AM.

  2. The Following User Says Thank You to Roush00 For This Useful Post:

    wim66 (2010-05-03)

  3. #2
    same happened to me, I had to restore & re-jailbreak. Freakin hassle

  4. The Following User Says Thank You to Goldenarmz97 For This Useful Post:

    wim66 (2010-05-03)

  5. #3
    I was waiting for posts like this to pop up.
    I'll hold off the updates for now.

  6. #4
    Default update failed
    I guess luckily for me I got an error message that said it failed. Guess I will wait and see if they fix it before I try again.

  7. #5
    John don't reboot your phone.. You could get the silver apple logo then the reboot every 3-4 secs.

    I guess Rock is doing the same thing. I'm a noob still, but from my understanding the update removes two system files causing the issue? Someone correct me please if I'm wrong.

    I had to Restore/JB/Unlock and all is good now.
    Last edited by Roush00; 2010-05-03 at 05:57 PM.

  8. #6
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Austin, TX
    Thanked 1,681 Times in 1,159 Posts

    I think the servers are getting slammed so bad that it's timing out during the update process and messing things up.

  9. #7
    Maybe now but not last night when I did the update at 10:30 at night. The update install didnt time out, the firmware update failed then my phone rebooted into a reboot loop.

  10. #8
    What's Jailbreak?
    Join Date
    May 2010
    Thanked 3 Times in 1 Post
    Last Error: Failed Installation of IPhone Firmware (/sbin). Error Info: (Reading database ... 14534 files and directories currently installed.) Unpacking firmware-sbin (from .../firmware

    Same thing is happening to me... I haven't rebooted yet though so hopefully there will be a fix to override it so I don't have to restore

  11. #9
    Default Any fixes for this yet....
    I can't install most of the apps on Cydia because of this error. I hope they fix it soon. This will be my second time restoring and JB'ing since last night

  12. #10
    Default Me thinks the package is empty
    my error is
    (Reading database ... 805 files and directories currently installed.)
    Unpacking firmware-sbin (from .../firmware-sbin_0-1_iphoneos-arm.deb) ...
    cp: cannot stat `/sbin/fsck': No such file or directory
    dpkg: error processing /var/cache/apt/archives/firmware-sbin_0-1_iphoneos-arm.deb (--unpack):
    subprocess pre-installation script returned error exit status 1
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    hartpauls-iPhone:/private/var/mobile/Library/RYP/install/debs root#

    so when I look at contents of firmware-sbin_0-1_iphoneos-arm.deb

    I find

    hartpauls-iPhone:/private/var/mobile/Library/RYP/install/debs root# dpkg -c firmware-sbin_0-1_iphoneos-arm.deb
    drwxr-xr-x root/root 0 2010-03-27 05:10 ./
    drwxr-xr-x root/root 0 2010-03-27 05:10 ./usr/
    drwxr-xr-x root/root 0 2010-03-27 05:10 ./usr/sbin/
    -rw-r--r-- root/root 0 2010-03-27 05:10 ./usr/sbin/nvram
    drwxr-xr-x root/root 0 2010-03-27 05:10 ./sbin/
    -rw-r--r-- root/root 0 2010-03-27 05:10 ./sbin/fstyp_hfs
    -rw-r--r-- root/root 0 2010-03-27 05:10 ./sbin/fsck
    -rw-r--r-- root/root 0 2010-03-27 05:10 ./sbin/newfs_hfs
    -rw-r--r-- root/root 0 2010-03-27 05:10 ./sbin/mount_hfs
    -rw-r--r-- root/root 0 2010-03-27 05:10 ./sbin/mount
    -rw-r--r-- root/root 0 2010-03-27 05:10 ./sbin/fstyp
    -rw-r--r-- root/root 0 2010-03-27 05:10 ./sbin/fsck_hfs

    I think (not an expert) that this means all the files are 0 sized. Thus the install script checks via stat to find that the executables haven't been installed.

    #ls -CF /sbin
    clri* fstyp_udf* mount_cd9660* netstat* route*
    dmesg* fstyp_ufs* mount_devfs* newfs* routed*
    dump* halt@ mount_fdesc* nologin* rtsol*
    dumpfs* ifconfig* mount_kernfs* ping@ slattach*
    dynamic_pager* ip6fw* mount_null* ping6* tunefs*
    fsck_hfs* ipfw* mount_procfs* quotacheck* umount*
    fstyp_msdos* kextload* mount_synthfs* reboot*
    fstyp_ntfs* launchd* mount_union* restore*

    no fsck!

    Also can't seem to find any other source for firmware-sbin
    hartpauls-iPhone:/etc/apt/sources.list.d root# apt-cache policy firmware-sbin
    Installed: (none)
    Candidate: 0-1
    Version table:
    0-1 0
    500 Index of / tangelo-3.7/main Packages

  13. #11
    This issue is due to Rock, not to anything else. Install the update in Cydia: proof that Cydia works and Rock bricks.

  14. #12
    miPhone's better than yours GellBrake'rrrr's Avatar
    Join Date
    Feb 2009
    D-town Tejas
    Thanked 79 Times in 53 Posts

    After I updated all 4 essential upgrades, Cydia froze up for a little bit. Other than that, it's fine. Keep in mind everybody..... Cydia is getting hammered with hits around the world right now. I would wait a few days to a week if you've previously had problems. Give the attention a little time to lag.

  15. #13
    Quote Originally Posted by chpwn View Post
    This issue is due to Rock, not to anything else. Install the update in Cydia: proof that Cydia works and Rock bricks.
    It says the same thing in both when i tried to update in cydia first, then rock both gave me the same errors... so theres no "prove" that rock bricks anything.

    I hope theres an update soon though...

  16. #14
    Default how are you guys missing fsck?! :(
    Somehow, some phones seem to not come with fsck? Is that even possible? It's like something is deleting fsck from these systems... isn't fsck required to boot the device?

    This program has come with every Apple firmware since at least 2.0 (I don't have any firmware extracts from before 2.0 to check against, but those platforms aren't supported anyway).

    The goal of this package, and the reason it has a bunch of 0-sized files in it, is to allow for a strategic removal of the old diskdev-cmds package from the wild as an upgrade to a new version that no longer overwrites these core files.

    This was required in order to deploy Spirit, which needs to have an environment where no file is ever overwritten or modified for any reason at all.

    However, this has to be done in a way that does not redistribute any official files from Apple, especially as I couldn't be certain of what firmware you are using anyway.

    Ok, wait: there was a full listing of /sbin listed by someone. That folder seems to be missing a ton of stuff... it looks like all of the files that are maintained by firmware-sbin are missing...

    What happened the very very first time you ran this upgrade? Does anyone have a lot of that? Preferably a /tmp/cydia.log of such an event?

  17. The Following User Says Thank You to saurik For This Useful Post:

    chrisrotolo (2010-05-13)

  18. #15
    Since the updates I've got 40+ GSC files appeared in PkgBackup that weren't there before. Anyone know what they are?

  19. #16
    So, I've done a bunch of testing now on this, and as far as I can tell there is no failure case of this script that would cause you to lose /sbin. Even dpkg is keeping a copy of the files that are being replaced as the install is occurring (which I wish I had known, as that would be a much better way of doing the restore than using my stupid shell scripts for prerm abort-install and preinst install).

    The core problem here is that these devices are missing /sbin, and my current bet is that is because the old diskdev-cmds package was installed, and then removed. This will cause the phone to not bootup. The firmware-sbin package package will not, as far as I currently understand, cause you to lose these files, but it will fail hard on install if you are already missing them.

    In essence, these phones are already broken before firmware-sbin is being installed. The question then: where did the diskdev-cmds package go? Is it on these phones? If not, who uninstalled it? This is an "essential" package, and under no circumstances should it be removed: to do so requires a multi-phase agree, whether you are in Cydia or at the console.

    In fact, the only thing I can think of right now is that users who are missing diskdev-cmds are using an alternative package installation mechanism that is refusing to use APT, such as Rock, that is causing this by misparsing Replaces: as Conflicts: and not bothering to honor diskdev-cmds, but even that's far fetched: Rock fails at this sort of thing, but is it really that bad? I sincerely hope not.

    Quote Originally Posted by Hitone View Post
    Since the updates I've got 40+ GSC files appeared in PkgBackup that weren't there before. Anyone know what they are?
    Those are hidden capability packages that are used by other packages to do things like "I need a camera, don't let me install if the user doesn't have a camera". Obviously, they should not be appearing in something like pkgbackup, which will have to be upgraded to not show them. They are like the "firmware" package.
    Last edited by saurik; 2010-05-04 at 09:56 AM. Reason: Automerged Doublepost

  20. #17
    What's Jailbreak? steveathome's Avatar
    Join Date
    Dec 2009
    Thanked 8 Times in 7 Posts

    My iphone working well with update. Is there a problem of identification of iphone with Appsidy?

  21. #18
    OK, stupidly I tried applying the updates yesterday through Rock and now Cydia is failing when I try to properly apply the iphone Firmware upgrade through there. ("Sub-process /usr/bin/dpky returned and error code (1)" & "/var/cache/apt/archives/firmware-sbin_0.1_iphoneos-arm.deb sunppocess pre-installation script returned error exit status 1")

    However my phone is currently up and working atm so is there anyway to repair the damage that has been done and avoid a situation where I need to restore the firmware ?

  22. #19
    Same here..

    When i try to install diskdev-cmds via Cydia, the error occurs.. I seem to be able to install it via RockApp (installation completes), but when i then change to Cydia, it says it has an update for diskdev-cmds and when i try to update, it fails again..

    All startet with RockApp yesterday telling me, that there are 6 (!) updates available, which i tried to install.. Can't remember which updates that have been, but i remember that all problems started with that install procedure..

    So far, i haven't restartet my iPhone and i won't, but i'm hoping that there will be a solution for this.. No problem with doing that in the console, as long as someone has a solution and can provide it here..

    Thanks for any help!!!

  23. #20
    Default fsck missing
    Here are some screen shots...

    It looks like fsck is missing

    Anyone know how to fix this??

    I am afraid to boot my phone - in case it bricks.....
    Attached Thumbnails Attached Thumbnails -screenhunter_04-may.-04-08.38.jpg  
    Last edited by dxe; 2010-05-04 at 03:31 PM. Reason: added images

Page 1 of 8 123 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts