Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone crashing after installing apps!

  1. #1
    Default iPhone crashing after installing apps!
    Plain and simple, why does this happen? Everythime I install an app from Cydia or the App Store my iPhone crashes and I get that unhappy iPhone on my look screen. How do I fix this?

  2. #2
    I have this problem too. I think it happened after a Cydia update but I can't remember which one. I'm using A 266 Collection theme and have only the first page on the springboard with stuff on it. If it tries to install someone on the 2nd page it crashes but not if its on the first page. I've tried to reinstall iconoclasm but still crashes
    Last edited by MonsterofMen; 2010-04-22 at 03:01 AM.
    ---------------------------
    iPhone 4 32 GB
    iPod Touch 4G 32 GB

  3. #3
    I read this same issue in another thread and what's crazy this fix actually works. If you have Emoji installed go into settings/general/keyboard/Japanese and enable Emoji then Cydia should work.

  4. #4
    Thanks for the help but it didn't work. My Cydia worked but installing normal apps from the App Store instantly sent my iPhone into the sad iPhone screen and I would need to put the new app in a category folder or delete it or I wouldn't be able to restart the springboard.
    ---------------------------
    iPhone 4 32 GB
    iPod Touch 4G 32 GB

  5. #5
    My bad, disregard what I posted. That fix is for when Cydia crashes on start up. And your right it only happens when I install apps from the AppStore.

  6. #6
    hi alles klar mann.

  7. #7
    After many trails, tests and resprings and a lot of seeing safe mode I narrowed the problem down to Iconoclasm.

    It seems to occur if you have per page layouts turned on and use a different layout for pages 1 and 2 (there may be other variations on this but this is my set up that causes the problems).

    In a normal situation, if page 1 of your springboard is full and you install something new (Cydia or AppStore or Rock) or move an App out of a Category folder, or add a web bookmark (basically anything that adds a new icon!) springboard slides along to page 2 and the icon is placed there.

    It seems recently Iconoclasm is having problems with this.

    The basics:
    Any theme activate or not? IRRELEVANT > Happens either way
    Categories being used or not? IRRELEVANT > Happens either way
    Space on the current page of Springboard = Yes > No problem installing or moving icons
    Space on the current page of Springboard = No > Crash to Safe mode

    It seems Iconoclasm cannot create a new page to put any new icon onto, it crashes, then when in Safe Mode the Icon is there (or Download has started etc)
    Cannot escape Safe Mode until Icon is put into Category folder (or removed). Once or twice I have exited Safe Mode and the new icon is present on page 2 of Springboard.

    This is happening on my 3G, don't know if it's device specific or not...?

    Yanik Magnan (creator of Iconoclasm) is aware of the problem already but cannot recreate it so until he can there is no fix!

    I've sent him Crash Logs in the hope they'll be of some use but we'll have to wait and see. If they are useful to him it may be good for everyone who has had the same problem to email Yanik so that he is aware of how many people this is effecting.

  8. The Following 2 Users Say Thank You to jonny79 For This Useful Post:

    Fervid (2010-05-03), oo3 (2010-05-05)

  9. #8
    What firmware are you running? I can't remember when this problem started but it may have been after I started using 3.1.3.

  10. #9
    Default Cydia Crash
    I only started getting the same crash problems after updating to 3.1.3. I've had to restore my iPod on many occasions too while trying to put all my Cydia software back on my device. I'm guessing the Iconoclasm problem is also linked to this. Now if I do get a problem I'm installing Iconoclasm last! Many thanks for letting me know what the issue is. I've been scratching my head for a while now wondering where the problem is coming from...

  11. #10
    Default 266 collection -> safe Mode
    jonny79 is correct! After add an url link to Springboard from Safari, it respring and enter in Safe Mode.

    I remove that icon that was created via Safari and respring.
    All works again!

    Thanks jonny79 for your information.


  12. #11
    Quote Originally Posted by jonny79 View Post
    After many trails, tests and resprings and a lot of seeing safe mode I narrowed the problem down to Iconoclasm.

    It seems to occur if you have per page layouts turned on and use a different layout for pages 1 and 2 (there may be other variations on this but this is my set up that causes the problems).

    In a normal situation, if page 1 of your springboard is full and you install something new (Cydia or AppStore or Rock) or move an App out of a Category folder, or add a web bookmark (basically anything that adds a new icon!) springboard slides along to page 2 and the icon is placed there.

    It seems recently Iconoclasm is having problems with this.

    The basics:
    Any theme activate or not? IRRELEVANT > Happens either way
    Categories being used or not? IRRELEVANT > Happens either way
    Space on the current page of Springboard = Yes > No problem installing or moving icons
    Space on the current page of Springboard = No > Crash to Safe mode

    It seems Iconoclasm cannot create a new page to put any new icon onto, it crashes, then when in Safe Mode the Icon is there (or Download has started etc)
    Cannot escape Safe Mode until Icon is put into Category folder (or removed). Once or twice I have exited Safe Mode and the new icon is present on page 2 of Springboard.

    This is happening on my 3G, don't know if it's device specific or not...?

    Yanik Magnan (creator of Iconoclasm) is aware of the problem already but cannot recreate it so until he can there is no fix!

    I've sent him Crash Logs in the hope they'll be of some use but we'll have to wait and see. If they are useful to him it may be good for everyone who has had the same problem to email Yanik so that he is aware of how many people this is effecting.
    Thanks for the tip...i wish i would've read this before i decided to do a restore...I had the same exact problem as described.

  13. #12
    Before the update to the last 266 & others, all app store update create a temporary icon on 2. page and i nerver had this problem. I believe there is a bug on new iconoclasm

  14. #13
    Iconoclasm hasn't worked since I redownloaded it today..

  15. #14
    What's Jailbreak?
    Join Date
    Aug 2008
    Posts
    7
    Thanks
    0
    Thanked 2 Times in 1 Post
    Quote Originally Posted by jonny79 View Post
    After many trails, tests and resprings and a lot of seeing safe mode I narrowed the problem down to Iconoclasm.

    It seems to occur if you have per page layouts turned on and use a different layout for pages 1 and 2 (there may be other variations on this but this is my set up that causes the problems).

    In a normal situation, if page 1 of your springboard is full and you install something new (Cydia or AppStore or Rock) or move an App out of a Category folder, or add a web bookmark (basically anything that adds a new icon!) springboard slides along to page 2 and the icon is placed there.

    It seems recently Iconoclasm is having problems with this.

    The basics:
    Any theme activate or not? IRRELEVANT > Happens either way
    Categories being used or not? IRRELEVANT > Happens either way
    Space on the current page of Springboard = Yes > No problem installing or moving icons
    Space on the current page of Springboard = No > Crash to Safe mode

    It seems Iconoclasm cannot create a new page to put any new icon onto, it crashes, then when in Safe Mode the Icon is there (or Download has started etc)
    Cannot escape Safe Mode until Icon is put into Category folder (or removed). Once or twice I have exited Safe Mode and the new icon is present on page 2 of Springboard.

    This is happening on my 3G, don't know if it's device specific or not...?

    Yanik Magnan (creator of Iconoclasm) is aware of the problem already but cannot recreate it so until he can there is no fix!

    I've sent him Crash Logs in the hope they'll be of some use but we'll have to wait and see. If they are useful to him it may be good for everyone who has had the same problem to email Yanik so that he is aware of how many people this is effecting.
    I faced the same problem today.
    I get no screen so am not able to correct the problem. Somehow using WinScp for a while i was able to rename the *.Plist file i had used in /Library/Iconoclasm/Layouts

    It did reboot normally.


    But then without realizing the real problem i again used different layouts for two pages & am stuck in a re-boot loop.

    Can anyone tell me a way to just disable Iconoclasm. Using WinSCP ?

    ### EDIT
    ok.. If u want to get back to a working phone..
    Try this

    IT will help u get out of the reboot loop..

    Just go to User/Library/Preference/ and deleted com.apple.springboard.plist
    Either respring or reboot and it should get u a working phone atleast.
    Last edited by dakoo; 2010-05-11 at 07:25 PM. Reason: Automerged Doublepost Corrected

  16. #15
    Same problem here and with a friend. I was having the issue with using spirit that anytime I added a new icon weather or not there were icons on the second page I was getting safe mode. I decided to go back to 3.1.2 with blackrain and only have a boot loop issue when installing a new icon if I only have one page that's full. I was able to get out of th boot loop by waiting fir the spinning wheel with the apple boot logo sshing into the phone and removing the newly added application. Once I deleted the app folder my phone instantly booted all the way.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •