Page 1 of 4 123 ... LastLast
Results 1 to 20 of 70

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Cydia error: Database

  1. #1
    Exclamation Cydia error: Database
    I have a 3GS with 3.0 FW. Have been using it for a month now with no issues. Then suddenly today I started Cydia and it gave me this Error: Database. Encountered a section with no Package: header.
    After okaying that error another popup opens giving a list of sources that it was unable to fetch. I tried for a couple of hours and every time the list of error sources seem random.
    After all this my cydia shows blank with no sources, packages, changes etc.
    Any help guys. pls.

  2. The Following 2 Users Say Thank You to saifeeab For This Useful Post:

    E-BNR32 (2010-12-02), tudtran (2009-11-23)

  3. #2
    What's Jailbreak?
    Join Date
    Dec 2007
    Location
    Kuwait
    Posts
    3
    Thanks
    1
    Thanked 2 Times in 1 Post
    Hi, I have a 3G with 3.0 FW, i have been using cydia for quite some time, today i had opened to download an app, it said there were some updates & i updated it, since after that i keep getting Warning: database, duplicate sources.list entry ultrasn0w.com ./ packages (/var/lib/apt/lists/repo666.ultrasn0w.com_._Packages) the next error i get is .. Error: database encountred a section with no Package: header

  4. The Following 2 Users Say Thank You to abbas_aj For This Useful Post:

    ai1973 (2009-11-22), callum_88 (2010-01-04)

  5. #3
    I Also noticed that a couple hours ago on my 3G
    I push home botton and reluached Cydia
    and work just fine ( Maybe they R UpGradeing or UpDateing SomeThing )
    Sign by Danasoft - Get Your Free Sign

    The Family iPhone 2G , iPhone 3G ,Iphone 3Gs , Iphone 4
    13" MacBook ( Black )



  6. #4
    The problem fixed itself 24hrs later. Wish I knew what the problem was

  7. #5
    my phone has been doing this for 2 days...
    still nothing works
    no packgs or sources showing up..

  8. #6
    Quote Originally Posted by lakerzfan27 View Post
    my phone has been doing this for 2 days...
    still nothing works
    no packgs or sources showing up..
    Hi, i had this very same problem for nearly a week, i was advised by another poster on here, i cant remember his name now....

    But here is what he advised. SSH into your device. go to private/var/lib/apt/lists, And delete everything apart from the "Partial" folder, open cydia select changes and then refresh, you should be good to go, it will still give you errors, but at least you will be able to load everything.

    Hope this helps?

    Cheers

  9. The Following 12 Users Say Thank You to iMister For This Useful Post:

    ai1973 (2009-11-22), corkey20000 (2010-03-06), DuBCaDiLLaC (2009-11-21), eeetripl (2010-01-13), gobosox (2009-12-27), lakerzfan27 (2009-09-26), mathew00181 (2009-12-24), rd8719 (2009-12-13), saifeeab (2009-09-26), Shaker Baig (2010-01-20), Tams420 (2010-02-09), yusuf530i (2009-12-09)

  10. #7
    I am having the same problems and i am cracking up with it, how easy is that ssh thing? and wat do i need to do
    Last edited by david.celica; 2009-09-25 at 09:26 PM.

  11. #8
    i did what iMister said and it worked. this problem was just never seen by me before so i never thought of doing that, but whenever your cydia has a problem simply clear private/var/lib/apt/lists except for the partial folder

  12. #9
    What's Jailbreak? andythai's Avatar
    Join Date
    Oct 2009
    Location
    Cyprus
    Posts
    4
    Thanks
    0
    Thanked 1 Time in 1 Post
    had exactly the same problem. out of nowhere cydia packages just dissapeared. i ssh'd and deleted the files in 'private/var/lib/apt/lists'
    and that was it. cydia working fine again. i was so frustrated that i was ready to restore and jailbreak again..thanks alot guys,great help...andy.

  13. The Following User Says Thank You to andythai For This Useful Post:

    ai1973 (2009-11-22)

  14. #10
    I went into SSH and deleted everything in this folder private/var/lib/apt/lists except for the partial folder and I am still not showing any of the packages, sources that I have downloaded before. Apparently everything is still working on my iPhone (e.g.winterboard, catagories, etc) But I can't get any updates just error messages. Can someone help please?

  15. The Following User Says Thank You to pondrboi For This Useful Post:

    ai1973 (2009-11-22)

  16. #11
    I have tried the method that is suggested above and I am still getting the database error. Please help, I am totally frustrated!

  17. #12
    iPhone? More like MyPhone duceduc's Avatar
    Join Date
    Sep 2007
    Location
    Saitama, Japan
    Posts
    249
    Thanks
    2
    Thanked 10 Times in 9 Posts

    I am getting that error too after the last cydia update. It comes and goes. Figure it is a glitch with their server or something. I will try to delete the list in the lists folder as suggested.

  18. #13
    Quote Originally Posted by iMister View Post
    Hi, i had this very same problem for nearly a week, i was advised by another poster on here, i cant remember his name now....

    But here is what he advised. SSH into your device. go to private/var/lib/apt/lists, And delete everything apart from the "Partial" folder, open cydia select changes and then refresh, you should be good to go, it will still give you errors, but at least you will be able to load everything.

    Hope this helps?

    Cheers
    it wont let me into ssh.it says it is not found !!! what can i do to get all my sources back i have a iphone 3g 3.1

  19. #14
    i fixed the porblem,
    just go to /private/var/lib/apt/lists and delete the files which files name include "modmyi" string,

    you can try....

  20. #15
    has malespider's method worked for anyone else? i have tried the other method listed here but that has not solved the problem. I have a 3GS and a 2G and both seem to be having the same problem. Keep getting error message "Unable to fetch new package http://xxxxxxxxx"..something like that. Everytime the message keeps changing with different sources.

  21. #16
    iPhone? More like MyPhone duceduc's Avatar
    Join Date
    Sep 2007
    Location
    Saitama, Japan
    Posts
    249
    Thanks
    2
    Thanked 10 Times in 9 Posts

    It's not working for me on a 3G phone.

  22. #17
    Default still not working...
    Hi guys. i just got my phone recently and i have the same error..

    but i also have "Duplicate sources.list entry http://repo666.ultrasn0w.com/packages (/var/lib/at/lists/repo666.ultrasn0w.com_._pakages)

    im not sure exactly how ssh works but from what i read on the internet i have to download "openssh" first right? but i cant search that on cydia.. it comes up as blank. what do i do next?
    Last edited by taibo5o3; 2009-10-13 at 04:18 AM.

  23. #18
    I deleted all the files w/the strand named modmyi.com and still cydia is not showing any packages. Any other suggestions? I don't want to re-jailbreak my phone and lose all the cydia programs I've installed.

  24. #19
    iPhone? More like MyPhone duceduc's Avatar
    Join Date
    Sep 2007
    Location
    Saitama, Japan
    Posts
    249
    Thanks
    2
    Thanked 10 Times in 9 Posts

    Quote Originally Posted by taibo5o3 View Post
    Hi guys. i just got my phone recently and i have the same error..

    but i also have "Duplicate sources.list entry http://repo666.ultrasn0w.com/packages (/var/lib/at/lists/repo666.ultrasn0w.com_._pakages)

    im not sure exactly how ssh works but from what i read on the internet i have to download "openssh" first right? but i cant search that on cydia.. it comes up as blank. what do i do next?
    I had that same issue before with the duplicate repo. I have tried to get rid of the message but failed. You may need to restore and start over.

  25. #20
    I actually fixed my problem by ssh'ing into /private/etc/apt/sources.list.d and deleting cydia.list, after deleting that file start Cydia back up and you should have to upgrade you cydia again, allowing you to see everything again. Only downside, at least for me, is that any source you manually entered, will have to be entered again. Hopes this helps...
    -------------------------------------------------------------------------------------

    Actually after loading my first source all my sources were restored.
    Last edited by LK Th3Myth; 2009-11-10 at 04:51 AM.
    Apple iPhone 3Gs: redsn0w 4.1 (8B117)
    Modem FW: 5.13.04 Unlocked: Ultrasn0w
    Preferred Apps: Cydia, Winterboard, 1nstall0us, Orbit, and SBSettings
    Don't Start None, Won't Be None. Get On... Before Ya Get Spit On


  26. The Following User Says Thank You to LK Th3Myth For This Useful Post:

    Davepr4 (2010-02-12)

Page 1 of 4 123 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •