Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 70

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Cydia error: Database

  1. #21
    Quote Originally Posted by andythai View Post
    had exactly the same problem. out of nowhere cydia packages just dissapeared. i ssh'd and deleted the files in 'private/var/lib/apt/lists'
    and that was it. cydia working fine again. i was so frustrated that i was ready to restore and jailbreak again..thanks alot guys,great help...andy.
    Thanks for this suggestion.
    I somehow couldnt SSH into my iphone (windows or mac just wouldnt work). I tried using blackrain to jailbreak again and re-install cydia to no success.
    Finally, I used mobile terminal and painstakingly deleted all files except Partial, re-booted phone and it worked. Only thing is that while all my sources (including those entered manually) were there, all packages i had installed failed to appear in the list under "installed" but I know they're still on the phone as the utilities still work for eg SB Settings.

    Just for info, you need to go into Mobile Terminal, type su and enter your password (default is alpine but I suggest you change it using passwd root command).
    after that,
    type cd /private/var/lib/apt/lists
    type dir (to see what's in the directory)
    type rm name files to be deleted here (for eg rm www.sinfuliphonerepo.com_._Release)
    remove everything except Partial, reboot phone and it should load again after doing an upgrade within Cydia (you will be prompted).

    Hope this helps someone else.

  2. #22
    What's Jailbreak? sqr47`'s Avatar
    Join Date
    Nov 2009
    Location
    New York
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts

    i have the same error, ive seen the patial fix on three other sources and amgoing to try it if all else fails

  3. #23
    Does anyone have any ideas for how i can access this folder and delete the files that are causing these problems?

    I did not install OpenSSH before this problem happened so I cannot SSH into my phone. Also, I'm running 3.1.2 so IphoneBrowser freezes when I run it and iPhone Explorer doesn't see that my iPhone is jailbroken! So far I have no ideas how to get into that folder and delete the offending file(s)!

    Any advice would be greatly appreciated!

  4. #24
    What's Jailbreak? sqr47`'s Avatar
    Join Date
    Nov 2009
    Location
    New York
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts

    youll probably have to restore, and iphone browser works on 3.1.2 if you have "afc2add" from cydia. But youll dfinitly have to restore, especially if you dont have rock installed either. When you rejailbreak, you should probably add it, i know some people say bad things about it but it really is great and it is much cleaner than cydia, although it is a little buggy

  5. #25
    man this is a headache i'm stucked with this cydia doesn't work same error message keeps coming up how can i fix this someone help PLEASE i'm gonna die before christmas if this keeps happening

    Quote Originally Posted by DMI187 View Post
    I Also noticed that a couple hours ago on my 3G
    I push home botton and reluached Cydia
    and work just fine ( Maybe they R UpGradeing or UpDateing SomeThing )
    i'm a sri lanakn and i have the same problem dude can u tell me how to fix this i'm araid to jailbreak and upgrade it to the FW 3.0 coz there's no good sftware for that please help
    Last edited by samcro; 2009-12-03 at 04:42 PM. Reason: Automerged Doublepost

  6. #26
    I know exactly what you mean. I was on my laptop for 2 days trying to figure what the hell to do. My last resort was to restore the phone and jailbreak/unlock it for the 5th time. Each time I do I've gotten better at it. Anyways, back to the subject at hand.

    I downloaded iphone explorer: iPhone Explorer - A USB iPhone browser for Mac and PC . I am not computer savvy by any means but was able to figure out what to do. For me, I deleted any file that has a "modmyi" and it did the trick. Ironically, aren't we posting a fix on a blog that got me in this mess the first place! That was a WTF moment for me....

  7. #27
    there was no Folder called modmyi btw explorer is good but the point is Cydia Is not working

  8. #28
    Im on an iPhone with 3.1.2 and I'm having almost the same exact issue.

    I added a source called apt.ripdev.com today hoping to get Icy then began having problems.


    I got an error that said:
    "Error: Database
    Encountered a section with no Package: header"

    Then when i returned to Cydia, all of my sources were gone.

    I would REALLY like to know how to fix this..

  9. #29
    Default Hay I Fixed this issue!
    I did a littly crafty trick usind icy and it took me two mins to fix the same issue you are all having, go into icy and look at installed packages, anyting with iaccess or i-access remove and then go into cydia! Job done, I hope this helps you all and i speciffically registered for this forum for this one post! Hope it was worth the effort!

  10. #30
    What's Jailbreak?
    Join Date
    Jan 2008
    Location
    Trinidad and Tobago
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hey guys. Listen up. My problem was that Cydia said Error: Database. Encountered a section with no Package: header. What i did is went into my Phone with a program I had previously installed called iFile and went to the var/lib/apt/lists folder and remove everything except the Partial folder, rebooted my iPhone and it loaded back up and now my Cydia is working without any errors!

  11. #31
    Default cydia database error
    I have iphone 3gs and i am having the same problem with the database error.

  12. #32
    this worked 4 me, and get no errors what so ever. thanks

  13. #33
    ******************************i fixed the porblem,
    just go to /private/var/lib/apt/lists and delete the files which files name include "modmyi" string,

    you can try....****************************

    The Above Solution Helped Me, I SSH'd and went to the folder /lists and deleted 3-5 strings with apt.modmyi in it. Resprung my iPhone, loaded Cydia, and error "error database Encountered a section with no Package: header" went away.

  14. #34
    This is the error I get when I load Cydia. I hit Okay and it works just fine and I can download whatever its just the same error for weeks now.

    GPG error:
    http://apt9.yellowsn0w.com ./
    Release: The following signatures were invalid: NODATA 1 NOTDATA 2

    Failed to fetch
    http://apt9.yellowsn0w.com/./Packages.bz2 Sub-process bzip2 returned an error (2)

    Failed to fetch
    http://apt.modmyi.com/dists/stable/m...s-arm/Packages Has Sum mismatch

    Some index files failed to download, they have been ignored, or old ones used instead.

  15. #35
    Default this worked for me...
    so it was kind of an accident but...
    i misread the earlier posts and deleted everything inside the partial folder, then deleted everything outside of it in the lists folder.

    not one error message and i still have everything.
    seems to be running faster too.

    just thought id share.

  16. #36
    This worked great. Thanks!

  17. #37
    Default cydia not functioning
    Quote Originally Posted by mathew00181 View Post
    this worked 4 me, and get no errors what so ever. thanks
    since cydia is not working I can not download openssh.

    How do I download the program openssh into the iphone?

  18. #38
    hopefully you have downloaded sbsettings and then you could turn on SSH there...

  19. #39
    no i did not load nothing.
    I did not even started to use cydia when i noticed the error message.
    thanks for any help
    oded

    no i did not download anything yet.
    Last edited by Oded_s; 2009-12-27 at 09:31 PM. Reason: Automerged Doublepost

  20. #40
    What's Jailbreak?
    Join Date
    Dec 2009
    Posts
    1
    Thanks
    0
    Thanked 2 Times in 1 Post
    Default iFunBox
    Use iFunBox http://i-funbox.com/, which is a file browser. This app will allow you to explore your iPhone or Touch in windows.

    TimeFreedom

    I second this solution. Worked like a charm. I used iFunBox to access the files on my iPod Touch and deleted the cydia.list file and all is well.

    TimeFreedom

    Quote Originally Posted by LK Th3Myth View Post
    I actually fixed my problem by ssh'ing into /private/etc/apt/sources.list.d and deleting cydia.list, after deleting that file start Cydia back up and you should have to upgrade you cydia again, allowing you to see everything again. Only downside, at least for me, is that any source you manually entered, will have to be entered again. Hopes this helps...
    -------------------------------------------------------------------------------------

    Actually after loading my first source all my sources were restored.
    Last edited by TimeFreedom; 2009-12-29 at 07:53 PM. Reason: Automerged Doublepost

  21. The Following 2 Users Say Thank You to TimeFreedom For This Useful Post:

    mynameisjordan (2010-01-06), vwdice711 (2010-05-17)

Page 2 of 4 FirstFirst 1234 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •