Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: no cydia icon after unlock with Cydia option selected

  1. #1
    Default no cydia icon after unlock with Cydia option selected
    So seems i'm doing something wrong in unlocking my 2g.

    Downloaded the OS3 ipsw file from the link in the unlock thread here and grabbed the redsn0w 0.7.1 file also.

    Restored my phone thru itunes using the ipsw file.

    Unzipped redsn0w and ran thru fine exactly how the thread shows it would, only issue i have is there's no Cydia icon.

    Tried the latest redsn0w (0.7.2) but that again gives me no cydia.

    Anyone else had any issues with not being able to see the Cydia icon after unlocking? Tried it three times now with no success, really dont want to be stuck with a standard iphone for any longer than need be...

  2. #2
    Same with me...Anyone know what I'm doing wrong?

  3. #3
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    try rebooting, if that doesn't work may have a corrupt file, happens sometimes. You may have to start all over with a fresh 3.0 restore and J/B again.

  4. #4
    thanks for the suggestions guys, was back on trying to solve the problem from 08:00 this morning. Glad to say problem is now solved.

    Here's how I managed it;

    After downloading various custom firmwares from piratebay and trying to restore to those with no success (various unknown errors occurring) I thought maybe I need to restore back to 2.1.2. Downloaded this firmware but could restore, again unknown error.

    Thought ok, maybe as blkcadi said the 3.0 firmware I got yesterday was corrupt in some way. Best bet was to download direct from Apple thru itunes. Plugged in iphone, clicked update/restore which started itunes download the OS.3 update. Let itunes do its stuff and update to OS.3 (which it had managed yesterday so still I didnt know if I was getting anywhere).

    Then download redsnow 0.7.2 from piratebay [link] and also downloaded replacement bootloaders from this thread (thanks Zwayne) just to eliminate the chance my originals were corrupt.

    Unzipped and loaded redsn0w. Select the OS.3 firmware that Itunes had downloaded earlier (for reference itunes keeps the OS.3 firmware here; "C%Userprofile%\Application Data\Apple Computer\iTunes\iPhone Software Updates"). Selected the 'unlock' & 'cydia' options and pointed redsn0w to the bootloaders.

    One thing I did different was I also held onto the home button for the full 30 seconds (previously i'd let go after the redsn0w changed which was normally about 10-12seconds after release power button) - perhaps this affects things.

    Let it run thru and noticed the pineapple pwnage image which I hadnt seen before so thought "hey i'm getting somewhere". Redsn0w completed and hey I now have a Cydia icon on my 2nd page. Result.

    Thanks again for peoples suggestions, to the other who have the same problem as me I suggest following my instructions to the letter.

  5. #5
    Been following your problem Andy from the other thread since i was having the same problem with my iphone 3g, ad even tried your latest method from this thread and it didn't work for me (without using the bootloader since my phone is factory unlocked)

    anyway i just gpt results after hours and ours of tinkering, so i thought i post what i did to save other people the headache.

    after a dozen failed attempts i changed three things in the way i was jailbreaking and i'm not sure which one fixed my problem so here it is:

    1- downloaded a new .ipsw file from this guide

    iClarified - iPhone - How to Jailbreak Your iPhone on OS 3.0 Using RedSn0w (Windows)

    (i used the itunes one before)

    2- disabled my nod32 firewall and antivirus (don't ask why my iphone is finally jailbroken)

    3- ran redsn0w with xp sp2 compatibility

    hope that helps anyone having the same problem.

  6. #6
    I'm betting that the versions of ipsw files were all good and that the things you changed had almost nothing to do with it. As I've seen on lots of FW restores, both with the iPhone and others, sometimes everything doesn't take. I've been having the same problem: no Cydia, though if you check through iPhone browser or another prog, it's there. I can't delete it because I'd have to remove about 30 other apps that are dependent on Cydia. Because you each tried different changes it seems that nothing can be identified as what made the difference, probably meaning it was nothing besides retrying the install. Maybe I'm wrong but that seems the best bet.

    Yep. All I did was try again and it worked. I did make sure that I held down the home key for the full 30 seconds, but that was all, so maybe there is something to that being the cure.

    I used the 3.0 ispw file from Apple both times. I did go back and completely update with iTunes restore before re redsn0wing it again. Now I have Cydia and Icy. Thanks for the hint on the home button, maybe that did it. Someone else want to confirm?
    Last edited by thehumble1; 2009-07-08 at 04:22 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •