Page 1 of 2 12 LastLast
Results 1 to 20 of 30

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: URGENT: cydia problem

  1. #1
    Default URGENT: cydia problem
    hi there,
    i have just jailbroke to 3.0 but now the most valuable part of jailbreaking - cydia is not working for me. everytime i try to download anything from cydia i get this error:

    "couldn't configure pre-depend dpkg for grep, probably a dependency cycle"

    do you have any solutions for me?
    thanks

  2. #2
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    have you re-booted your phone?

  3. #3
    Livin the iPhone Life
    Join Date
    Dec 2007
    Location
    Boston, MA
    Posts
    1,033
    Thanks
    16
    Thanked 143 Times in 138 Posts

    check and make sure your cydia is at the newest version 1.0.2938-56

  4. #4
    well i jailbroke it again with redsn0w. didn't work again. so instead of using redsn0w 7.2 i used 7.1 and now its working. must have something to do with 7.2

  5. #5
    Same problem. It worked fine with PwnageTool but I can't seem to get the latest version of Cydia when jailbroken via redsn0w.

  6. #6
    I have the same problem. I installed the latest update from apple through iTunes, then I activated my phone. I installed and ran redsn0w 7.2 and installed Cydia and Icy. the first thing i tried doing was to update Cydia, but it gave me the above error, though trying to update each package individually gave me the error with either sed or grep. i had jailbroken just before that with redsn0w 7.1 and it worked fine over wifi, but i had to redo the jailbreak because i forgot to activate my phone before jailbreaking it. Anyone have any clues on this?

  7. #7
    I have same issue, I did re-boot iphone though. It looks like cydia is about download packges (complete,essential upgrades) but at the end it gives same message..

    Quote Originally Posted by jtesnani View Post
    check and make sure your cydia is at the newest version 1.0.2938-56
    I have cydia in redsnow 7.2, it came out few days ago and it has cydia.

  8. #8
    Lightbulb Figured it out!
    KK, to resolve the issue, just re-restore the iPhone to 3.0 again, and jailbreak it with redsn0w 7.1. I'm not sure if its Icy or just 7.2, but 7.1 worked smoothly for me and all my apps work fine without crashing. Safari is also MUCH smoother when using 7.1. I'd stick with this version until a new one comes out, possibly in a day or two. (and imo, Icy sucks because the repos all use older versions than what are available with Cydia)

    Hope this helps!

  9. #9
    Hey guys, i had the same problem, no need to restore again just apply 7.1 redsn0w again and it workd great for me

    hope this helps
    cheers

  10. The Following User Says Thank You to aharen For This Useful Post:

    chocol8_lvr (2009-06-22)

  11. #10
    zshift,aharen, thanks guys both of methods works

  12. #11
    Quote Originally Posted by aharen View Post
    Hey guys, i had the same problem, no need to restore again just apply 7.1 redsn0w again and it workd great for me

    hope this helps
    cheers
    THANK YOU!!!!!!

    I managed to get most things to work by going to ICY to install sed and grep, then returning to Cydia to upgrade sed and grep to the latest versions first. Then, I was able to install the essential updates in Cydia manually, except for Cydia itself. I tried toupgrade Cydia in ICY, but they have an old version (and old versions of everything else too WTF?) and I just ended up with a working iphone with a hosed Cydia.

    I uninstalled Cydia via ICY and did a re-jailbreak with 0.71 and I got a semi working old Cydia that was good enough to upgrade itself. Best part was not having to restore and resync again!

    Hope they come out with a redsn0w 0.73 that includes the 2938-56 version of Cydia from the get go.

    Also what is up with ICY not seeing new versions of packages? Doesn't it point to the same package sources as Cydia? Everything I use and need had older versions on ICY, SBSettings, Mobile Substrate, Winterboard, Cydia, etc. It seems anything that has been updated since 3.0 released if not earlier is still an old version even after you refresh the sources.

  13. #12
    same problem...
    reapply redsnow 0.72 (without icy) and without restore
    all working well

  14. #13
    That is interesting, so reapplying 0.72 solves the problem which seems to be caused by using 0.72 for the original JB?

  15. #14
    yes work for me

  16. #15
    Default Similar yet maybe different
    I jailbroke my 3G yesterday with redsn0w 7.1. Was working fine Cydia needed to do 2 updates the first time I opened it.

    Then this morning, SBSettings wanted to update to 3.0 (was 2.99-? yesterday, working ok). After updating SBSettings and rebooting, now Cydia always crashes during its "loading" process and it seems to vary actually when it crashes. Maybe right away and maybe 5-10 secs into loading.

    I reloaded redsn0w 7.1 and Cydia operated the same way. I loaded redsn0w 7.2 without icy and Cydia is still doing the same thing.
    I would try removing SBSettings, but can't without Cydia.

    Any help, please?

  17. #16
    i think you need to restore your ipod, then rejaklbreak with 0.72

  18. #17
    All right I'm having the same problem. I have a 1st gen iPhone. I jailbroke it and installed cydia and ICY via redsn0w 7.2 because I have a Mac. I can't find redsn0w 7.1 for mac so that doesn't help me.

    My problem is I get an error that reads
    "couldn't configure pre-depend dpkg for ncruses, probably a dependency cycle"

    Since I can't update cydia I can't install winterboard or SBsettings its a bummer.

    Also does anyone know if I can just put iPod firmware on my 1st gen iPhone, I have a 3G so I just use my 1st gen as an iPod touch and I would rather have the touch 2g 3.0 firmware on it... Just wondering

  19. #18
    You can use redsnow 72 to install icy. Then use icy to remove SBSeettings. You can also use icy to remove Cydia and redsnow to add it back.
    Last edited by chocol8_lvr; 2009-06-22 at 09:41 PM.

  20. #19
    I can't install SBsettings at all.

    I tried removing cydia with ICY and then reinstalling it with ICY and it just crashes as soon as I start to run cydia.

    I also tried to just install Cycorder with ICY and when I opening it my screen goes black for a sec then just back to springboard?

    Guess I'll just force restore and then try running redsn0w 0.72 again?

  21. #20
    I wish I could help you as I have been having the same problems and have tried redsnow over and over but cydia just keeps crashing. After an extremely long waiting process I managed to get some apps, using icy, which has been working best for me (but still not very well). Then my whole phone froze when I tried to run an app and I had to do a DFU restore. No idea what to do anymore but I dont think I will bother until things are fixed so I dont waste my entire life away lol.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •