Results 1 to 1 of 1

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Not all packages are shown

  1. #1
    Default Not all packages are shown
    I've just jailbroken, and gone into Cydia to look for Kexan's analogue battery gauge ( Apple Forums | ModMyi.com | iPhone, iPod, Mac, OS X, Mods, More - Downloads - analogue Battery Gauge )

    I've checked my sources and I have:

    http://apt.modmyi.com/
    as well as
    http://modmyi.com/repo/dists/stable/...-iphoneos-arm/

    in there.

    As far as I can tell it's the following package:
    Package: com.modmyi.analogue
    Version: 2.1
    Section: Themes (Battery)
    Maintainer: Christian Ytterstrom <[email protected]>
    Depiction: http://modmyi.com/info/analogue.d.php
    Homepage: http://modmyi.com/info/analogue.php
    Architecture: iphoneos-arm
    Filename: 2debs/analogue2.1.deb
    Size: 883398
    MD5sum: d189995215f3d39395a2a0ac1ff32dea
    Name: Analogue
    Sponsor: modmyi.com <http://modmyi.com>
    Description: An analogue battery indicator by Kexan.

    If I SSH into the phone and grep analog * from /private/var/lib/apt/lists/ it finds the package in both repository files!

    The file is also in the repository at http://modmyi.com/repo/2debs/

    But if I just browse the repositories using Cydia, or if I search for analog using Cydia, it comes up empty!

    Where is this package? I'm also missing loads more packages, where are they?!

    OK, so if you go to

    /private/var/lib/apt/lists/

    and then

    vi apt.modmyi.com_dists_stable_main_binary-iphoneos-arm_Packages

    find the package and change:

    Package: com.modmyifone.analogue
    Version: 2.1
    Section: Themes (Battery)

    to

    Package: analogue
    Version: 2.1
    Section: Themes

    Then Cydia will find it, but give an error message after install. But will work.

    This can't be the 'correct' way of doing it though - how do I get this package (and all the other battery indicators and other packages) to show up properly in Cydia?

    OK after restoring and re-jailbreaking and re-installing cydia, I discovered when you start cydia it asks you what level user you are and if you choose anything but 'developer' you don't get these packages.
    Last edited by dagon; 2008-09-24 at 04:10 PM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •