Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Cydia Crashes after Permission Change

  1. #1
    Default Cydia Crashes after Permission Change
    Hi, Was wondering if someone could tell me what the permissions are supposed to be for Cydia and it's enclosed folders. I placed an app inside my phone and changed all permissions in APP folder to 777. Now Cydia crashes to Springboard when launched. How can I fix this?

    Thanks

  2. #2
    ahhh, i'm having the same problem, please help!

  3. #3
    iPhoneaholic kwall's Avatar
    Join Date
    May 2008
    Location
    New York
    Posts
    308
    Thanks
    7
    Thanked 40 Times in 32 Posts

    If you have OpenSSH installed, SSH into your iPod/iPhone and run the terminal. Run the command "apt-get remove Cydia" (Confirm any and all Prompts). Next run the command "apt-get install Cydia" Afterwards Cydia should be re-installed good as new.

    The commands are listed within the quotes but do not enter the quotes.
    Last edited by kwall; 2008-10-11 at 01:31 PM.

  4. #4
    That is incorrect. If you are running the commands through SSH, you just type:

    apt-get remove cydia (lowercase)

    Yes, do as I say!


    apt-get install cydia (lowercase)


    If you have terminal on your iPod, type in:

    su

    alpine

    apt-get remove cydia
    (lowercase)

    Yes, do as I say!

    apt-get install cydia
    (lowercase)

  5. #5
    If Cydia was working fine, but is now crashing in the first few seconds of loading do this:

    Delete the contents of the /var/lib/apt/lists folder (except for the folder called “partial”) through SSH.

    How to do that:

    If you’re comfortable using a command line terminal you can do that.. But most people aren’t (including me) so do this instead:

    1. Turn SSH and Wi-Fi on in your iphone (can do this through toggles in Bossprefs, SBSettings etc If you don’t see the option for SSH in these or your similar toggling program, then you need to install SSH on your phone. OpenSSH is a good one that you can find in Installer. If it still isn’t showing up or working then you need to also install BSD Subsystem via Installer.
    2. Open the SSH program of your choice on your computer (for mac I like Cyberduck – Fugu is another but it’s a little sketchy sometimes. For PC, try WinSCP or try searching the google)
    3. Get the Wi-Fi IP address of your phone. You can find this through SBSettings, or other IP displaying app.. Should be something like: 192.168.3.8 (your numbers will be slightly different) and not: 77.76.23.2- You can also find the IP address of your phone the way Apple intended by opening the Settings app on your phone, selecting Wi-Fi, and pressing the little blue arrow at the right of your current network’s name – the first one listed is IP Address, that’s what you want. Or you can log in to your router through a browser and find it through the DHCP network list. Not going to go into how to do that now – search for how to do that for your specific router on the internet if you’re curious.
    4. Enter the Wi-Fi IP address of your phone in the SSH program and use the username: root and the password: alpine to connect to it (if you changed the username and password.. you would know, but those are the defaults.)
    5. Find the folder /var/lib/apt/lists (may have to backtrack to the var folder – default log-in isn’t always the root folder where var is)
    6. I opted to back up all of the files I was deleting simply by dragging them to a folder on the desktop – you don’t have to, but having a way to undo stuff is usually a good option to have.
    7. Delete all of the files except for the partial folder
    8. Disconnect the SSH connection in your program
    9. Open Cydia and download horrible all-pink themes for Winterboard

    Why did that happen:

    Some repositories were corrupted or broken – it’s not your fault. Personally, this happened immedietely after I locked the program with the app “lockdown” which adds a file to this exact folder. So, after confirming that Cydia worked again, I tried locking it again, restarting, turning on and off different lock types – and cydia worked fine. I also hid the icon with bossprefs – Checked to see if this was the culprit and it was not. So far I haven’t had any trouble using lockdown or hiding icons through bossprefs or SBSettings. Seems this happened just because of a few bad repositories.

    If deleting the contents of the lists folder does not fix the problem you can also try deleting the contents of the /var/lib/dpkg/updates/ folder.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •