Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Activation (sutck on emergency calls)

  1. #1
    Default Activation (sutck on emergency calls)
    So, as I said here: http://modmyi.com/forums/3g-s-downgr...ml#post5167259 :

    I have a 3GS that came stock with:

    iPhone: 3GS
    Firmware:3.1.2 (currently using Fake 3.1.3 for an app)
    Baseband: 5.11.07
    iBoot: 359.3

    I was able to jailbreak(no tether) w00t.
    I wanted to restore, to get rid of lingering files from a TON of uninstalls and/or bad installs..etc.. And set it up the way I liked.

    I was able to restore to a custom 3.1.2. However, as I mentioned in that thread, I would get stuck at any activations.

    Right now its working fine EXCEPT; i had to hacktivate it, and unlock it. This causes push to not work. I had to use Push Doctor to fix that. A YouTube fix also.

    I'm on ATT and don't plan on leaving.
    Does anyone know what/where I went wrong with the activation process?

    I have latest iTunes64 on a Win7 64.
    After the first few Restores; I would get iTunes error stating it couldn't read my iPhone. And recommend doing a restore.

    After another, I would get an error about not being able to read the SIM (maybe a SIM PIN - not the case).

    After I hacktivate/unlocked it, I got that couldn't read my iphone error a couple of times. Forgot what I did (i think i had done some 3G testing). plugged it back in, and it worked.

    So thats why I just stuck with it.


    I'd like to be "official" and not have to hacktivate ..etc.. just to get my phone working on the official carrier. I'd also like to NOT Restore to 3.1.3(stock) and lose untethered jailbreak.

  2. #2
    Retired Moderator Cer0's Avatar
    Join Date
    Apr 2008
    Location
    MN/WI
    Posts
    14,099
    Thanks
    395
    Thanked 1,182 Times in 915 Posts

    When using a custom firmware did you leave activation unchecked? Since you are on a legit carrier then you shouldn't need hacktivation or unlock.
    [CENTER][SIGPIC][/SIGPIC][/CENTER]

  3. #3
    The first time, I didn't know I didn't need it (pretty much used default settings).

    But after a few tries and realizations, I had made a custom firmware with;

    Activate *NOT* selected
    Unlock *NOT* selected
    nothing else other than Cydia.

    With this combo. I was stuck in the Emergency Call screen. and iTunes would give me an error about not being able to read my iphone and offer to restore it. Or something about my SIM (the SIM worked fine in another phone, and is working fine now - hacktivated/unlocked iPhone)
    Last edited by ydgmms; 2010-03-23 at 06:42 AM.

  4. #4
    Retired Moderator Cer0's Avatar
    Join Date
    Apr 2008
    Location
    MN/WI
    Posts
    14,099
    Thanks
    395
    Thanked 1,182 Times in 915 Posts

    Possibly a bad ATT sim card. Not sure.
    [CENTER][SIGPIC][/SIGPIC][/CENTER]

  5. #5
    i'm using it now though?
    I can use ANY ATT Sim to activate though, right? and then put mine in?

    because i do have access to two more.

  6. #6
    Retired Moderator Cer0's Avatar
    Join Date
    Apr 2008
    Location
    MN/WI
    Posts
    14,099
    Thanks
    395
    Thanked 1,182 Times in 915 Posts

    You could try and see if that lets you. That way you get push and everything working as normal without extra stuff.
    [CENTER][SIGPIC][/SIGPIC][/CENTER]

  7. #7
    i read there were some issues with using Windows 7(64bit), is there any thing to that?

    I dont have a mac or a non win7 pc in my house now.
    I can virtualbox something if i need to?

  8. #8
    Retired Moderator Cer0's Avatar
    Join Date
    Apr 2008
    Location
    MN/WI
    Posts
    14,099
    Thanks
    395
    Thanked 1,182 Times in 915 Posts

    Not sure on that one. An OSX user here. Did you build it in compatibility mode?
    [CENTER][SIGPIC][/SIGPIC][/CENTER]

  9. #9
    no. used sn0wbreeze to build custom firmware *not* in compatibilty mode. used lastest itunes64 to restore.

  10. #10

  11. #11
    Retired Moderator Cer0's Avatar
    Join Date
    Apr 2008
    Location
    MN/WI
    Posts
    14,099
    Thanks
    395
    Thanked 1,182 Times in 915 Posts

    I am out of ideas. I couldn't find anything on sn0wbreeze causing issues when using windows 7 64bit.
    [CENTER][SIGPIC][/SIGPIC][/CENTER]

  12. #12
    not snowbreeze, but itunes restore feature... lemme see if i can find anything again..

    damn cant find anything now that i need to

    i might try again tomorrow virtualboxing OS X and mac itunes...
    Last edited by ydgmms; 2010-03-23 at 08:16 AM.

  13. #13
    I saw an article the other day that says that there have been some problems with doing a restore on a JB'd phone on windows. The solution that they offered was to uninstall and reinstall iTunes and then to ensure that your phone goes into DFU immediately once you have reinstalled itunes. If you do anything with it before the restore then the settings and preferences are already in the logs and it will not work. I do not have the link otherwise I would put it up.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •