Page 1 of 4 123 ... LastLast
Results 1 to 20 of 80

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: old at&t blue mmode settings on iphone

  1. #1
    What's Jailbreak?
    Join Date
    Sep 2007
    Posts
    2
    Thanks
    0
    Thanked 4 Times in 1 Post
    Talking old at&t blue mmode settings on iphone
    I got the "old" AT&T blue mmode working on my iphone

    Here are the steps:

    You basically need to modify one file and add a new file.

    *** Before you do anything, turn your WIFI OFF on your iphone *****

    the file to modify is
    /var/root/Library/Preferences/SystemConfiguration/preferences.plist

    In this file, search for "cingular", you will find this section

    ----------------------------------------
    <key>apn</key>
    <string>wap.cingular</string>
    <key>password</key>
    <string>CINGULAR1</string>
    <key>username</key>
    <string>[email protected]</string>
    ---------------------------------------

    replace
    wap.cingular
    with
    proxy

    Delete
    CINGULAR1
    and
    [email protected]

    so this section looks like this

    ---------------------------------------
    <key>apn</key>
    <string>proxy</string>
    <key>password</key>
    <string></string>
    <key>username</key>
    <string></string>----------------------


    then find this section, (close to the top of the file)

    <key>Interface</key>
    <dict>
    <key>DeviceName</key>
    <string>ip2</string>
    <key>Hardware</key>
    <string>com.apple.CommCenter</string>
    <key>Type</key>
    <string>com.apple.CommCenter</string>
    </dict>

    add following section after it.

    <key>Proxies</key>
    <dict>
    <key>ProxyAutoConfigEnable</key>
    <integer>1</integer>
    <key>ProxyAutoConfigURLString</key>
    <string>file:///private/var/root/proxy.pac</string>
    </dict>


    Now we are done with this file, next step is to add a proxy.pac file.

    copy text below to Notepad and save it as proxy.pac (make sure it does not have .txt in the file name)

    function FindProxyForURL(url, host)
    {
    if (isInNet(myIpAddress(), "10.0.0.0", "255.0.0.0"))
    return "PROXY 10.250.250.54:8080";
    else
    return "DIRECT";
    }

    then upload to iphone at this directory

    "/private/var/root"

    after finish this, DON't DO anything else, reboot the phone

    You are done!

    BTW: I found the proxy ip address setting from here

    http://forums.wireless.att.com/cng/b...hread.id=12670

    and it works for me (I am in NorCal).

    Good luck to those fellow AT&T blue users!

  2. The Following 4 Users Say Thank You to ngejung For This Useful Post:

    amm151 (2007-11-03), giantquesadilla (2007-11-05), PaulE (2007-10-01), txdesi (2008-03-29)

  3. #2
    Hi,

    Thanks. I too have an old ATT sim, but I've never used mmode so forgive my ignorance...


    Would this allow me to check email and googlemap over GSM? Is it something that I would have had to have signed up for? I don't think I ever did, so perhaps this won't work for me or they'll force me to 'downgrade' to a newer, more expensive plan.

    Thanks,

  4. #3
    Default old at&t blue mmode settings on iphone
    Thanks for the brilliant tip. I was able to successfully configure my iPhone to use the data features using my old ATT mMode data plan. I had the pay-per-KB data plan and it worked perfectly fine with it.

    However, I then got my data plan changed to mMode Unlimited ($24.99) data plan to use it more effectively and cheaply and now the data access on the iPhone doesn't work anymore!!! Any ideas???? It works perfectly fine on my older windows mobile phone though.

    Any help would be greatly appreciated

    ok...found the issue. The APN entries in preferences.plist had somehow reverted back on its own to the original values. I am not sure why, but it probably happened after i had popped in the original ATT sim that came with my iPhone to check if the EDGE settings show up or not.

    Changed the APN value to "proxy" and BINGO!! Its working like a charm now. Thanks again for the brilliant tip
    Last edited by vinkap; 2007-10-02 at 06:19 PM. Reason: Automerged Doublepost

  5. #4
    Owner / Founder - ModMyi
    aka cash7c3
    Cody Overcash's Avatar
    Join Date
    May 2007
    Location
    Denver, CO
    Posts
    11,920
    Thanks
    339
    Thanked 15,254 Times in 649 Posts

    moved to att forum.

    Help us help you. Please respect our site by posting in the correct forums in the future.

  6. #5
    Ok guys I just suscribe to the mmode plan and i did the following steps you mentioned. the problem i am facing now is the quality of the picture downgraded specially in the youtube. if i play the vedio on my wifi quality gets way better. any Idea how to fix and why that happens.

  7. #6
    Thats normal. It automatically changes the resolution based on the network you are using. This helps keep speed sup while on EDGE.

  8. #7
    What's Jailbreak?
    Join Date
    Nov 2007
    Posts
    8
    Thanks
    1
    Thanked 2 Times in 1 Post
    Thanks ngejung for the original info.

    I have a revirginized phone 1.1.1 running and found that I also had to edit


    /var/root/Library/Preferences/com.apple.carrier.plist

    From
    ----------------------------------------
    <key>apn</key>
    <string>wap.cingular</string>
    <key>password</key>
    <string>CINGULAR1</string>
    <key>username</key>
    <string>[email protected]</string>
    ---------------------------------------

    to

    --------------------------------------
    <key>apn</key>
    <string>proxy</string>
    <key>password</key>
    <string></string>
    <key>username</key>
    <string></string>----------------------

    reason being my files kept overwriting.

    Worked for me!!!! Hope this helps someone else.

    BLUE FOREVER!

  9. The Following 2 Users Say Thank You to amm151 For This Useful Post:

    giantquesadilla (2007-11-05), txdesi (2008-03-29)

  10. #8
    hi i would like to know if i copy and paste the section that says to be "copy and pasted" and adjust the margins to fit like the margins around it. thanks.

    - ok i just copy pasted the SECTION to the correct path and adjusted the margins so it looks like the area around it, and left no spaces inbetween lines and it WORKS!

    thanks a lot for the info! awesome
    Last edited by ngangsta; 2007-11-04 at 12:56 AM. Reason: Automerged Doublepost

  11. #9
    Hey. Thanks for the info guys. I have a question though. The first time I tried to do this, I think I edited the wrong part of the file. Can someone please send me their preferences.plist file? I would greatly appreciate it. Just email or PM me.
    I went into the AT&T store today to activate mmode. The guy there said that AT&T is actually considering bringing mmode back. However, I have a feeling that they will make a "new mmode" that will not be compatible with our "former mmode".

    Thanks a lot for posting. I didn't think there was anyone left with the former at&t.

    EDIT: I went through the code and fixed the part I screwed up. It works now. THANK YOU ALL SO MUCH!!!!!! YOU ARE GENIUSES! How do u even figure this stuff out!?!
    Last edited by giantquesadilla; 2007-11-05 at 03:56 AM.

  12. #10
    I am so happy to see all your posts about getting mmode to work on the iPhone. I read so much info about how to do it and gave up because I am not as skilled as the brilliant people on this board. So I paid someone to edit my settings and it worked for a day. Then I transferred a tv show to my iphone and update my music -- and the mmode capability disappeared completely.

    I realize if I could figure out how to get into my iPhone, I could edit my preferences myself -- but I can't figure it out.

    Can one of you geniuses break it down for me in baby steps so I can tackle this issue myself?

    I have the iPhone, I had it unlocked, I have version 1.1.1 (3A109a); Modem Firmware 04.01.13_G. There is no remaining icon for SimFree, although I know it was used.

    Can you please enlighten me on how I can change mmode settings myself? Remember, I need BABY steps.

    Thanks for your help! I too want to be back on my mmode blue!


    :-)

  13. #11
    Quote Originally Posted by equivocal1 View Post
    I am so happy to see all your posts about getting mmode to work on the iPhone. I read so much info about how to do it and gave up because I am not as skilled as the brilliant people on this board. So I paid someone to edit my settings and it worked for a day. Then I transferred a tv show to my iphone and update my music -- and the mmode capability disappeared completely.

    I realize if I could figure out how to get into my iPhone, I could edit my preferences myself -- but I can't figure it out.

    Can one of you geniuses break it down for me in baby steps so I can tackle this issue myself?

    I have the iPhone, I had it unlocked, I have version 1.1.1 (3A109a); Modem Firmware 04.01.13_G. There is no remaining icon for SimFree, although I know it was used.

    Can you please enlighten me on how I can change mmode settings myself? Remember, I need BABY steps.

    Thanks for your help! I too want to be back on my mmode blue!


    :-)
    Did you ever get a response from anybody ? I also have the iPhone with the old ATT card and have not been able to browse the web. Thanks.

  14. #12
    I have a question. I just updated to 1.1.1 and unlocked it. every time I restart/reboot my iPhone it reverts back to the default EDGE settings. It's frustrating as with 1.0.2 it didn't do that. Please let me know if there's something that can be done to retain that configuration.

  15. #13
    Quote Originally Posted by amm151 View Post
    Thanks ngejung for the original info.

    I have a revirginized phone 1.1.1 running and found that I also had to edit


    /var/root/Library/Preferences/com.apple.carrier.plist

    From
    ----------------------------------------
    <key>apn</key>
    <string>wap.cingular</string>
    <key>password</key>
    <string>CINGULAR1</string>
    <key>username</key>
    <string>[email protected]</string>
    ---------------------------------------

    to

    --------------------------------------
    <key>apn</key>
    <string>proxy</string>
    <key>password</key>
    <string></string>
    <key>username</key>
    <string></string>----------------------

    reason being my files kept overwriting.

    Worked for me!!!! Hope this helps someone else.

    BLUE FOREVER!

    I had the same problem. I did your fix.. however I still dont have edge.. the setting stay but still no edge . I had a 1.02 unlocked.. virginize, upgrade to 1.1.1 and jailbreak.. (didn't unlocked though) help !??

  16. #14
    I found that sometimes the settings dont save. you just need to do it a few times. yes it's frustrating but it will eventually work. after all it needs our assistance to function properly

  17. #15
    does the position of the extra proxy

    <key>Proxies</key>
    <dict>
    <key>ProxyAutoConfigEnable</key>
    <integer>1</integer>
    <key>ProxyAutoConfigURLString</key>
    <string>file:///private/var/root/proxy.pac</string>
    </dict>

    matter?

    i put it after ip2.. and doesn't seem to do anything.. i see on t-mobile they tried after ip1.. im strill trying this.. no worky.. please help

  18. #16
    if i turn off WIFI as the guide states, how do i connect to the iphone and perform these file changes?

  19. #17
    Quote Originally Posted by bonefish View Post
    if i turn off WIFI as the guide states, how do i connect to the iphone and perform these file changes?
    you wont be connected via wifi. You could use mobiletextedit to make those changes. and install the save EDGE settings app too

  20. #18
    Quote Originally Posted by phattbam View Post
    you wont be connected via wifi. You could use mobiletextedit to make those changes. and install the save EDGE settings app too
    Great Site !

    I just added the $24.99 mmode data plan to my old blue $99/mo charter unlimited calling plan.

    I have read that I need to change characters but I need someone to walk me through the process of getting to where I change these ?

    Please help me out, this is driving me crazy....

  21. #19
    I used this method to make 1.1.1 EDGE work on my jailbroken iPhone and it worked perfectly. Then when I upgraded my phone to 1.1.3 using natetrue's method, It wiped out something to do with these files and now EDGE doesn't work. Is anyone else running into this issue? Anyone know how to fix it?

  22. #20
    In 1.1.3, the preferences.plist file has been moved. You will need to copy the modified preferences.plist file to "/private/var/preferences/SystemConfiguration/" or modify the preferences.plist file that is there already. You will also need to put the proxy.pac file back on the phone (still in "/private/var/root/") at least that's what worked for me...
    Last edited by giantquesadilla; 2008-02-10 at 07:33 AM.

Page 1 of 4 123 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •