Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Could not activate EDGE.

  1. #1
    Exclamation Could not activate EDGE.
    my iphone has been getting this error when im on EDGE:
    Could not activate EDGE:you are not subscribed to EDGE
    Im on the unlimited data plan for sure
    Ive hard reseted my phone
    Ive turned it off and on
    ive tryed installing services
    My iphone is currently jailbroken 1.1.2
    Everything was working fine then just all the sudden i couldnt access web,weather,youtube,maps anything that used the edge

    Is this my phone or is this AT&T at's its finest?

    If its at&t then they are making apple look real bad if i was them id be looking for loopholes in the contract to at&t exclusive service provider.

  2. #2
    well the thing is that you need to go tell the store that you want edge on you iphone. In the contract you did not say yyou want edge. This also happened to me also!!!

  3. #3
    Before taking it to any store try this. I had the same probably after I upgraded to 1.1.2.

    Go to (from iPhones home screen) Setting --> General --> Reset --> Reset Network Settings

    That should fix it or it worked for me.

  4. The Following 2 Users Say Thank You to GimpedT For This Useful Post:

    gh3ownzrockband (2008-01-21), inkdracula (2008-06-05)

  5. #4
    Thank you man that fixed it!

  6. #5
    Green Apple RottieMan's Avatar
    Join Date
    Jan 2008
    Location
    Bay Area, Ca
    Posts
    52
    Thanks
    14
    Thanked 2 Times in 1 Post
    That worked for me also, i was on the phone all day saturday with AT&t and it was this quick fix!! thanks

  7. #6
    Previously Known as A.T MetallicaFan1991's Avatar
    Join Date
    Apr 2008
    Location
    Manchester, UK
    Posts
    1,584
    Thanks
    188
    Thanked 111 Times in 94 Posts

    I'm on o2 uk payngo sim. I get the "could not be subscribed to edge". Does anyone know how to get round this. Heard you can by SSH. Will the SSH method work when FW 2.0 comes out?
    Last edited by MetallicaFan1991; 2008-05-26 at 10:27 PM. Reason: spelling mistake

  8. #7
    Hi everyone, I'm experiencing this since I got my phone OTB 1.0.2 upgraded/unlocked/jb running now 1.1.4 under AT&T (old plan, 2003).

    I do get the E in a blue box, suggesting that EDGE is available.

    Trying to fix it, I tried all suggestions I found including Reset Network Settings (or whatever that's called), modified plist files to include APN configs, restored... but nothing seems to work.

    Any other suggestion?

  9. #8
    Reset Network Settings worked for me too! I just switched service from TMobile to AT&T because I was planning on getting the new Iphone in July for the 3G. They let me switch without a contract and still let me add the iphone data plan. But it wasn't working. Reset network settings fixed the problem, now visual voicemail and edge are good to go. My guess is that the culprit was one of the hacks I had been using to make edge work on tmobile using tzones. Hope this helps.

  10. #9
    Hi All, I did the reset thing but I still do not get the option of Edge anywhere in my General settings - do I have to install something to get this???

    Thanks.

  11. #10
    maybe try restoring your iPhone?

  12. #11
    If I restore my iPhone will it lock it? Will I lose everything I have loaded?

  13. #12
    if you're really concerned about losing stored pictures or songs or contacts or whatnot, first plug it into iTunes and then it should sync the iPhone. it will also back-up everything including pictures that was previously on the last sync after you restore it.
    after that, just simply unlock it again and sync with iTunes and it should be the same as havng everything there again, but hopefully with edge this time.

    hope I helped.

  14. #13
    Quote Originally Posted by Kally View Post
    Hi All, I did the reset thing but I still do not get the option of Edge anywhere in my General settings - do I have to install something to get this???
    Try this?

    http://www.modmyi.com/forums/jailbre...tml#post473351

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •