Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Cannot connect to appstore.

  1. #1
    Default Cannot connect to appstore.
    I tried to download an app from the appstore and when I click buy it just doesn't do anything. It does act like it is going to download the app and it shows a gray app that is loading but doesn't do anything and just says waiting. I got to settings and look at my itunes account and it says I am signed in. So I go to view account and it says, "cannot connect to itunes store". I have tried a lot and have looked everywhere but don't know what to do. I am using an Iphone 3gs 3.1.3 with the spirit jailbreak. Anyone have any ideas on what I should do?

  2. #2
    I pretty much have the same issue. But when I try to buy anything or update anything I have to give my password and it says connot connect to iTunes store

  3. #3
    Same happens to me!
    the funniest things are the forbidden...
    -Mark twain

    73rd member!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts