Page 1 of 2 12 LastLast
Results 1 to 20 of 28

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3.0 white/blank and mixed up app icons

  1. #1
    iPhone? More like MyPhone
    Join Date
    Nov 2007
    Location
    Palm Bay, FL
    Posts
    102
    Thanks
    17
    Thanked 32 Times in 15 Posts

    Default iPhone 3.0 white/blank and mixed up app icons
    Hello,

    I got an iPhone 3G S on launch date and since have been having the most annoying issue regarding my app icons.

    The stock app icons and certain App Store icons are fine, but certain App Store programs install with a white icon or an icon from another app (except it will be slightly darkened). I have tried rebooting, deleting and reinstalling, as well as downloading them through iTunes and sending them to my phone. Sometimes, the applications will install fine and only have a white or different icon after rebooting my phone.

    Normally I would think to restore my phone, but this has been happening since the first app I downloaded when I bought my phone and I'm obviously not jailbroken. I also don't really wanna go through the trouble of restoring unless anyone else can confirm it helped them.

    Is anyone else having this issue or is it just me?

    Thanks,
    KoNeko

  2. #2
    I have the same thing going on with my phone, half the icon will be palringo and the other half is AOL instant messanger... its pretty wierd

  3. #3
    iPhone? More like MyPhone
    Join Date
    Nov 2007
    Location
    Palm Bay, FL
    Posts
    102
    Thanks
    17
    Thanked 32 Times in 15 Posts

    Well, I caved and did the restore and everything seems fine again. I'm just wondering if it will ever come back. If it makes a difference, I temporarily logged into someone's iTunes Store account with my phone to download a few apps they bought and then returned to my personal account. Has anyone else had a problem like this?

  4. #4
    I too am having this issue on my 3G[S], but I reckon it's a bug in the 3.0 OS as it was present on my 3G running beta 5. On mine if, say, I delete 3 apps, the next 3 that I download will take on those previous 3 icons after the first reboot, and further reboots do not solve it. Come on Apple, such an obvious bug should have been caught during the beta stages.

  5. #5
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Corrupted file during J/B, you'll have to restore and start over, sorry guys

  6. #6
    iPhoneaholic kwall's Avatar
    Join Date
    May 2008
    Location
    New York
    Posts
    308
    Thanks
    7
    Thanked 40 Times in 32 Posts

    Quote Originally Posted by blkcadi View Post
    Corrupted file during J/B, you'll have to restore and start over, sorry guys
    No disrespect to you but the first poster said he or she has a 3G S so there cannot be a corrupted file during the jailbreak as it cannot be jailbroken as of now.

  7. The Following User Says Thank You to kwall For This Useful Post:

    Bo Troxell (2009-06-23)

  8. #7
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Quote Originally Posted by kwall View Post
    No disrespect to you but the first poster said he or she has a 3G S so there cannot be a corrupted file during the jailbreak as it cannot be jailbroken as of now.
    opps, your correct. It gets a bit confusing trying to help so many people. I have to slow down a bit and make sure I read their problem before I respond. I was reading the last (Andy) post.

  9. #8
    iPhoneaholic kwall's Avatar
    Join Date
    May 2008
    Location
    New York
    Posts
    308
    Thanks
    7
    Thanked 40 Times in 32 Posts

    Haha no worries at least your helping unlike the other wise members of the community who bash. I am wondering if keneko and others problems are like the first batch of iPod Touches with the negative image problem with the screen.

  10. #9
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Quote Originally Posted by kwall View Post
    Haha no worries at least your helping unlike the other wise members of the community who bash. I am wondering if keneko and others problems are like the first batch of iPod Touches with the negative image problem with the screen.
    Not sure, weird. Apple making a mistake, come on, lol
    Seems most problems people are having are user induced, didn't follow instructions,or corrupt J/B.
    Last edited by Bo Troxell; 2009-06-23 at 02:19 AM.

  11. #10
    I also have the same problem, everything runs fine. If I delete and redownload the app will have normal icon but after restart they get screwed up again LOL.

    I am restoring, although I am sure with others having the problem it will only temporarily fix the problem. Must be 3.0 bug.

  12. #11
    My iPhone is a Part of Me
    Join Date
    Dec 2008
    Location
    New Orleans, LA
    Posts
    953
    Thanks
    60
    Thanked 81 Times in 64 Posts

    Nope. It is a jailbreak bug. You're right, the 3G S can't be jailbroken yet, but files that came from backing up a jailbroken 3G can still be transferred. Just like the battery percent on the 3G right after the 3.0 upgrade was there before a jailbreak was available.

    Restoring it not from a backup will solve your problem. I'm thinking about restoring before I get too much info on my phone that I can't lose.
    Does this rag smell like chloroform to you?

    If I helped you, be sure to press the Thanks! button over there ->
    If I didn't, press it anyway.

  13. #12
    I did not jailbreak any of the 3.0 beta's on my 3G, and even if i did, how would they be transferred to my 3G[S] when it is a different firmware.

  14. #13
    I actually don't "mod my iphone". I got to this forum by googling for "iphone mixed up icons". I can say, this is an iPhone 3.0 software bug, as I don't (and have never) jailbreak my iphone. I recently upgraded from the 3g to the 3g[s], and I've been having this very same problem. Some icons are mixed up with other icons (half one icon, half another), and some apps are straight up using the full icon from a different app. Very annoying.

    Sadly, I don't have a solution. I just wanted to chime in and say it's not (entirely) a bug that arises from jailbreaking.

  15. #14
    Haha, this is funny because I thought I was the only one having this issue. I am having the same thing happen on my 3GS.

    If you guys find a fix or a solution to the issue let me know.

    Also, I have never jailbroken my iPhone 3G before buying my new one, so i don't think its a jailbreak issue.

  16. #15
    iPhoneaholic kwall's Avatar
    Join Date
    May 2008
    Location
    New York
    Posts
    308
    Thanks
    7
    Thanked 40 Times in 32 Posts

    what i find funny is no one has posted screenshots of their said problem

  17. #16
    What, the description isn't good enough?

    I'd post them, but I already did a restore. If it happens again, I'll take some.

  18. #17
    Green Apple Du Blex's Avatar
    Join Date
    Jan 2009
    Location
    Massachusetts
    Posts
    54
    Thanks
    9
    Thanked 1 Time in 1 Post
    I have a 1st Gen iPhone and i am too experiencing these problems. most likely an apple bug. hope a fix comes soon in the near future
    ALL THEY DO IS DRINK, SMOKE DOPE, AND TELL JOKES TO THE OLD FOLKS

  19. #18
    This issue is extremely annoying. It's happening on my 3GS which I did NOT restore from backup, and have not done any modifications to. Also happening on my Jailbroken 2G phone.

    <table style="width:auto;"><tr><td><a href="http://picasaweb.google.com/lh/photo/8s4kmY_wd3R4F2dEGh04bA?feat=embedwebsite"><img src="http://lh4.ggpht.com/_kOnC4UImz3k/SkVA_en9uPI/AAAAAAAAAG8/0mAZauxa78w/s144/photo.jpg" /></a></td></tr><tr><td style="font-family:arial,sans-serif; font-size:11px; text-align:right">From <a href="http://picasaweb.google.com/JGrizz36/IPhone?feat=embedwebsite">iPhone</a></td></tr></table>

  20. #19
    I am having the same problem. Very annoying.

  21. #20
    Well 3.1 should be out soon enough, maybe they will fix it in that firmware. (Hopefully)

    I just got my iPhone a wee or so ago, and I am a total novice to any of the modding nonsense (as in, I haven't done any yet) and I am getting issues with scrambled icons. Half the icon will look like the original and half will look like some other icon I deleted the app for, or that was on another page.

    When I tried deleting and re-downloading some, or restarting, neither worked. This seems to be the same issue others are having. I don't particularly want to reset everything if it's just plausibly going to happen again, and it's mostly just really damn irritating, seemingly benign, so I shall wait for them to fix it.

    And also wait for the 3GS Jailbreak. =D

    Sorry I can't provide a screenshot. I don't know how to take one of my phone.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •