Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: iTunes Stuck reporting 1 App update!?

  1. #1
    Default iTunes Stuck reporting 1 App update!?
    I don't know what happened, but ever since I tried to update Evernote and Beatmaker something went crazy with my iTunes and now its stuck showing 1 update is available. However, if I click the update button it takes me to an itunes page and says that there aren't any updates available for my account... Huh?

    Anyone run into this problem? I'm tempted to just delete all my apps and salvage the IPA files from the trash bin so I can install them again later, especially the ones you can't get anymore like iphone saber and free rider.

    If I get super annoyed at the (1) always being there I think I might do just that. One hunch I have is that the apps that were removed had an update applied to them but then were taken off the appstore (iphonesaber etc) so now when I go to update them, iTunes doesn't find anything because its not there anymore. I could be wrong, but I'm assuming this is what may be the problem.

    Help is appreciated, otherwise I'll post my results once that (1) sends me to the point of desperation.

  2. #2
    I'm glad I'm not the only one. I have 2 apps that supposedly need updating. I just decided to live with it. It is annoying however.

    x999x - I just did a complete backup (took forever) and sync and my updates notifications went away. I only do a complete back up once a week or so since it takes forever. Try that.
    Last edited by TheOrioles33; 2008-08-17 at 12:28 AM. Reason: Automerged Doublepost

  3. #3
    in itunes make sure you go to "file - transfer purchases to iphone". this fixes it for me. if you apply updates via iphone or via itunes they need to be in-sync not just SYNCed.

  4. #4
    iPhone? More like MyPhone iRoach74's Avatar
    Join Date
    Feb 2008
    Cincinnati, OH
    Thanked 1 Time in 1 Post
    i got this too. yeah... it sucks cause i got like OCD which i think would relate to this type of thing, but im not really shure... hehe

  5. #5
    I tried what was suggested here, but unfortunately I still have (1) app reported as having an update

    I think I may just delete all the apps that have since been removed from the Appstore, like iPhoneSaber and FreeRider just to see if that clears up the update notice. I'm going to save the IPA file that it puts in the trashbin just so I can install them later (gotta have my freerider :P)

    Alrighty, I seem to have fixed my "stuck update" by deleting all my apps from iTunes and then removing the IPA files from the trash bin. From there, I double clicked each IPA one by one to add them back into iTunes.

    It turns out that CrashBandikoot Racing brought back up the "Update" notice, and when I tried to click the update button, nothing was available. To fix this I deleted CBNK3D again, and this time went back to the appstore to re-download it. This sorted it out, and I'm now back to normal with my App Update Status
    Last edited by x999x; 2008-08-18 at 04:37 AM. Reason: Automerged Doublepost

  6. #6
    Join Date
    Nov 2007
    Wraysbury, UK
    Thanked 62 Times in 40 Posts

    Thank god I'm not the only one... maybe I have all these cracked apps though?

  7. #7
    Quote Originally Posted by [email protected] View Post
    Thank god I'm not the only one... maybe I have all these cracked apps though?
    I don't have any cracked apps, it seems my iTunes just got stuck with the CrashBandicoot update that happened a while ago. I didn't realize this until I deleted all my apps from itunes and then re-added them one by one.

    When you delete the apps from iTunes and it asks you if you want to move them to the trash, I just selected Yes. Then I moved them from the trash and onto my desktop, followed by double clicking them one by one to add them back into iTunes.

    Once CrashBandicoot was added my update notice changed, so I knew that was the problematic app. Just delete that problem app and redownload it from iTunes and you're all set. The big hassle is finding that "problem" app in the first place :T

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts