so -- I want to download Drummer (drum machine app that supposedly only works with 2.0 FW) and I have an unlocked, jailbroken iPhone working on 1.1.4. FW.
So, I assume that there is NO way to get a 2.0 app to work on a 1.1.4. phone so what will I need to do? Will I need to wait until the unlocked version of 2.0 is hacked and the upgrade to that and then get the 2.0 (Drummer) app?
And if so- when I upgrade, will I loose all of my current apps and phone numbers etc...?