Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Error 3014 help (and yes, I've done a TON of searching!!)

  1. #1
    Default Error 3014 help (and yes, I've done a TON of searching!!)
    ok folks. First post here, and it's a long one. I'm hoping yall can help out. Iíll try to provide as much info as possible.

    Here's the situation- I bought a 3gs many moons ago, jailbroke it the night I purchased it, and life was good. Until I decided to upgrade. After the upgrade to 3.1.2, I couldn't jailbreak it, and the baseband had changed to the 5.11.07 Now, itís running 3.1.2, I thought I managed to jailbreak it with BlackRain, as the Cydia icon is there, but the program begins to open, then after a few moments, automatically closes.

    I've spent a combined 12 or 15 hours in the evenings over the past few days trying to downgrade it to 3.0 and restore my original baseband- I have SHSH blobs on Cydia for 3.0, but can't seem to get the downgrade to work.

    All of this is done using Itunes 9.0.0.7 (possible issue?) I've also uninstalled/reinstalled Itunes, and downloaded a new 3.0 .ipsw file, just to be safe

    Here's what I've done so far-

    -Found the how to set up local server tutorial on here and read through. Seemed easy enough, right? Maybe for some folks...not this dude

    -download TinyUmbrella, and checked for SHSH blobs from Cydia. 3.0 is there. In the writeup on this site, it says the files should be 66kb, however all of mine are 6kb. This may be an issue?

    -When trying to downgrade, with the tinyumbrella server set to run locally and redirect gs.apple.com, and being told (through tinyumbrella) that I DO have SHSH on file with Cydia, I get Error 3014

    What next? Google usually has answers!

    -Found something that said 3014 is caused by connection/network issues. It recommended this VPN software (HotSpotShield) that seemed to work quite well. Like before- Maybe for some folks, but, of course, not for me.

    -Thought it could be my network. Turned on the wifi tethering on my other phone (Android- donít hold it against me!) and tried the same process again connected to the phoneís network- start TinyUmbrella server, open Itunes, connect phone, DFU mode, restore. Still same error.

    OK, well, maybe itís something else. Dig more.

    -Came across a post on the Apple forums that 3014 could also be caused by limited space left on your HD. Well, on my 100GB HD, Iíve only got about 1GB left. Dump some stuff to external, free up about 10 gigs, and get excited. It HAS to work now, right? Hell no. Same damn error.

    So, I check out the log in TinyUmbrella, think I may have found a clue-

    -In the log, I get a ďDevice: INVALID X.X.X (XXXX)Ē error. Time to go digging again to figure out wtf that means. Still havenít found that one out, but Iím assuming this may be playing a role in my problems. Iíve searched and searched, but found no good info on what that error is describing, or if it is an issue (which I assume it is)

    Iíve tried different USB ports, uninstalling/reinstalling programs, downloading new .ipsw, uninstalled/reinstalled TinyUmbrella, verified that my hosts file is correct (took out the Cydia server redirect), and searched until I thought I was going to throw my computer out the window. All without success. Iím typically a more competent person than this with my technology, but this one has me stumped.

    SO, with all of that said, anyone have some advice? I feel as if itís either my SHSH files at 6kb instead of 66kb, or whatever the hell the INVALID X.X.X error means.

    Also, is there a way besides file size to verify you have downloaded complete SHSH files?

  2. #2
    127 views and still nothing? Where's the love for the no0b?!

    AARGH! Still trying to get this and having no success...will be trying on a different computer this evening and will report back the results.

    This is so frustrating...

  3. #3
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    Quote Originally Posted by pyrplhaze View Post
    ...I've spent a combined 12 or 15 hours in the evenings over the past few days trying to downgrade it to 3.0 and restore my original baseband...
    The baseband / modem firmware can never be downgraded (aka: restored to an earlier version) !!

    Old iOS firmware versions (aka 3.x or 4.x) can be restored if SHSH blobs are available.

    Error 3014

    False edited hosts. The SHSH request couldn't be completed. No connection to the Apple Server, Sauriks Server or localhost. iTunes can't connect to gs.apple.com. Maybe Port 80 and Port 443 is blocked. Open it on your router
    iTunes Errors - The iPhone Wiki
    Last edited by Mes; 2011-08-11 at 11:44 PM.

  4. #4
    thanks for the info. Didn't know about the baseband issue (again, more familiar with android than ios) guess I misunderstood a few things in my reading.

    so maybe I'm going to a bit more work than I need to...

    now my next question...

    If I have SHSH blobs on file for every ios between 3.0 and 4.3, is it necessary to go back to 3.0? I am currently running 3.1.2, and seem to have a failed jailbreak from blackrain, which is the main reason I'm going to this effort. I want an unlocked and jailbroken phone, then I'm going to sell it to whoever will give me a few bucks for it.

    is there an os that would be preferential over others? I assume that I could still unlock my current baseband (5.12.01) but have no clue what would happen to it if I upgraded the ios version, which is why I'm trying to downgrade at the moment...

    so, anyone have some advice?

    Thanks for any help!! I'm about to give this a shot on another computer...will report back the results

  5. #5
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    The best iOS for a 3GS is 4.2.1 (IMHO). It can be installed directly in a single restore operation.
    All 3GS's require SHSH blobs for the version to load. Tiny Umbrella retrieves and TU + TSS Server serves them up when needed.
    To preserve the current baseband, 4.2.1 must be installed using a custom built (and loaded) firmware by Pwnage or Sn0wbreeze.
    Install Ultrasn0w for the unlock

    To be clear: Pwnage or Sn0wbreeze build and assist putting the phone into pwnd-DFU mode.
    Then iTunes restores (shift or option + click restore) + point to custom built firmware.
    Last edited by Mes; 2011-08-12 at 02:00 AM.

  6. #6
    sounds good. I'm somewhat familiar with snowbreeze...used it to jb my wife's 3g...

    Progress report: I believe the restore to 3.0 is going to complete successfully on a different computer.. not sure what the issue was with my other comp, but it's working exactly as it should according to the writeup on this forum on this different computer

    I'll have to do some reading up on snowbreeze and give it a whirl. I hope I don't f--- it up and upgrade the baseband :/

    Thanks for your help. 'tis much appreciated!!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •