Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Upgrade 3.1.3 to 4.0

  1. #1
    Default Upgrade 3.1.3 to 4.0
    I have a question about upgrading from 3.1.3 to 4.0. I used tinyumbrella to see what available shsh's i have, and this is what i get:


    http://img809.imageshack.us/img809/1...nyumbrella.png

    why does my phone have shshs for an ipod touch? am i able to use those to upgrade to 4.0? thanks!

  2. #2
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    You will not be able to use those SHSHs for other devices. They are device-specific. You don't have an iPod Touch? Cuz any time you use the same comp to pull SHSHs for any device, they will be reported by TU as saved in your system.

  3. #3
    Thanks for the quick response! I do have an ipod touch but Ive never used it with tinyumbrella. I guess what really threw me off was the fact that those firmware had the same ECID as my iphone 3gs. Is that normal or am I not understanding this concept correctly?

  4. #4
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    That is kind of weird, I've seen this before only once. I still haven't had a chance to assess the sitatuation yet cuz it doesn't happen a lot. Perhaps you'd like to experiment and try a restore with the TSS server running. I'm not saying you can use an iPod Touch SHSH for an iPhone or any other device besides itself as the ECID is unique to each device, but it is so weird that your two devices share the same. It might be a reporting error, I'll have to go home and check my iPod's ECID. I know my 2 iPhone 4's have different ECIDs tho, as they should.

    You can try a restore. It won't hurt your phone as long as you're not trying to restore to 4.1. I'm curious to see if it will work just because your devices report the same ECID. I doubt it'll work since they're not the same device, but I'm still curious :P

  5. #5
    Quote Originally Posted by Anniex423 View Post
    That is kind of weird, I've seen this before only once. I still haven't had a chance to assess the sitatuation yet cuz it doesn't happen a lot. Perhaps you'd like to experiment and try a restore with the TSS server running. I'm not saying you can use an iPod Touch SHSH for an iPhone or any other device besides itself as the ECID is unique to each device, but it is so weird that your two devices share the same. It might be a reporting error, I'll have to go home and check my iPod's ECID. I know my 2 iPhone 4's have different ECIDs tho, as they should.

    You can try a restore. It won't hurt your phone as long as you're not trying to restore to 4.1. I'm curious to see if it will work just because your devices report the same ECID. I doubt it'll work since they're not the same device, but I'm still curious :P
    I would give it a shot but im afraid that if it doesnt work, ill be forced to to restore to 4.1. My phone is unlocked so I have to avoid any possibility of that happening

    So Im wondering if anyone ran into this before and what I should do. I just find it really bizarre that my phones ECID is on those firmwares.

  6. #6
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    It won't force you up to 4.1 unless you allow it.

    Attempting a shift+restore to 4.0.1 can only give you an unharmful error 3194 if it fails. If it fails, just kick it out if DFU mode and your phone is back to normal. Then only way you'll ever be forced up to 4.1 is if you click upgrade or if iTunes prompts an upgrade and you click download and install.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •