Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Another 4.1 downgrade question.

  1. #1
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    UK
    Posts
    165
    Thanks
    9
    Thanked 55 Times in 30 Posts

    Default Another 4.1 downgrade question.
    Right, I have looked all over and can't find a clear answer to my question.

    I am well aware of the downgrade procedure and the prerequisites.

    I have just had to send my iPhone 4 off to have a new screen fitted as I stupidly manage to drop it.

    Obviously before I sent it off I retored to the lastest 4.1 firmware to wipe my jailbreak. I DO have SHSH for 4.0, 4.0.1 etc stored with Saurik AND on my computer so I know I'm good to downgrade back to either of those versions so I can re-jailbreak.

    My question is, is the 4.1 baseband compatible with 4.0/4.0.1? No good me having a jailbroken phone that can't connect to the network.

    I seem to remember the 3.x beta basebands not being compatible with 2.2.x and having to use Ultrasn0w to get it working. Obviously, as Ultrasn0w does not work on the lastest baseband if I find my self in the same situation then I'm in trouble....

    Has anyone had the same situation that can advise me?

    Once again, I know how to downgrade so this is not a requst for step by step instructions. I simpley want to know if the 4.1 baseband will work on 4.0/4.0.1

    EDIT: I know I have posted this in the 3GS Downgrading section! It seemed to be the best place!

    Thanks guy!
    Last edited by FinalBillybong; 2010-09-21 at 12:31 PM.
    If I helped please head on over and smash the Thanks button.

    My Personal Cydia source: apt.finalbillybong.com

  2. #2
    Can't give you a definitive answer, but I think you'll be fine with 4.0/4.0.1 firmware with the newer baseband. I've not heard of any problems.

    Obviously, it has to be with the official carrier though.

  3. The Following User Says Thank You to eyeRobot For This Useful Post:

    FinalBillybong (2010-09-21)

  4. #3
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    UK
    Posts
    165
    Thanks
    9
    Thanked 55 Times in 30 Posts

    I with an official carrier and have no interest in an unlock. Well I guess I'll have to wait and see what happens. They could, of course, send me a new iPhone 4 yet which might have 4.0.2 or above on it. That would be BAD! :-)

    Thanks for the reply dude.
    If I helped please head on over and smash the Thanks button.

    My Personal Cydia source: apt.finalbillybong.com

  5. #4
    Livin the iPhone Life jkmonkey's Avatar
    Join Date
    Mar 2010
    Location
    Upstate NY
    Posts
    1,433
    Thanks
    67
    Thanked 254 Times in 245 Posts

    Since you don't need to unlock you'll be fine with the baseband from 4.1. The only problem you'll run into with it is that when you downgrade you'll get error 1015 towards the end of the restore. Just use tiny umbrella at that point to kick it out of recovery.

  6. #5
    Retired Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,851
    Thanks
    42
    Thanked 699 Times in 594 Posts

    Quote Originally Posted by jkmonkey View Post
    Since you don't need to unlock you'll be fine with the baseband from 4.1. The only problem you'll run into with it is that when you downgrade you'll get error 1015 towards the end of the restore. Just use tiny umbrella at that point to kick it out of recovery.
    Either 1015 or 1004 errors on the i4. Both are expected behavior, both can be bypassed with TinyUmbrella.

    On topic: I believe baseband 02.10.04 is fully compatible with iOS 4.0.x. Haven't tested it personally, but it should be just fine. Good hunting.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •