Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Upgrade and preserving baseband

  1. #1
    Default Upgrade and preserving baseband
    Hello hope someone can help

    i have a 3gs new bootroom on 3.1.2 with baseband 05.11.07 and shsh saved since 3.1.2 for all firmware. Now i was wondering if i could upgrade to 4.0.1 without changing my baseband?
    By updating through suriks server would this preserve my baseband?

    Thanks in advance

  2. #2
    No, the only way to maintain your baseband is by upgrading to 4.0 using the Pwnagetool method.

  3. #3
    Thanks for that can you give me a source to read instructions on how to use that. I read that it was not possible on new bootroom

  4. #4
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by Tspoon View Post
    Thanks for that can you give me a source to read instructions on how to use that. I read that it was not possible on new bootroom
    Yes, new bootrom cannot use Pwngage tools, atleast for now. You have to restore to stock firmware if you want to upgrade.

  5. #5
    thanks for your help everyone. I finally sorted it out. I didn't want to update my baseband to the latest one attached with IOS 4.1 since it has not yet been hacked and may never be hacked.
    For those who want to know what I did, as i had my shsh saved in cydia i retrieved them locally using tiny umbrella and then updated using the TSS server from tinyumbrella.

    thanks for all your help.

  6. #6
    Your baseband would have been upgraded to 5.13.4 once you updated to 4.0.1, luckily that baseband can still be unlocked using ultrasn0w.

  7. #7
    I upgraded to 4.0.1 using TU from 3.1.3, and my baseband also upgraded to 5.13.4, can this be possible?
    so that your baseband does not upgrade, yo have to use TU using the TSS server and clicking restore or upgrade in iTunes right?
    and I heard we can upgrade to 4.1 using TU... but to upgrade to 4.1 how and for what would you use TU?

    thanks in advance

  8. #8
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    First you have to download the latest TU version 4.1.3, then grab 4.1 shsh blogs and store it locally. Start TSS server, and do the restore, the verification will be done thru the TU, when restored, the BB will remain unchanged but the OS 4.1 will be installed. I cannot confirm this , if anyone can confirm this would be great.

  9. #9
    for some strange reason, when I check on my iphone the SHSHs in cydia I only have up to 4.0.2... why dont I have 4.1?.. sorry haha

  10. #10
    My iPhone is a Part of Me Trooper Sam's Avatar
    Join Date
    Jul 2010
    Location
    Somewhere in California
    Posts
    503
    Thanks
    51
    Thanked 78 Times in 62 Posts

    The way I read it on The Firmware Umbrella:

    "Note that this will only work while Apple is signing 4.0.2 SHSH requests. This is due to the way Apple now updates/restores Baseband Firmware for the iPhone 4 different from the way it did to prior devices. Lucky us..."

    So, the method stated MAY only work for the iPhone 4. There was also talk of being able to downgrade the baseband, but that was only for as long as 4.0.2 was being signed, which has apparently come to an end.

  11. #11
    Retired Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,851
    Thanks
    42
    Thanked 699 Times in 594 Posts

    Quote Originally Posted by Trooper Sam View Post
    The way I read it on The Firmware Umbrella:

    "Note that this will only work while Apple is signing 4.0.2 SHSH requests. This is due to the way Apple now updates/restores Baseband Firmware for the iPhone 4 different from the way it did to prior devices. Lucky us..."

    So, the method stated MAY only work for the iPhone 4. There was also talk of being able to downgrade the baseband, but that was only for as long as 4.0.2 was being signed, which has apparently come to an end.
    No more i4 baseband downgrades. The nonces for 01.59.00 will not be signed by Apple anymore; therefore, no dice. Sucks too, because the i4 actually allows for baseband downgrades out of the box--with the corresponding signed nonces.

    You can still upgrade to 4.1 using TinyUmbrella and preserve the baseband on an iPhone 4 (and the iPhone 4 ONLY) using Semaphore's instructions. But if you've lost the 01.59.00 for 02.10.04 you're stuck and will be for a loooooooong time.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •