Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: A different story about shshs...

  1. #1
    Default A different story about shshs...
    So I was one of the masses that jailbroke and saved their SHSH after apple came out with 4.0.2 and apparently stopped signing previous releases which was why I was positively befuddled when after a week of cydia's pending tss note becoming "this device has shshs on file for iphone os/ios: 4.0" I was positive that the version number had been truncated and was missing the '.2.' However, maybe two days later, 4.0.1 and 4.0.2 showed up in the list! (I probably wouldn't have even gotten that far without stumbling and lurking on this forum, thanks)

    I then installed tiny umbrella and tried to save my shsh thinking that I could save my 3.1.2 blob for later use, but unfortunately only 4.0.2 was saved. Saurik had to be wrong, how was it possible for them to be in disagreement? It's his server after all.

    Crestfallen, I resigned myself to living with a buggy (maybe I haven't reset it correctly? (files aren't saving from safari correctly)) jailbroken 3.1.2 (via jailbreakme (which is still complaining that something went wrong and the pdf exploit is still not fixed)). However, looking at this forum and seeing just how much conversation that is going on gave me a glimmer of hope that it was still possible to upgrade to 4.0.1.
    I then happened upon a now locked thread: http://modmyi.com/forums/3g-s-downgr...-no-shshs.html

    Apparently there were a bunch of people that were managing to upgrade without the proper shsh blobs! But! there was a strong undercurrent of skepticism turning to distrust!(exclamation mark!) I grew disappointed that people were trying to get me to irreversibly upgrade my iphone.

    So! risking accusations of dummy accounts and spamming and the like, I think I can resolve that:

    I saw this post: http://modmyi.com/forums/3g-s-downgr...-no-shshs.html

    and noticed that I had never tried to save the 4.x blobs manually. so I fired up tiny umbrella again and gave it a shot (nothing to lose after all, I wasn't even touching anything other than reading a number into a server). Ah Ha! It turns out that saurik and his server aren't in disagreement after all! I discovered that 4.0, 4.0.1, and 4.0.2 were saved for me! Still didn't have my 3.1.2 though. I'm not sure if this is a recent development by saurik or if I should keep quiet or what, but How Exciting! It's a bingo!

    I still have no idea how this is possible as I just got this phone (maybe close to a month ago now and didn't jailbreak till after 4.0.2 had come out) from a neoluddite friend who had never jailbroken or saved the blobs or anything like that so I logically should have only been able to upgrade to 4.0.2, but here they were: the options to upgrade to 4.0 and up.

    So In case I've missed any new conversation to the topic or I have just opened my eyes far later than everyone else

    If you want to downgrade: grab tiny umbrella, and click advanced just to check if it is possible that cydia has saved the blobs for you. I'm sure that this might be another isolated case where a noob has just gotten lucky (as the list of others in the other thread (I assume you can grab my ip or something to see that I'm not a dummy shill account)). Anyways, a harmless 5 minute test for others that are 'stuck' with the new firmware.

    I'll readily admit that I'm positively giddy with this recent development and that there's no way that I can prove anything beyond the fact that I have blobs saved which is the whole point, but I'll be a happy shill for at least giving the faint glimmer of hope to try the whole process another time while waiting for the next jailbreak to come out.

    Finally, a disclaimer, I haven't actually upgraded my firmware yet as I discovered my blobs a few minutes ago and had to shout it to the modding world. (more questions to ask and all that)

    My question then is: Is there still no way for me to save my current 3.1.2 shsh blob? and am I now good to go for upgrading to 4.0.1 and jailbreaking Finally, why do some upgrade to 4.0 rather than 4.0.1?

    Why aren't the safari plugins working? (pdf exploit and downloader (I get gibberish displayed on the screen when trying to grab an .avi or w/e)) I've turned the thing off and back on but that doesn't do the job.

    Post script: Apologies for nested parenthesis and less than perfect grammar/articulation.

    tl;dr: If you're stuck at 4.0.2 and need to downgrade, use tiny umbrella's advanced function and try to manually download the 4.0/4.0.1 firmware. You've got nothing to lose at this point.

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,878
    Thanks
    8,108
    Thanked 17,646 Times in 8,026 Posts

    Wow that is some story. The moral of it is good though, it doesn't hurt to check if you have SHSH you might be surprised by what you find...

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •