Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Problem restoring to 3.1.3

  1. #1
    Default Problem restoring to 3.1.3
    I have SHSH blobs saved on Cydia when I was on OS 3.1.3 but I keep getting 3194 error while trying to restore to 3.1.3. Please help.

    EDIT: I tried restoring to iOS 4.0.1. Tinyumbrella states that my device DOES NOT have SHSH blobs for 3.1.3, which is impossible. I specifically had Cydia 'make my life easier' and even saw the 'This device has a pending TSS request' message go to 'This device has SHSH on file for...'. Did my ECID change or what?
    Last edited by nackkerel; 2010-08-28 at 01:50 PM.

  2. #2
    Bumping. I'm seriously at my wit's end here; there's so much conflicting information out there.

  3. #3
    Green Apple
    Join Date
    Aug 2010
    Location
    Australia
    Posts
    34
    Thanks
    6
    Thanked 1 Time in 1 Post
    Download the latest Tiny Umbrella.
    Grab all your shsh from Cydia and it will be stored locally.
    Select from Tiny Umbrella 3.1.3 shsh
    Start your Tiny Server
    Put your Iphone into Recovery Mode.
    Do the Shift + Restore to 3.1.3

    And make sure you have the latest ITunes

  4. #4
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Did your cydia specifically say your device had SHSH for 3.1.3?

  5. The Following User Says Thank You to Simon For This Useful Post:

    nackkerel (2010-08-28)

  6. #5
    Green Apple
    Join Date
    Aug 2010
    Location
    Australia
    Posts
    34
    Thanks
    6
    Thanked 1 Time in 1 Post
    Oh I didn't read it propally, if it says Cydia DOESN'T HAVE them then it's impossible unless it's got old iBoot

  7. #6
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Even with old bootrom you still need SHSH to downgrade.

  8. #7
    Cydia says that blobs for 4.0 have been saved but nothing about 3.1.3... goddamn it. Most of my apps aren't working on OS4 just as I feared.

    I don't understand... I was very careful to make sure that I had SHSH blobs saved by Cydia's 'Make my life easier' function. Did my ECID change when I did the restore thus rendering my blobs incompatible? Haha, I don't even know if that's possible...
    Last edited by nackkerel; 2010-08-28 at 06:03 PM.

  9. #8
    Green Apple
    Join Date
    Aug 2010
    Location
    Australia
    Posts
    34
    Thanks
    6
    Thanked 1 Time in 1 Post
    No I don't think it's possible for ECIDs to change, if it says you only have 4.0 blobs then you can't downgrade

  10. The Following User Says Thank You to Vatec For This Useful Post:

    nackkerel (2010-08-28)

  11. #9
    But then, what exactly happened to the 3.1.3 blobs? Was Cydia lying to me when it said 'This device has SHSH on file for 3.1.3' before all this happened?

  12. #10
    Green Apple
    Join Date
    Aug 2010
    Location
    Australia
    Posts
    34
    Thanks
    6
    Thanked 1 Time in 1 Post
    Probably, you can never trust saurik

  13. #11
    Well, that's news. Excellent news indeed. Really excellent. Although I think there could be other reasons why Cydia apparently 'lost' my blobs.

    Thanks to the two of you for replying anyway. Maybe I'll go ask around in saurik's irc channel for an explanation or something lol. Or see if custom fws will save me from the clutches of the ios4 hellhole.
    Last edited by nackkerel; 2010-08-28 at 07:28 PM.

  14. #12
    nackkerel, what version of TinyUmbrella are you using? Have you tried using an older version (version 222 seems to work for me) in getting the blobs from Cydia. It's worth a try. If you strongly believe that Cydia should have the 3.1.3 blobs, I'm sure it's there. I had the same issues before and I found that in my case, using an old version of TinyUmbrella works with my XP. As I said, it's worth a try.

  15. #13
    Oh. I'm using the latest version, though, where would I be able to download older versions of tinyumbrella?

  16. #14
    nackkerel, try the link below

    The Firmware Umbrella: March 2010

  17. #15
    TFU has put the file on Mediafire to private, so I can't access it, but I got one from iPhone Firmware. Couldn't get the blobs either, it was worth the shot though.

    Also, there seem to be a few very scary warnings on TFU, one of which specifically tells me NOT to upgrade iTunes past 9.1, which I unfortunately did because that was required to sync with iOS 4+.

    By the way, what IP address should I put in the hosts file when trying to contact Saurik's server? There are a number that different guides have recommended: .105.171, .10.249, . 0.1 and so on. I'm rather confused at which one to use.
    Last edited by nackkerel; 2010-08-29 at 05:20 PM.

  18. #16
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by nackkerel View Post
    TFU has put the file on Mediafire to private, so I can't access it, but I got one from iPhone Firmware. Couldn't get the blobs either, it was worth the shot though.

    Also, there seem to be a few very scary warnings on TFU, one of which specifically tells me NOT to upgrade iTunes past 9.1, which I unfortunately did because that was required to sync with iOS 4+.

    By the way, what IP address should I put in the hosts file when trying to contact Saurik's server? There are a number that different guides have recommended: .105.171, .10.249, . 0.1 and so on. I'm rather confused at which one to use.
    You can see what IP to use in Saurik's article on the whole downgrading process. You can find that here: Caching Apple's Signature Server - Jay Freeman (saurik)

    iTunes version doesn't matter when downgrading so it's fine to use the newest one. Also, the newest version of TU is preferred.

    In the hosts file, make sure there's only one reference to gs.apple.com - if you run TU's TSS server, it adds a reference, so be sure to comment that out (by putting a # in front of the line) if you're trying to downgrade using Cydia's server.
    We're all just toymakers in the game of life.

  19. #17
    I have the exact same problem as nackkerel
    I had a problem with my iPhone 3gs today so I had to restore it and update it to 4.0.2. I bought my iPhone in July and it had the 3.1.3 firmware and I didn't do a single update from it. I had it jailbroken, and I had pressed the {HEART) "Make my life easier, Thanks button" in Cydia. The green message at the top of cydia confirmed that I had saved my SHSH's for 3.1.3. But today as I said, after upgrading to 4.0.2, I wanted to downgrade back to 3.1.3, but iTunes shows error 3194, and TinyUmbrella says I hadn't saved any SHSH's before! Hmhmhm seems strange to me that I am not the only one who has the same problem. Hope someone can find a solution. Thanks!

  20. #18
    I've tried using the latest version of TU and I managed to get all 4 of my SHSHs blobs (previously I had had some trouble using TU version 4.) The latest version is 4.02.05

    When you are requesting the SHSH from Cydia (i.e. pressing the Save my SHSH button), make sure the host file is clean (i.e no line with Cydia's IP address etc etc).

  21. #19
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by Panos99GR View Post
    I have the exact same problem as nackkerel
    I had a problem with my iPhone 3gs today so I had to restore it and update it to 4.0.2. I bought my iPhone in July and it had the 3.1.3 firmware and I didn't do a single update from it. I had it jailbroken, and I had pressed the {HEART) "Make my life easier, Thanks button" in Cydia. The green message at the top of cydia confirmed that I had saved my SHSH's for 3.1.3. But today as I said, after upgrading to 4.0.2, I wanted to downgrade back to 3.1.3, but iTunes shows error 3194, and TinyUmbrella says I hadn't saved any SHSH's before! Hmhmhm seems strange to me that I am not the only one who has the same problem. Hope someone can find a solution. Thanks!
    Did you ask TU to get your SHSHs from Cydia? TU won't automatically have your SHSHs the first time you run it.
    We're all just toymakers in the game of life.

  22. #20
    Quote Originally Posted by dhamien View Post
    Did you ask TU to get your SHSHs from Cydia? TU won't automatically have your SHSHs the first time you run it.
    Hmm, I think yes. You ask them by pressing the Display SHSHs button, right?

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •