Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Did reset and erase all settings on JB 3gs, what next?

  1. #1
    Default Did reset and erase all settings on JB 3gs, what next?
    So the phone is stuck at pineapple logo and I feel stupid.
    I know I can put it in DFU mode and then restore to official 4.02. I have saved SHSH with Cydia but I have never used this process and I am wondering if there is a way to avoid it and install directly an older firmware or modified/jailbroken 4.02? I may have modified firmware saved from last jailbreak. Thanks!
    Last edited by HDTV4me; 2010-08-25 at 05:24 AM.

  2. #2
    Retired Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,851
    Thanks
    42
    Thanked 699 Times in 594 Posts

    Quote Originally Posted by HDTV4me View Post
    So the phone is stuck at pineapple logo and I feel stupid.
    I know I can put it in DFU mode and then restore to official 4.02. I have saved SHSH with Cydia but I have never used this process and I am wondering if there is a way to avoid it and install directly an older firmware or modified/jailbroken 4.02? I may have modified firmware saved from last jailbreak. Thanks!
    If you've got SHSH blobs backed up with Cydia, then you can in fact restore to any firmware you'd like (that you have SHSH blobs saved for) using a host file edit or Umbrella. However, you may not have to do that.

    Is your 3GS an old-bootrom model? Did you use a custom firmware made by PwnageTool to jailbreak it (or rather, last jailbreak it)? If so, you might not have to even touch the SHSH blobs.

  3. #3
    Is your 3GS an old-bootrom model?
    =Yes
    Did you use a custom firmware made by PwnageTool to jailbreak it
    =Yes

    Do I need to find the exact custom firmware I used last time or can I just find for example 3.1.2 firmware I have blobs for and run PwnageTool again?

  4. #4
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by HDTV4me View Post
    Is your 3GS an old-bootrom model?
    =Yes
    Did you use a custom firmware made by PwnageTool to jailbreak it
    =Yes

    Do I need to find the exact custom firmware I used last time or can I just find for example 3.1.2 firmware I have blobs for and run PwnageTool again?
    You can directly restore to custom firmware of OS 3.1.2, 3.1.3, iOS 4.0.

  5. #5
    Retired Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,851
    Thanks
    42
    Thanked 699 Times in 594 Posts

    Quote Originally Posted by yeow202 View Post
    You can directly restore to custom firmware of OS 3.1.2, 3.1.3, iOS 4.0.
    ^^Yessir.

    Put your 3GS in Recovery mode (not DFU) and just restore to any PwnageTool-made custom IPSW of your choice. No blobs, no mess, (hopefully) no hassle, keep your jailbreak and your baseband (although the current one is unlockable, I'd preserve yours just in case).

  6. #6
    Got jailbreak with Pwnage to 3.1.2, modem 04.26.08. No error messages. It says carrier and network not available when I put in ATT sim from working Iphone 2g. Not sure what I did wrong

  7. #7
    Retired Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,851
    Thanks
    42
    Thanked 699 Times in 594 Posts

    Quote Originally Posted by HDTV4me View Post
    Got jailbreak with Pwnage to 3.1.2, modem 04.26.08. No error messages. It says carrier and network not available when I put in ATT sim from working Iphone 2g. Not sure what I did wrong
    The SIM is active and working, right? That's strange...

    If you can find another working SIM, try it in your phone, see if it gets bars (unlock with ultrasn0w if you need to). You also can reset your network settings only (that shouldn't bring up a need to restore again).

  8. #8
    Quote Originally Posted by orbyorb View Post
    The SIM is active and working, right? That's strange...

    If you can find another working SIM, try it in your phone, see if it gets bars (unlock with ultrasn0w if you need to). You also can reset your network settings only (that shouldn't bring up a need to restore again).
    Thanks,

    I got it working after connecting to itunes and downloading ATT "updated carrier settings". I think I had to activate also.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •