Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3gs downgrading help

  1. #1
    Default 3gs downgrading help
    i tried everything, including saving my SHSH blobs. i also followed sauriks instructions. I accidentally upgraded to 4.0.2, losing my jailbreak. every time i shift restore, 'THE Iphone was not restored because the firmware file isn't compatible" can some one help?

  2. #2
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Are you running TinyUmbrella's TSS server when restoring?

  3. #3

  4. #4
    Default .
    I have an iphone 3Gs running 4.0 firmware and I could not jailbreak just like you but you can try the following steps: open up safari then go to jailbreakme.com slide where it saids jailbreak and wait for a little bit and it should jailbreak.....hope I helped
    Last edited by douglascastaneda12; 2010-08-24 at 07:20 AM. Reason: Messed up

  5. #5
    jailbreakme doesnt work on ios 4.0.2

    on sauriks "Caching Apple's signature server" it says apple will give an error code when it says, " verifying restore with Apple". But, i cant even get to that step. before the thing even starts restoring, it says firmware file is not compatible even though it is compatible. i am so pissed. will i have 2 wait for 4.1?
    Last edited by calvind77; 2010-08-26 at 12:08 AM. Reason: Automerged Doublepost

  6. #6
    You need to tell us the steps you are taking to downgrade so that we can see if you are missing a step or if we can propose other solutions for your problems.

    1. You need to tell us the previous firmware you had before you accidentally upgraded to 4.0.2
    2. If you had a previously jailbroken firmware, was the SHSHs blobs saved into Cydia (i.e. did you remember going into Cydia and seeing at the top of Cydia some sort of message saying that Cydia has saved your 3.1.2, 3.1.3, 4.0.0, 4.0.1 blobs

    More details would allow some of us to help you. Most of us do not like to offer help when we don't know what is going on there.

  7. #7
    i had 3.1.2, and I saved my SHsH blobs. I changed bottom of the hosts file to 74.208.10.249 gs.apple.com and saved it. After i put my device, which is a iphone 3gs into DFU mode, i shift clicked and opened the backup of my 3.1.2 ipsw. before it starts, i get a window saying, the iphone was not restored because the firmware file is not compatible.

  8. #8
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    You mustve chosen the wrong firmware. What is the exact firmware name?

    It should start (for 3GS) with iPhone2,1_xxx

    If you have anything with iPhone1,1_xxx or iPhone1,2_xxx then you are not using the right firmware appropriate for your phone.

    Edit: also make sure they are STOCK firmwares (get working ones from here on MMi in Downloads) and not custom fw.
    Last edited by i.Annie; 2010-08-27 at 04:19 AM. Reason: Automerged Doublepost

  9. #9
    it said iPhone2,1_3.1.3 _7E18_Restore. I downloaded it from a site, i forgot which one but i am sure the firmware is not not compatible...

  10. #10
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Are you sure it was a STOCK firmware then?

    Try downloading it from the Downloads section here on MMi to ensure its validity.

    Youre sure Tinyumbrella displays that you have your 4.0 and/or 4.0.1 SHSHs?

  11. #11
    calvin,

    try these steps. It worked for me.

    I'm not sure if this will help but try this (if possible try on an XP Machine)

    If you remember saving the blobs on 3.1, then I'm sure Cydia will have your blobs. This has worked for me Everytime (I have had to downgrade 4 iPhone 3Gs)

    1.Download the latest TinyUmbrella (or the version 4.0.54 should be okay as well) Google for it or better yet, go to the TinyUmbrella blog (google for it)
    2. Download also TinyUmbrella version 222 (yes, it's an old version). It should be in the TinyUmbrella blogs as well. If you cannot find the old version from the blogs, googled for it.
    3. You will need both version of TinyUmbrella
    4. Once you have downloaded both of them, run the latest version (or 4.00.54) and click on the advance tab, get your ECID for this version. Write it down and copy it somewhere. Cydia will have stored the same ECID in its system.
    5. Exit that version and now run TinyUmbrella 222 (the old version). Key in the ECID that you wrote down. DO NOT MESS with the host file at this time. Point the software to Cydia-Saudrik repository. Make sure also you select the SHSHs blob version that you believed Cydia saved for you (i.e. 3.1.2, 3.1.3 etc etc.)
    6. IF your SHSHs were saved by Cydia, it will download the SHSH blobs to your local machine (most likely in the same directory as where you ran TinyUmbrella 222, otherwise search your computer for file with the *.shsh extension.)

    You now have your ECID in your local machine and you should rejoice since now you can downgrade your Firmware using the local host anytime you want.

    To downgrade using a local host, follow the steps below

    1. Edit your host file (in XP, it should be in c:/windows/system32/drivers/etc/hosts)

    2. Add at the bottom of the line 127.0.0.1 gs.appple.com

    3. Saved the hosts file

    4. Now run the latest version of TinyUmbrella and DRAG the SHSHs file that was saved on your local machine into the application window. It will give you some messages saying that a certain version of the firmware is accepted etc etc

    5. Click on Start TSS Server. (It will then say that it's waiting for request or something of that sort)

    6. Run iTunes. Put your iPhone in DFU mode and press Shift+Restore and select the 3.1.2/3.1/3.1.3 etc etc firmware (ohh you need to download the OFFICIAL 3.1.2/x firmware, look either in iClarified or Modmyi for the firmware)

    7. This should work. If you have upgraded to 4.0.2, the iPhone's baseband probably would have been upgraded and you will get the 1015 error. This is normal, do not worry.

    8. You need to use Quickpwan to kick the iPhone out of the 1015 error (search this forum on 1015 error and you will find the solution)

    9. You will have successfully downgraded to 3.1.2/x

    10. Use Blacrain to jailbreak/hacktivate the iPhone

    11. Use Pwnagetool 4.0.1 to create a custom firmware of the 4.0 firmware (this is another guide altogether, but it's not that difficult to follow. Just follow the tutorial from iClarified)

    It's a bit long but I hope it helps. The key thing is getting the SHSH blobs from Cydia so that you can save it locally. As I mentioned before, I have done these type of downgrades several times and this method works everytime.

  12. #12
    i got 3194 error.

  13. #13
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Lack of SHSHs present or youre not editing your host files correctly.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •