Results 1 to 20 of 20

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Upgrading to 4.0.1 (not 4.0.2)

  1. #1
    Default Upgrading to 4.0.1 (not 4.0.2)
    I am having some troubles with my iPhone 3GS (jailbroken, 3.1.3). iTunes keeps giving me some error message saying it can't read from my iPhone and that I need to do a factory restore to the phone. So, what iTunes begins to do is download 4.0.2. However, I don't want to upgrade past 4.0.1. I have 4.0.1 downloaded on my desktop, I just can't figure out how to get it on my iPhone. I'm kind of new to jailbreaking, so I don't know a whole lot yet...

  2. #2
    You can't upgrade right now, you missed your window. Apple is no longer allowing 4.0.1 to be loaded (either upgraded or downgraded) onto 3GS iPhones. Can't be done unless you saved your 4.0.1 SHSH files thru Cydia. But since you indicate you've never been past 3.1.3, you're stuck.

    You might wanna try reloading 3.1.3 to see if that helps (assuming you've clicked the "make my life easier" button on the Cydia homepage).

  3. #3
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    If he has his 3.1.3 SHSH then he should have his 4.0 and 4.0.1 SHSH. Cydia automatically backs them up after the first time you touch make my life easier. If that is the case then he can use tiny umbrella to update to 4.0 or 4.0.1.

  4. #4
    My iPhone is 3.1.3, and as of yet has never been upgraded past that. If I use the "Erase All Content and Settings" option on my iPhone, I assume that will get me back to a non-jailbroken 3.1.3, which means I could just do a Spirit jailbreak from there? I would still be on 3.1.3, but if getting to 4.x is going to be a pain, it's not a big deal to me. Or is there a better option? Like I said, I don't know a whole lot about jailbreaking yet...
    Last edited by erik_andresen; 2010-08-21 at 04:58 PM.

  5. #5
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Don't use that setting, on a jail broken phone it could cause you to have to restore. Open cydia and see what SHSH you have backed up, it will be on the first screen at the top.

  6. #6
    It says 3.1.3, 4.0, 4.0.1.

  7. #7
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    http://modmyi.com/forums/general/725...ml#post5412335

    Then you can restore to 4.0.1. Just follow the instructions i gave in this thread and you should be fine.

  8. The Following User Says Thank You to Simon For This Useful Post:

    erik_andresen (2010-08-21)

  9. #8
    Sounds good. Looks like it is working. Thanks a lot!

    Edit:

    Okay, so I have my shsh files saved on my computer and I have the server running...

    I start iTunes... then what? I try to restore, but it just looks like a normal restore to me. I think I might have missed a step. Sorry
    Last edited by erik_andresen; 2010-08-21 at 05:32 PM. Reason: Automerged Doublepost

  10. #9
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Have you downloaded the 4.0 firmware? You can download 4.0 from here: http://modmyi.com/wiki/index.php/IPh...Download_Links after that You have to hold down option (for Mac) or shift (windows) then click restore, a window will pop up and you choose the firmware you just downloaded. Also you should download the firmware with firefox or another browser. Internet explorer tends to download the firmware as a zip file instead of an ipsw. You would have to change the file extensions from .zip to .ipsw, firefox does not have that issue i believe.
    Last edited by Simon; 2010-08-21 at 05:43 PM.

  11. The Following 2 Users Say Thank You to Simon For This Useful Post:

    crazy88 (2010-08-22), erik_andresen (2010-08-21)

  12. #10
    Oh, great! I'm officially on 4.0.1. Thank you so much!

  13. #11
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    No problem, glad I could help.

  14. #12
    Hello,

    Just joined the forum with the exact same problem as above, but have a few questions.

    I have never updated past 3.1.3 on my iPhone 3GS, but would like to update to 4.0.1. I need to be able to jailbreak in order to unlock as I use a different carrier.

    When I load Cydia, at the top it says: "This device has SHSHs on file for iPhone OS/ iOS: 3.1.3, 4.0 and 4.0.1"

    Does this mean I can still upgrade to 4.x even though Apple has stopped signing the firmware?

    On a side note, I do not seem to be able to download tiny umbrella. When I go to the website it just gives me this error when I try download it:

    http://dl.dropbox.com/u/7078752/Umbr...la-4.02.04.dmg

    Any help would be very much appreciated!

    Thanks in advance

  15. #13
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Yes you can update to 4.0 or 4.0.1. Don't know why you are getting that error downloading tiny umbrella. You may just have to wait til he fixes his download links or find another source to download it.

  16. The Following User Says Thank You to Simon For This Useful Post:

    crazy88 (2010-08-22)

  17. #14
    Thanks for the reply dude! I will let you know how I get on.

    OK, so I have now saved my SHSH thingy's for 4.0.1 and it all went well...but what do I do now?

    I have the shsh file saved locally, but how do i upgrade to 4.0.1?
    Last edited by crazy88; 2010-08-22 at 10:38 PM. Reason: Automerged Doublepost

  18. #15
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Just click start server in tiny umbrella, open iTunes and option/shift update or restore to 4.0 or 4.0.1. You can see here for more info: http://modmyi.com/forums/general/725...e-restore.html
    Last edited by Simon; 2010-08-22 at 10:46 PM.

  19. The Following User Says Thank You to Simon For This Useful Post:

    crazy88 (2010-08-22)

  20. #16
    Thanks again dude! I have successfully updated to 4.0.1 and the phone is unlocked. A great relief after someone told me that I couldn't do it, haha!

    Thanks

  21. The Following User Says Thank You to crazy88 For This Useful Post:

    Killah1 (2010-08-23)

  22. #17
    Default Upgrading from 3.1.3 to 4.0.1
    I have an iPhone 3GS with 3.1.3 installed and jailbroken with jailbreakme, but it is my husbands. He got an iPhone 4, but I want to use his 3Gs and sync it with my iTunes, but also upgrade it to 4.0.1. I downloaded the .ipsw firmware for 4.0.1, but when I tried to restore the phone, iTunes tells me that it is not valid, what do I need to do? I'm familiar with jail breaking, but have not gotten up to speed with any of the recent jailbreaks since Spirit, can someone please help.

  23. #18
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    You need the 4.0 or 4.0.1 SHSHs to restore to them.

    If you didnt save at least the 4.0.1 SHSHs before the 19th of this month, you cant get them anymore so you cant restore.

    If you have the old bootrom, you can restore with a custom firmware tho.
    Last edited by i.Annie; 2010-08-27 at 05:41 AM. Reason: Automerged Doublepost

  24. #19
    Hi m using a 3gs with ios 3 jailbraked so can any1 help me upgrading to ios4 or 4.0.1 plz
    i dont knw wat is SHSH n i didnt find nothin in cydia
    Last edited by safz2safz; 2010-08-27 at 08:09 AM. Reason: Incomplete

  25. #20
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    If Cydia doesnt say you have ypur SHSHs on top of the home page, you dont have them.

    Double check with Tinyumbrella to see of they are somehow saved.

    You need those SHSHs to upgrade to 4.0 or 4.0.1.

    If you happen to have an old bootrom phone tho, you can simply restore to a custom fw.

    If you have a new boot phone, you need the SHSHs there isnt any other option.

    If you have no idea what Im talking about, its a good idea to do some research and maybe spend a little time with Google.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •