Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 5.14.01 Baseband on 3GS Phone - HELP

  1. #1
    Default 5.14.01 Baseband on 3GS Phone - HELP
    So I bought a phone off someone without knowing the horror stories of the 5.14.01 baseband. I am able to jailbreak it, right now it's running 4.0.1 just fine, but I'm not able to unlock it. I thought it was unlocked but after sticking my T-Mobile SIM card in, it continues to just say "searching".

    My question is, is there ANY way to down or upgrade from this firmware so that I can get this phone working? Or am I just up a creek without a paddle??

  2. #2
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    You're up the creek without a paddle. You got taken adv of by someone that upgraded to 4.0.2 and it upgraded the baseband permanently and then they downgrade the firmware back to 4.0.1 just to sell it.

  3. #3
    IDK if that was the case as the guy up there said but if you have this BB you are done for the time being.

    Only option now is to sit tight.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •