Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help iPhone 3GS on 4.0

  1. #1
    Default Help iPhone 3GS on 4.0
    I have just upgraded my iphone 3gs to 4.0 and i want to jailbreak it. Not sure what procedures i need to take. I have seen that it has to be 3.1.2 in order to jailbreak the 4.0 is that true? Can someone give some directions on how to jailbreak it.

    Thanks

  2. #2
    Livin the iPhone Life Simtech's Avatar
    Join Date
    Aug 2007
    Location
    LA
    Posts
    2,387
    Thanks
    105
    Thanked 304 Times in 276 Posts

    You can only jailbreak it if you have your SHSH files for 3.1.x stored. If you do, you downgrade, jailbreak, create a custom 4.0 firmware, <shift> Restore to custom firmware.

  3. #3
    how do i find out if i do have SHSH files on my iphone?

  4. #4
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,824
    Thanks
    553
    Thanked 515 Times in 427 Posts

    Alter your iTunes hosts folder to point at Sauriks server(google it) and download a stock 3.1.2 from apple(in our downloads section) then Shift/Restore to the 3.1.2 that you downloaded. If it lets you then you are golden Jailbreak with blackrain, then Shift/Restore again to a custom 4.0 that you created with Snowbreeze or one you downloaded from the Internet. Otherwise download umbrella/tinyTSS to see what shsh files you may have.
    Last edited by CaptainChaos; 2010-07-12 at 10:02 PM.

  5. The Following User Says Thank You to CaptainChaos For This Useful Post:

    kouspo619 (2010-07-12)

  6. #5

  7. The Following User Says Thank You to Simtech For This Useful Post:

    kouspo619 (2010-07-12)

  8. #6
    is there another way a much more simpler way?

  9. #7
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,824
    Thanks
    553
    Thanked 515 Times in 427 Posts

    Absolutely not. With the 3GS anyways. You could get a 3G phone for simplicity, but the 3GS blows it away.

  10. #8
    haha alright. i need help with the Sauriks server thing im currently on a mac osx 10.6.4.

  11. #9
    Connect your phone to TinyUmbrella and click "Display SHSH". If nothing is displayed, wait for the userland JB. There's nothing more you can do at this time. If you do see an SHSH for 3.1.3 or 3.1.2, come back and let us know. We'll point you in the right direction.

  12. #10
    nah nothing is displayed. Will there be a jailbreak for 4.0 in the future where you will not need to downgrade in order to jailbreak it?

  13. #11
    Drinks the Kool Aid Captinsmooth's Avatar
    Join Date
    Mar 2010
    Location
    New York
    Posts
    1,322
    Thanks
    131
    Thanked 351 Times in 199 Posts

    Quote Originally Posted by kouspo619 View Post
    nah nothing is displayed. Will there be a jailbreak for 4.0 in the future where you will not need to downgrade in order to jailbreak it?
    Should be one released within the next few weeks. Sit tight and in the mean time save your shsh blobs for 4.0 just in case.
    This post infers no rights and is provided as is.

    Click here to follow me on twitter

  14. #12
    so i have a quick question.

    my friend has a 3gs w/ old bootrom on 4.0 with 5.13 baseband. i dont think he ever saved his shsh blobs while on 3.1.x and he put 4.0 on. so you HAVE to downgrade to 3.1.x BEFORE jb'ing 4.0? thanks in advance guys!

  15. #13
    Livin the iPhone Life jkmonkey's Avatar
    Join Date
    Mar 2010
    Location
    Upstate NY
    Posts
    1,433
    Thanks
    67
    Thanked 254 Times in 245 Posts

    Quote Originally Posted by jabregousmc View Post
    so i have a quick question.

    my friend has a 3gs w/ old bootrom on 4.0 with 5.13 baseband. i dont think he ever saved his shsh blobs while on 3.1.x and he put 4.0 on. so you HAVE to downgrade to 3.1.x BEFORE jb'ing 4.0? thanks in advance guys!
    There is currently no way to jailbreak a 3GS that is on stock 4.0. The phone has to be on 3.1.x then upgrade to 4.0 with a custom fw.

  16. #14
    yeah i know that it cant be on stock 4.0. i was just wondering about the downgrade portion. i checked in tiny umbrella and he doesnt have his shsh blobs saved from 3.1.x so cant downgrade and then load up a CFW. thanks though!

  17. #15
    Livin the iPhone Life Simtech's Avatar
    Join Date
    Aug 2007
    Location
    LA
    Posts
    2,387
    Thanks
    105
    Thanked 304 Times in 276 Posts

    No SHSH files, no downgrade..

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •