Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: jailbreak stock ios4 on 3gs with old bootrom

  1. #1
    Default jailbreak stock ios4 on 3gs with old bootrom
    I bought this phone use, it has a old boot room, it never jailbreak and it came with ios4, I try many method and read through modmyi, it has been mixed, some can jailbreak and some can't. so Can I jailbreak my old boot rom iphone 3gs with stock ios4?

  2. #2
    Yes, you need to be on OS 3.1.2, then jailbreak it with redsn0w, then you need to build a custom firmware 4.0 with pwnage tool and restore to it following pwnage tools instructions.

  3. #3
    Quote Originally Posted by JedixJarf View Post
    Yes, you need to be on OS 3.1.2, then jailbreak it with redsn0w, then you need to build a custom firmware 4.0 with pwnage tool and restore to it following pwnage tools instructions.
    Well, the OP's on 4.0, so that's too bad. Here's what you can try first, as some have reported some success. In order to downgrade to 3.1.3 or lower, YOU NEED TO HAVE YOUR SHSH BLOBS SAVED!

    Recently, some have reported being able to save older SHSHs even with iOS 4 installed. Follow the steps below to see if the previous user has stored any SHSH blobs.

    1. Connect your iPhone to your computer and run Tiny Umbrella 4.0.0.49.
    2. Click "Save My SHSH" so that you will save your iOS 4 SHSHs.
    3. Click "Advanced options". Your ECID will be displayed below. 4. Select "iPhone3GS 3.1.3 (7E18)" in the "Device/Version" drop down menu.
    5. Select "Cydia" in the "Location" drop down menu.
    6. Click "Save My SHSH", and you'll be able to see whether your SHSH can be saved. If it tells you that the device is not eligible, that means there are no saved SHSHs. Try that for all versions of iOS (3.0 to 3.1.3).

    If your device is ineligible for all those versions, that means no previous SHSHs were stored, and you're going to have to wait till a new JB tool is released. If you are able to save for any one of those versions, that means you can downgrade your phone to that version.

    Use this guide as an example of how to downgrade your phone.
    Last edited by douflag; 2010-07-02 at 10:14 PM.

  4. #4
    Default tried that
    I tried that but it gave me an erro 3194. I think it becuause i don't have shsd blob or something.

    so i am screw
    Last edited by danielvictor1983; 2010-07-03 at 10:57 AM. Reason: Automerged Doublepost

  5. #5
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by danielvictor1983 View Post
    I tried that but it gave me an erro 3194. I think it becuause i don't have shsd blob or something.

    so i am screw
    Put your Iphone in DFU mode and try it again. I assume you have pointed your hosts file to Cydia already.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •