Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3194 Error

  1. #1
    Default 3194 Error
    Looking for guidance, possibly a port number...

    I have a 3GS that was running 3.1.2 jailbroken with PwnageTool. About a month ago, I registered my SHSH glob with Cydia. I did get confirmation that 3.1.2 was stored by Cydia. I prepared a new 4.0 ipsw and sadly made the mistake of restoring the original 4.0 ipsw. Time to leverage the SHSH glob record...

    In preparation for the downgrade, I modified my Windows host file and performed a ping gs.apple.com to confirm it took. All good. I go into DFU and attempt to restore. Regardless of what I try to restore, I get the 3194 error that it cannot verify.

    At this point, I have no clue what is wrong. I think I am (somewhere) blocking a key port that is used to communicate back to apple for verification.

    Any thoughts on what I should check (again)... Any idea what ports are used in the process?

    -----------------------------

    edit: Just found out that the traffic is over port 80, which does not surprise me. Still no understanding why I am getting denied...

    -----------------------------

    edit 2: I tried a different approach and learned more... I attempted to get my SHSH data from Cydia with Umbrella. When I try to pull the 3.1.2 or 3.1.3 globs, I get a message that "This device isn't eligible for the requested build." When I try and get any other version, I get the expected 'null' comment. This leads me to believe that error 3194 is generic for any reason that a verification cannot be made--not just a communication problem. Next step... finding out whassup with my Cydia glob...
    Last edited by ahonamous; 2010-06-25 at 04:13 AM. Reason: Automerged Doublepost

  2. #2
    iPhone? More like MyPhone
    Join Date
    Apr 2009
    Location
    SoCal
    Posts
    156
    Thanks
    6
    Thanked 11 Times in 8 Posts

    Windows or mac?
    in windows just go to cwindows\system32\drivers\etc\ and copy "hosts" to your desktop. the one under the etc folder add a ".bak" to the end.
    now the one on your desktop right click it and open it with notepad. at the bottom add
    74.208.10.249 gs.apple.com
    DON'T HIGHLIGHT AND COPY i learned the hard way. (a couple of hours later) anyway do that then put your iphone in recovery mode( turn the iphone off then hold the homebuttom and plug) SHift+restore find the 3.1.2 or 3.1.3 and wait. you will need recboot to get out of the recovery boot later

  3. #3
    Well, I figured it out... sort-of. At least, I figured out what the problem was and then a work-around.

    Short story is that I was communicating properly and all was working on my end. There is a problem with either tinyumbrella or Saurik's server, not sure where. When I use tinyumbrella to get my SHSH file, it has mis-labelled the 3.1.2 SHSH as an iPod 2G file, not an iPhone 3GS file. It did report back that a proper 3.1.3 SHSH file was available for my 3GS, and that seemed to work. I did get he 1015 error, but the documentation here got me through that...


    @KoolMan0: I used a PC for this process.

  4. #4
    If it is 1015 error, google up iRecovery and follow the directions, it should work.

  5. #5
    Quote Originally Posted by Munchzors View Post
    If it is 1015 error, google up iRecovery and follow the directions, it should work.
    Thanks for the tip, but I got though this one... I now have a 3.1.3 non-JB install. Since my 3.1.2 SHSH blob is not showing up at Cydia properly, I will have to try and go from here. I will attempt to install a custom 3.1.3 IPSW tonight and see what happens...

  6. #6
    I have the same (or similar) problem. I jailbroke my step-dads 3gs (3.1.3 5.12.1) with Spirit, all went lovely. Then I decided to be clever and use the Spirit2pwn method to upgrade to 4.0. It all went well, got the files on and uploaded with Terminal but when it rebooted it went into DFU mode. I tried a restore to 3.1.3 with the blobs I save with Cydia but got a 3194 error, then tried a normal restore to 4.0 but that wouldnt work either. What is the trick to get iTunes to read the Saurok server? I am going mad here, I wouldnt mind so much if it was my phone but the fact that it is someone elses is making me uneasy, and I cant afford to buy him a new one!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •