Page 1 of 4 123 ... LastLast
Results 1 to 20 of 74

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3GS stuck in DFU

  1. #1
    Default iPhone 3GS stuck in DFU
    Hey guys, I recently bought an 3GS with 3.1.2 that was jailbroken and unlocked. As soon as I received it, I attempted to do a SHSH blob backup to Saurik's server. Unfortunately the server was down today and I had to do a local backup using Umbrella.

    I couldn't find any information about it but when I tried to backup the SHSH blob with 3.1.2 FW (the version that I had on my phone at the time) and selected in Umbrella, it said that it wasn't correct. I tried with 3.1.3 selected and it said it was backed up correctly. The file was created and everything. I thought this was probably the correct way of doing it.

    I then went to do a fresh restore using a custom 3.1.3 fw using Pwnage tool to ensure that I could keep my unlock. After iTunes said the restore was completed, it said that the phone would restart in 10 seconds. After the 10 seconds, iTunes said the phone was in recovery mode, but it has been stuck in DFU mode ever since. Just a BLACK SCREEN.

    If I have the SHSH blobs backed up locally, what can I do to help my situation?

  2. #2
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by donaetrinz View Post
    Hey guys, I recently bought an 3GS with 3.1.2 that was jailbroken and unlocked. As soon as I received it, I attempted to do a SHSH blob backup to Saurik's server. Unfortunately the server was down today and I had to do a local backup using Umbrella.

    I couldn't find any information about it but when I tried to backup the SHSH blob with 3.1.2 FW (the version that I had on my phone at the time) and selected in Umbrella, it said that it wasn't correct. I tried with 3.1.3 selected and it said it was backed up correctly. The file was created and everything. I thought this was probably the correct way of doing it.

    I then went to do a fresh restore using a custom 3.1.3 fw using Pwnage tool to ensure that I could keep my unlock. After iTunes said the restore was completed, it said that the phone would restart in 10 seconds. After the 10 seconds, iTunes said the phone was in recovery mode, but it has been stuck in DFU mode ever since. Just a BLACK SCREEN.

    If I have the SHSH blobs backed up locally, what can I do to help my situation?
    You shouldn't have done that, now you are screwed. You can either restore to stock 3.1.3 and lose your unlock OR use the last ditch method (saving the baseband ) In any way , you still new the official sim to activate.

  3. #3
    Try getting out of DFU by holding home+sleep button for 10 seconds then releasing it.

  4. #4
    Quote Originally Posted by yeow202 View Post
    You shouldn't have done that, now you are screwed. You can either restore to stock 3.1.3 and lose your unlock OR use the last ditch method (saving the baseband ) In any way , you still new the official sim to activate.
    My girlfriend has an official sim card. Can I use that somehow to get it back to working order while preserving the unlock?

  5. #5
    Yes. Try this: Preventing baseband update as a last-ditch effort [iPhone Dev Team]
    When you get to the home screen, don't use spirit yet.
    First go to Settings>General>About and check your baseband version.
    Then use spirit.
    If your baseband is 4.26 use ultrasn0w for unlock.
    If its 5.11 use blacksn0w RC2 for unlock.

  6. #6
    Quote Originally Posted by lairtonlelis View Post
    Yes. Try this: Preventing baseband update as a last-ditch effort [iPhone Dev Team]
    When you get to the home screen, don't use spirit yet.
    First go to Settings>General>About and check your baseband version.
    Then use spirit.
    If your baseband is 4.26 use ultrasn0w for unlock.
    If its 5.11 use blacksn0w RC2 for unlock.
    Thank you all for the quick responses. I will give this a try.

    Ok. I did the last Preventing baseband update last ditch effort and am stuck on the final step. When I restore the firmware that I edited and it was completed, I get the error #6 as expected.

    It went all black like it went back to DFU mode. iTunes detected it and said it was in recovery mode. I closed iTunes and ran the rslite command but rslite is just detecting it in DFU mode and note Recovery mode.

    What am I doing wrong?
    Last edited by donaetrinz; 2010-05-12 at 07:45 PM. Reason: Automerged Doublepost

  7. #7
    Try taking it off dfu. Hold home + sleep for 10 seconds.

  8. #8
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by lairtonlelis View Post
    Try taking it off dfu. Hold home + sleep for 10 seconds.
    You are almost there, all you need now is to get out of error #6, I know if you use Ireb, you need to install libusb ( becareful when installing Libusb in Vista mode) On my windows 7, I have to put libusb in xp2 compatibility mode.

    Quote Originally Posted by yeow202 View Post
    You are almost there, all you need now is to get out of error #6, I know if you use Ireb, you need to install libusb ( becareful when installing Libusb in Vista mode) On my windows 7, I have to put libusb in xp2 compatibility mode.
    I think quickpwn22 will also get you out of this recovery loop
    Last edited by iYeow; 2010-05-12 at 09:18 PM. Reason: Automerged Doublepost

  9. #9
    Quote Originally Posted by yeow202 View Post
    You are almost there, all you need now is to get out of error #6, I know if you use Ireb, you need to install libusb
    I don't see any info on the ih8sn0w site that says that iReb is able to be used on a 3GS. Do you know if it is compatible?

    Forgive me for being so noobish man. I got into this thinking I had enough info to know what I was doing. Dude was I wrong.
    Last edited by donaetrinz; 2010-05-12 at 10:11 PM.

  10. #10
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by donaetrinz View Post
    I don't see any info on the ih8sn0w site that says that iReb is able to be used on a 3GS. Do you know if it is compatible?

    Forgive me for being so noobish man. I got into this thinking I had enough info to know what I was doing. Dude was I wrong.
    when you use ireb 3.1.2, it will ask you if you have libusb installed

  11. #11
    Quote Originally Posted by yeow202 View Post
    when you use ireb 3.1.2, it will ask you if you have libusb installed
    Ok, I may be getting confused here. After the last ditch effort, my phone went to DFU mode and NOT recovery mode. I can't see anything on the screen. Not even the connect to iTunes dialog. No matter what buttons I hold only itunes will recognize the device.

    Am I bricked?

  12. #12
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by donaetrinz View Post
    Ok, I may be getting confused here. After the last ditch effort, my phone went to DFU mode and NOT recovery mode. I can't see anything on the screen. Not even the connect to iTunes dialog. No matter what buttons I hold only itunes will recognize the device.

    Am I bricked?
    You should get an error, then use irlite or ireb to get out and will boot into emergency

  13. #13
    Quote Originally Posted by yeow202 View Post
    You should get an error, then use irlite or ireb to get out and will boot into emergency
    Ok, I am still getting the same output. If I follow it correctly, there should be something that says
    Code:
    % rslite
    rslite v0.2 - by the iPhone Dev Team, 2009.
    --THIS IS AN UNSUPPORTED TOOL--
    
    Connecting...
    [Recovery] setenv auto-boot true
    [Recovery] saveenv
    [Recovery] reboot
    But when I run rslite, I am get this

    Code:
    rslite - by the iPhone Dev Team, 2009.
    --THIS IS AN UNSUPPORTED TOOL--
    
    Connecting...
    Apple Mobile Device (DFU Mode)
    CPID:8920 CPRV:15 CPFM:03 SCEP:03 BDID:00 ECID:000000413A1E6D4D SRTG:[iBoot-359.3.2]
    [DFU]
    After that, I can't input the "etenv auto-boot true" command because it just errors out.

  14. #14
    Try restoring it again with the last ditch method. If iTunes sees it, it's not bricked.

  15. #15
    Quote Originally Posted by lairtonlelis View Post
    Try restoring it again with the last ditch method. If iTunes sees it, it's not bricked.
    I did this a couple of times with the same exact process. iTunes always sees it, but it still goes back to DFU when I run rslite.

  16. #16
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by donaetrinz View Post
    I did this a couple of times with the same exact process. iTunes always sees it, but it still goes back to DFU when I run rslite.
    Can you try using quickpwn22.1 to see if it boots up

  17. #17
    Are you saying that before you run rslite, your phone is not in DFU mode?

  18. #18
    i have the exact same problem, anybody willing to shed some light on this issue?

  19. #19
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by marcus34 View Post
    i have the exact same problem, anybody willing to shed some light on this issue?
    What did you do to get you into DFU mode ? Can you not put it in Recovery Mode ? Did you try IREB 3.1.2 from iH8sn0w.com | Jailbreak your iPod touches and iPhones

  20. #20
    the phone was in dfu mode, when i got it from my friend. apparently he took it to a phoneguy who tried to restore to a custom firmware and the phone ended up in dfu, it was in 3.1.2 before and it doesnt have a backup of the shsh files so my only option to fix it without updating the baseband was using this method. i followed the guide flashed the firmware got error 6 but after that the phone stayed in dfu mode and not recovery, i tried using irecovery on windows and got an error like "device cannot be identified" then i tried rslite on my friends mac an there i got the same screen as TS where it said [DFU] instead of recovery.

    ooh and i have tried resetting the phone by holding both power and home buttons but i didnt help at all

    if someone knows how to use rslite to get the phone out of DFU pls help me.

    PS. yeah i tried ireb but i didnt manage to make it work, is there a guide to using it somewhere?

Page 1 of 4 123 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •