Page 2 of 2 FirstFirst 12
Results 21 to 30 of 30

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Tutorial: iPhone 3gs 4.0 Beta -> 3.1.3 The Legit Way (No SHSH or JB Tool Used)

  1. #21
    Thanks a lot for the help...

  2. #22
    will this work on the ipod touch 3g?
    Name? whereswaldo
    iDevice + Firmware? 32GB Black iPhone 4 iOS 5.0
    Computer + OS? Dell Inspiron 15R 2nd Gen i5, 2.3 Ghz, 750GB HDD, 8GB RAM Windows 7 HP
    Location? Toronto
    Found yet? No

  3. #23
    Hi! I have a 3gs mc model with new bootrom and locked and never jb. What can I do? This works for me?

  4. #24
    Quote Originally Posted by residentaliennz View Post
    FYI I still needed to use the same process for the 3GS to downgrade my 3G (which worked like a charm. Standard DFU restore only did not work.
    same here

  5. #25
    I've succesfully downgraded from 4.0 to 3.1.2, but I get no service now. I'm on AT&T and don't need/didn't use an unlock. Any idea why this might be?

  6. #26
    everytime i try to run irecovery, it exits out before i can type anything in. I am running windows xp. Anyone have any help they can offer? im trying to downgrade from 4.0 to 3.1.3

  7. #27
    I can't get iRecovery to run correctly. It just tells me "No iPhone/iPod found."

    I've installed the LibUSB and am running in XP compatibility mode, but no matter what I do, I simply cannot get my iPhone out of recovery mode.

    On a 3G going from 4.0 Beta 1 > 3.1.3 using iTunes 9.1.1


    edit: I had to run it in XP Mode. NOT XP Compatibility mode, but the optional XP Virtual Environment from Windows 7 Pro.
    Last edited by Suteru; 2010-05-03 at 02:17 PM.

  8. #28
    I know I'm a little late to this thread, but I see some unanswered questions so figured I'd throw my two cents in.

    I did the downgrade like this on a 3G[S]:
    1) Restore to 3.1.2 stock using SHSH
    2) Get error, then restore again (not sure if this was necessary, but I did it)
    3) Used Spirit to jailbreak
    4) Got no service, and realized it was probably a baseband issue
    5) Make a custom ipsw using sn0wbreeze to upgrade to 3.1.3 without a baseband install
    6) Everything works, YMMV

  9. #29
    Thanks a lot for the instructions!

  10. #30
    Try to use Spirit an Spirit

Page 2 of 2 FirstFirst 12
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •