Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: [HOW TO] Downgrade from 4.0 beta... on my week 32 3Gs

  1. #1
    Default [HOW TO] Downgrade from 4.0 beta... on my week 32 3Gs
    It took me forever to figure it out, but I got it to work... There is no UNLOCKING after you try 4.0, unless you have a factory unlock...

    Note. I has my SHSH's backed up with Cydia, and had my Hosts set to have this in it:
    So I installed 4.0 and played around. since the apps I had don't do multitasking, I wanted to go back to 3.1.2.

    So I do the restore, and I get a error 1015. Tried a DFU, same thing. Ran Blackra1n, and it got my phone to boot, but I had no signal, because it Hacktivated my phone, and I have AT&T. I will spare all the details, but here is what works....

    after the restore, and you get the error 1015, run BlackRa1n. Once you see Geohot's face on your iphone, hold down the power and home buttons. the phone will restart and not be jailbreaked. Then it will start up, and iTunes will activate it when it connects to the store. Then I ran redsnow 9.3 (That way I can tether with the right ipcc file) and selected the 3.1.2 firmware. It ran, and now I am back in jailbreak land!!!

    I am sure that Blackra1n will work just fine to jailbreak it too.. but without BlackSn0w, it won't be able to tether internet... and Blacksn0w will not work with the new baseband!
    Last edited by jaminmc; 2010-04-09 at 06:32 AM.

  2. #2
    Let me guess this only works if you have your SHSH on Saurik server and have Mac computer

  3. #3
    did you do the restore to a custom ipsw? i've tried various things and cannot get it to restore to 3.1.2 jb or 3.1.3 jb. i was able to downgrade to 3.1.3 non-jb. i do have my shsh on file with cydia (or so it said the last time i was able to run cydia). can you be specific on how you did this. i get the 'preparing for restore' and not eligible for restore using all the various methods. i'm curious how you got back to 3.1.2 jb.


  4. #4
    "not eligible for restore" means that you don't have that server in your hosts file from my first file, and Apple's server isn't signing the 3.1.2.

    I first got my iphone to come alive with 3.1.3, but it is the same with 3.1.2. With 3.1.3, I ran blackra1n on it, and it just went to a black screen, because they broke the jailbreak for it.. BUT, it does take it out of the restore loop, and I was able to turn the phone off, and when I turned it back on, it wanted me to plug it in to itunes to activate it.. I did, and it worked fine as a non jailbraked phone. So I restored 3.1.2, and got the same 1015 error. Did above, and I am jailbraked on 3.1.2, then I installed the 3.1.3 app that makes it become 3.1.3. I have no unlock. but I am on AT&T, so I don't need it unless I travel out of the country.

    And no, I am not using a custom rom.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts