Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Need help with 3Gs 3.1.3 with 05.11.07

  1. #1
    Arrow Need help with 3Gs 3.1.3 with 05.11.07

    I accident upgrade to 3.1.3..

    check with the cydia show the SShS 3.1.3...

    I have a 3Gs 16Gg.. are stuck with jailbroken custom 3.1.3 firmware with the old baseband 05.11.07

    and old bootrom and are unable to use your phone because blacksn0w does not work on 3.1.3...


    can someone help me how to unlock it or downgrade to 3.1.2..

    thank you for reading

  2. #2
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    You need to make or download a custom 3.1.2 firmware and restore to that. That'll fix your phone. I recommend using pwnagetool to make the CFW.

  3. #3
    I am in the EXACT same position as you... since we're on the Custom 3.1.3 firmware with the older 5.11.07 baseband, shouldn't we be able to unlock somehow?


    Quote Originally Posted by dhamien View Post
    You need to make or download a custom 3.1.2 firmware and restore to that. That'll fix your phone. I recommend using pwnagetool to make the CFW.
    Correct me if I'm wrong but iTunes no longer allows you to restore to anything older than 3.1.3 right?

  4. #4
    I have try to search for pwnagetool for ( Windows ) but it only for the ( Mac )only...

    I have try the sn0wbreeze-3.1.3-V1.5.1 and redsn0w-win_0.9.4 for
    Jailbrake... it work,,

    after I make a custom firmware for 3.1.3 , connected to the computer it only jailbroke only.. but the firmware is still 3.1.3 and 5.11.07...

    can you show me the step to downgrade to 3.1.2 and unlock it...

  5. #5
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by stabadus View Post
    I am in the EXACT same position as you... since we're on the Custom 3.1.3 firmware with the older 5.11.07 baseband, shouldn't we be able to unlock somehow?




    Correct me if I'm wrong but iTunes no longer allows you to restore to anything older than 3.1.3 right?
    Yes, you should be able to unlock but blacksn0w, which unlocks baseband 05.11.07, doesn't play well with firmware 3.1.3 and that's the reason it doesn't work. The combination of those two. Had you had baseband 04.26.08 and unlocked with ultrasn0w, it wouldn't be a problem but blacksn0w and 3.1.3 is a no-go.

    You're correct that iTunes doesn't allow restore to lower firmwares than the current. The thing about custom firmwares though, is that they skip the signing process when restoring to them on an already jailbroken phone. This means that since you're currently jailbroken on 3.1.3, you can make a custom 3.1.2 firmware and restore to it, even without your 3.1.2 SHSHs stored.

    To conclude, you should make a custom 3.1.2 firmware (I highly recommend pwnagetool) and shift-restore to it in iTunes. If you make and restore to the CFW on a mac, select 'yes' when pwnagetool asks if you're 'already pwned'. If you restore to it on a windows computer, don't put your phone in recovery or DFU mode. Simply have it turned on and sitting on the springboard.

    Quote Originally Posted by andytrinh View Post
    I have try to search for pwnagetool for ( Windows ) but it only for the ( Mac )only...

    I have try the sn0wbreeze-3.1.3-V1.5.1 and redsn0w-win_0.9.4 for
    Jailbrake... it work,,

    after I make a custom firmware for 3.1.3 , connected to the computer it only jailbroke only.. but the firmware is still 3.1.3 and 5.11.07...

    can you show me the step to downgrade to 3.1.2 and unlock it...
    You need to make a custom 3.1.2 firmware. That's the only option you have.

    Also, you shouldn't use redsn0w or any other jailbreak tool once you've used a custom firmware. The point of CFWs is that they're already jailbroken.
    Last edited by dhamien; 2010-03-19 at 05:30 PM. Reason: Automerged Doublepost

  6. #6
    I tried restoring with a custom 3.1.2 and it wouldn't allow me. Are you sure about it letting you downgrade to 3.1.2?

    Has anyone tried this?
    I'm at work, I'll try it when I get home and post results.

  7. #7
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by stabadus View Post
    I tried restoring with a custom 3.1.2 and it wouldn't allow me. Are you sure about it letting you downgrade to 3.1.2?

    Has anyone tried this?
    I'm at work, I'll try it when I get home and post results.
    Yes, I'm sure. I'm guessing you're getting 160x errors? Try restoring without putting the phone in DFU or recovery mode.

  8. #8
    but one thing is Pwnagtool only for the ( Mac )only...

    I only have Windows only... is there a way, can someone make a CFW for Iphone 3gs for CFW 3.1.2 for me...

    that be great.. I have no way to make a CFW...

    thank all your guy for help...

  9. #9
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by stabadus View Post
    This is probably a stupid question but how would one go about restoring the iPhone without putting it in DFU mode?
    It'd actually be the same process as if the phone was in DFU mode, you just do it while the phone is on and on the springboard; in iTunes, hold down the 'shift' key and then click 'restore'. Then point to the custom firmware.

  10. #10
    Default Problem Fixed!!1
    Ok, I downloaded the custom 3.1.2 firmware from that website and joined the two files with HJ Split. Opened up iTunes and just hit Shift + Restore > custom 3.1.2 and everything went smoothly. Downloaded blacksnow to unlock and now I'm back on 3.1.2, unlocked, and good to go.


    The weird thing is that my friend tried this EXACT same procedure on his computer and it did NOT work. He must have tried it 4 or 5 times. He said he had the newest version of iTunes (which might have been the problem) - I have an older version so I don't know if that has anything to do with it. Maybe someone with more knowledge can shed some light to clear things up for the person that started this thread.


    Anywho, thank you all.

  11. #11
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by stabadus View Post
    Ok, I downloaded the custom 3.1.2 firmware from that website and joined the two files with HJ Split. Opened up iTunes and just hit Shift + Restore > custom 3.1.2 and everything went smoothly. Downloaded blacksnow to unlock and now I'm back on 3.1.2, unlocked, and good to go.


    The weird thing is that my friend tried this EXACT same procedure on his computer and it did NOT work. He must have tried it 4 or 5 times. He said he had the newest version of iTunes (which might have been the problem) - I have an older version so I don't know if that has anything to do with it. Maybe someone with more knowledge can shed some light to clear things up for the person that started this thread.


    Anywho, thank you all.
    Good to hear it worked out for you. As for your friend, a number of things could be the cause. Though I doubt it has to do with iTunes. More likely he has a new bootrom phone or his phone isn't previously jailbroken.

  12. #12
    Quote Originally Posted by dhamien View Post
    Good to hear it worked out for you. As for your friend, a number of things could be the cause. Though I doubt it has to do with iTunes. More likely he has a new bootrom phone or his phone isn't previously jailbroken.
    He was trying it with my phone which has an old bootrom*


    New problem now... I woke up and found my iPhone turned off. I pressed the power button to turn it on. It goes to the Apple screen and shuts off. It does NOT restart (which was the problem before, it was stuck in a reboot cycle) but this time, it just goes to the Apple screen and shuts off.

    Any help? I spent a long time fixing everything after I finally got it working so I really don't want to restore again =/

    (Tried blackra1n and it didn't help, don't know how to get iRecovery to work)

  13. #13
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    I think you should look for another custom firmware from another source. Not sure what the problem is, but restore is usually the best fix. But as you're using a custom firmware, it might be that that's the cause of it. So try getting one from somewhere else.

    When you've done that, try installing anything for a day or two so you can see if it has to do with the phone and not something you might've installed.

  14. #14
    Do you have any suggestions on where I should get another custom firmware from? I don't understand though, the phone was working perfectly fine for several hours. After the restore, I did a "restore from backup" that I had before. Then downloaded blacksnow. And I had only installed a couple of new things like Trillian from **********, Categories, and SB Settings.

    After that, I went to sleep and woke up to find my iPhone messed up again.

    I figured I might as well restore it once again and see if it gives me problems, if this happens again, I'll try looking for another source to get the custom 3.1.2 firmware from.

  15. #15
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Ok, usually it's recommended to set up as new phone instead of restoring from a previous backup. The reason for this is that problems can carry over from said backup.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •