Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Jailbreaking 3gs 3.01, Upgrade?

  1. #1
    Default Jailbreaking 3gs 3.01, Upgrade?
    I have a 3GS running 3.0.1 that has never been jailbroken/unlocked before. I never got to register my 3.0 ECID via Cydia so once I upgrade I cannot go back to 3.0x.

    From my understanding I am able to jailbreak my 3gs on 3.0.1 right now using redsn0w? with a small chance of a couple of errors and the like. I noticed that PwnageTool 3.14 jailbreaks the most recent firmware (3.1.2?), so would it be better to just update and jailbreak on 3.1.2 or stay on 3.0.1? My 3gs is on an official carrier (at&t) so I don't particularly care about unlocking my phone, if that makes any difference. Would it be better to upgrade so I can store my 3.1 ECID now before it's too late?

    Sorry for so many questions :/, and thank you.

  2. #2
    I think it's probably too late to store your 3.1 ECID, I would bet that Apple stopped signing them.

    I would probably suggest not upgrading to stock 3.1.2, even though you do not need your phone unlocked now, a locked phone with a higher baseband the resale value is going to drop significantly...
    Don't worry I'm not in jail anymore

  3. #3
    I have the same exact problem. I don't know what to do at this point. I dont want to update to jailbreak and lose my ability to unlock because I need that. Im still stuck at the activation screen.

    Is it possible to load a custom firmware from somebody else? through the DFU mode without redsnow and etc?

    Thanks

  4. #4
    Quote Originally Posted by dannylu88 View Post
    I have the same exact problem. I don't know what to do at this point. I dont want to update to jailbreak and lose my ability to unlock because I need that. Im still stuck at the activation screen.

    Is it possible to load a custom firmware from somebody else? through the DFU mode without redsnow and etc?

    Thanks
    You *may* (and I STRESS may) be able to load a custom 3.1.2 AS LONG as it is set up right.

  5. #5
    Quote Originally Posted by L00i3 View Post
    You *may* (and I STRESS may) be able to load a custom 3.1.2 AS LONG as it is set up right.
    Yes sir u can as long as its set up RIGHT. If u are using an ATT sim, then u need a custom thats (not activated). If u are going to use another carrier, then u need a custom that (is activated). This should also leave ur baseband at 04.26.08 so u can unlock with redsn0w after u get it all set up.

    I updated my 3GS from 3.o to 3.1.2 this exact way. And i have not had a single problem with it since.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •