Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Iphone 3GS upgrade from 3.0 to 3.0.1 possible?

  1. #1
    Question Iphone 3GS upgrade from 3.0 to 3.0.1 possible?
    Newbie poster, so please be gentle.

    I've searched the forums and the internet, but can't seem to find a conclusive answer.

    I recently bought a second hand iphone 3gs which is jailbroken and unlocked with firmware 3.0 (US AT&T iphone using it in HK). Its all well and good and works fine.

    I know there is no unlock solution as yet if I upgrade the firmware to 3.1(.2), however I'm trying to upgrade the firmware to 3.0.1 (actually is there a need to try and upgrade to 3.0.1, or will 3.0 suffice?)

    Anyway, I followed the instructions on Iclarified to get the JB and unlock and downloaded the necessary ipsw listed there.

    I followed the instructions however I got itunes (version 8) showing "connecting to Apple" (or something like that) and then an error saying something along the lines that the firmware/device is not recognised (or unauthorised) by apple (can't remember the exact words, I'm at work at present).

    In Cyida I do have the following: "This device has a 3.1 ECID SHSH on file".

    Now does this mean it is no longer possible to upgrade my firmware to 3.0.1 and keep the JB (and also the unlock), or is there a way round it that I can't seem to find?

    Thanks

  2. #2
    Nope, no way for you to get a successful restore to either 3.0 OR 3.0.1

    Since you require an unlock, be VERY careful with what you install on that phone. If you have access to a Mac, get PwnageTool 3.1.3 and make yourself a custom 3.1 firmware so if you ever DO need a restore, you can restore to your custom 3.1 And NEVER upgrade to stock 3.1.x since you need the unlock until you know for an ABSOLUTE FACT that you will still be able to unlock after. Currently there is not even any real indication that an unlock for the latest baseband is even being worked on.

    Summary...Guard your 3.0 setup like a hawk. Make yourself a custom 3.1 in case of emergency.

  3. The Following User Says Thank You to L00i3 For This Useful Post:

    rupino (2009-10-12)

  4. #3
    OK, thanks for the info. I guess that answers my question!

    Just want to check one thing. With my iphone I have baseband 04... or something like that.

    I presume that will make no difference for jailbreak / unlock?
    Last edited by rupino; 2009-10-12 at 02:05 PM. Reason: Automerged Doublepost

  5. #4
    That is the baseband you need to be able to unlock

    If you ever end up at baseband 05.xx.xx, your unlocking days are over. With no evident hope of 05.xx.xx ever being unlockable, be VERY concious of what you are putting on your phone.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •