Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3G[S] stuck on apple logo

  1. #1
    Default 3G[S] stuck on apple logo
    I need some help guys. My cousin upgraded some apps through cydia and now his 3GS is stuck at the boot logo. My guess is the Rock app crashed this thing. When I plug the phone into the computer, it takes about 5 minutes before itunes recognizes the phone. If I hold the home button and then plug it in, it takes about 2 minutes before itunes puts it into recovery mode. Using iphonebrowser, it looks like the phone is 3.0.1.

    Heres what Ive done with no success:
    -modify /System/Library/LaunchDemons/com.apple.SpringBoard.plist to remove all DYLD_INSERT_LIBRARIES. This did nothign for me
    -using iphonebrowser, removed the rock.app. This did nothing for me
    -ran the irecover utility (results below). This did nothing for me
    -ran iH8sn0w iREB V3.1. Ran the fix recovery mode loop portion of it. This did nothing for me.
    -tried a restore in itunes, kept crapping out and returing a network error.

    At this point, im not sure what else I need to do to get this phone back online! Any and all help is much appreciated!

    [iRecovery Output BEGIN]
    CDocuments and Settings\genuser\Desktop\iRecovery\iRecovery_SVN>i recovery -s
    iRecovery - Recovery Utility
    by wEsTbAeR-- and Tom3q

    Got USB


    =======================================
    ::
    :: iBoot for n88ap, Copyright 2009, Apple Inc.
    ::
    :: BUILD_TAG: iBoot-596.24
    ::
    :: BUILD_STYLE: RELEASE
    ::
    :: USB_SERIAL_NUMBER: CPID:8920 CPRV:14 CPFM:03 SCEP:02 BDID:00 ECID:000001
    F06A03FD0F IBFL:01 SRNM:[88932BG43NR]
    ::
    =======================================

    [FTL:MSG] Apple NAND Driver (AND) RO
    [NAND] Found Chip ID 0x3295DE987A on FMI0:CE0
    [NAND] Found Chip ID 0x3295DE987A on FMI0:CE1
    [NAND] Found Chip ID 0x3295DE987A on FMI1:Cnt: 0
    Entering recovery mode, starting command prompt
    ←[m] IL_Init [OK]
    [FTL:MSG] BUF_Init [OK]
    [FTL:MSG] FPart Init [OK]
    read new style signature 0x43313132 (line:305)
    [FTL:MSG] VSVFL Register [OK]
    [FTL:MSG] VFL Init [OK]
    [FTL:MSG] VFL_Open [OK]
    [FTL:MSG] YAFTL Register [OK]
    yaFTL::YAFTL_Open(l:2738): CXT is not valid . Performing full NAND R/O restore .
    ..
    [FTL:MSG] FTL_Open [OK]
    Boot Failure Count: 15 Panic Fail Cont: 0
    Entering recovery mode, starting command prompt
    ←[m] (Recovery) iPhone$ setenv auto-boot true
    (Recovery) iPhone$ saveenv
    (Recovery) iPhone$ fsboot
    HFSInitPartition: 0x4fc61640
    (Recovery) iPhone$
    [iRecovery Output END]

  2. #2
    Hi ,
    I had similar problems so i might be able to Help .

    Is your phone stuck at the apple logo or the "plug into itunes " logo ?

    It sounds like your apple is stuck in a boot up loop or a recovery mode loop .

    Follow these instructions :
    [ame=http://www.youtube.com/watch?v=LUC1t11JDMA]YouTube - iREB 3.1 [Windows] - How to Get out of a Recovery Mode Loop[/ame]

    I KNOW U TRIED THIS METHOD BUT KEEP AT IT !..MAY TAKE A FEW ATTEMPTS

    download the piece of software on your P.C , connect up your phone and hopefully the software will get you past the boot up loop or recovery mode loop .
    If it does work then you are back to normal like nothing happened .

    BEST OF LUCK ...keep me updated .

    M

  3. #3
    When I run this, the phone reboots and goes back to the apple logo and gets stuck there. I will try to run it another 1/2 dozen times with my fingers crossed
    **EDIT, this didnt work**


    So Im ok with losing all the data so im trying a fresh restore now. Heres what ive done and the issue im having:

    1. Got ECID from iRecover
    2. Used iHatesn0w iREB to generate an .shsh file
    3. ran tinytss with the newly generated .shsh file
    4. put 3gs into dfu mode
    5. shift restore in itunes to restore to 3gs 3.0.1. itunes says its verifying with apple, I can see tinytss respond with information. Then itunes asks again, again, tinytss responds. Then I get a restore error 1600.

    The only thing I can think of is that the .shsh file iREB generated is for 3.1?
    Last edited by ironfistt; 2009-10-08 at 06:03 PM. Reason: Automerged Doublepost

  4. #4
    If it's jailbroken, the only thing you will be able to do as of right now to maintain your jailbreak is restore to a custom 3.1

  5. #5
    Hi IRONFISTT,

    I have the same problem as you,

    Did you have any luck fixing it?

    I've been stuck for 2 weeks on the same problem.

  6. #6
    Retired Moderator battlecrushr's Avatar
    Join Date
    Jun 2009
    Location
    Houston follow @al_da_beast
    Posts
    7,940
    Thanks
    273
    Thanked 1,034 Times in 956 Posts

    Put it in dfu mode and restore to 3.1.2 here's how to enter dfu
    How To: Enter DFU Restore Mode - ModMyi - Wiki

  7. The Following User Says Thank You to battlecrushr For This Useful Post:

    b_lang (2009-11-20)

  8. #7
    Thanks BATTLECRUSHR ... I've already tried that ... no luck.

    I'm stuck in Recovery Loop -- Tried iRecovery, can't get it to work; and tried iReb for Windows... can't get that to work either.

  9. #8
    iPhoneaholic reddawg's Avatar
    Join Date
    Sep 2008
    Location
    Massachusetts, USA
    Posts
    430
    Thanks
    39
    Thanked 71 Times in 59 Posts

    Quote Originally Posted by mrk86m View Post
    Thanks BATTLECRUSHR ... I've already tried that ... no luck.

    I'm stuck in Recovery Loop -- Tried iRecovery, can't get it to work; and tried iReb for Windows... can't get that to work either.
    I know you tried iRecovery, but try using 'reboot' instead of 'fsboot'.

    1) Run iRecovery -s

    2) Execute the following commands:

    setenv auto-boot true
    saveenv
    reboot
    "When I die, I want to go peacefully in my sleep like my grandfather did...not kicking and screaming like the passengers in his car." -- Unknown

  10. #9
    OK, cheers...

    I'll try that when I get the chance.

    Appreciate the tip!

  11. #10
    What's Jailbreak?
    Join Date
    Sep 2009
    Location
    Edmonton, AB, Canada
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts

    I just spent the last 8 hours with this exact problem. My new 3GS, freshly jailbroken with blackra1n on 3.1.2, got stuck in the logo loop and I COULD NOT get out of it. I tried iRecovery which did not work, along with several other solutions online (none of which worked at all).

    THANK YOU BATTLECRUSHR!!!! I thought I had done this several times, but the one obvious step that I was missing was having iTunes open WHILE I put it into DFU mode. I thought I had to put it into DFU mode then plug it into iTunes. The instructions that were given on the website that you suggested worked perfectly. I just restored my 3GS and everything is working wonderfully again! THANK YOU THANK YOU THANK YOU!!!

  12. #11
    hey guys.. I am not sure if this is the right place to post... I have a 8GB 3GS iphonewith new boot rom which requires tethered jb(make it ra1n evertime u reboot).. Now, everytime I open ROCK the spring board gets restarted in safe mode. There is no uninstall option for Rock when I open Blackra1n icon... Please help..!!

  13. #12
    iPhone? More like MyPhone nautical79's Avatar
    Join Date
    Mar 2008
    Location
    Baja Mexico
    Posts
    124
    Thanks
    13
    Thanked 0 Times in 0 Posts

    Hi there, how about you tried to upgrade to 3.1.2 then do the downgrade, it work for me. hope i,ll help you best regards
    Common Sense Its Not So Common

  14. #13
    Quote Originally Posted by Chandrasekarcr View Post
    hey guys.. I am not sure if this is the right place to post... I have a 8GB 3GS iphonewith new boot rom which requires tethered jb(make it ra1n evertime u reboot).. Now, everytime I open ROCK the spring board gets restarted in safe mode. There is no uninstall option for Rock when I open Blackra1n icon... Please help..!!
    If you have Cydia installed, go in and search for RockApp and try and uninstall it that way. Or get CyDelete from Cydia, then delete Rock the same way you would delete any app store app from the springboard, hold the icon til it gets the little x on it.

  15. #14
    Default Invalid CXT issue Fixed
    Just use ireb, to fix the boot chain and then use redsn0w 0.9 make a complete JB with new model option if you happen to have the new Boot ROM, and that's all ohh one ohter thing when i fixed mine i had iTunes opened. i don't think this matters but, could be important, also it will take a couple of tries.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •