Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Why can't I downgrade? I have ECID on file

  1. #1
    Default Why can't I downgrade? I have ECID on file
    Hey,

    Having a bit of an issue.. here is my story.

    I've kept 3.0.1 Jailbroken for a while, actually just updated yesterday. I submitted my information to Cydia, I am 100% positive about this, there is no mistakes.

    I have AT&T, so unlocking is NOT an issue.

    Yesterday, I downloaded a Custom 3.1 jailbroken, since I don't have access to a Mac. It was fine, except the carrier name was missing. Not a big deal, but it was at the time. I read a bunch of people saying they upgraded to official 3.1, then back to custom 3.1 and it fixed everything while maintaining the jailbreak.

    This did not work for me, it wouldn't let me restore to the custom FW, kept getting 1604 error. I tried multiple USB ports, and another PC. Still the same error.

    SO now I don't know what to do. I tried downgrading the 3GS, but I get the error "this device isn't elgible for the requested build"...

    I followed all guides exactly, my phone is in DFU mode (black screen), and edited my hosts file accordingly. I tried using offical 3.0 and 3.0.1 and neither work.

    Any ideas?

  2. #2
    How long ago did you send your info through cydia? If it was after 3.1 was released then you wont have the 3.0 shsh on file

  3. #3
    I would guess a week, maybe 2 weeks ago.

    I sent it to Cydia WAY before I installed 3.1 (yesterday).

    I'm not sure if I had 3.0 or 3.0.1 at that point, if that matters. (Dont' think it does, since I tried both via iTunes)

  4. #4
    It doesn't matter what firmware you had installed, it matters what firmware apple was signing at the point when you pushed the button. And they were signing 3.1 at that point.

  5. #5
    Quote Originally Posted by L00i3 View Post
    It doesn't matter what firmware you had installed, it matters what firmware apple was signing at the point when you pushed the button. And they were signing 3.1 at that point.
    Hrm,

    Doesn't make sense to me. But thanks for the response, I appreciate it! Guess i'll wait for Geohot

  6. #6
    Basically the way it works (at least as far as i can tell) is when itunes requests a signature from apple, itunes tells apple the version of firmware it is requesting a signature for. If apple is no longer signing that firmware (3.0 & 3.0.1) apple says "no"

    When saurik's server or umbrella request a signature, they send the ECID of your phone, not the firmware version to apple, and apple says "that is a valid ECID, yes you may have a signature, but only for what I consider to be a valid firmware (3.1 as of September 9)"

    So in order to have a successful signature request for 3.0, it had to be requested BEFORE September 9. And since saurik only got his signature requesting service perfected less than a week before the official rollout of 3.1, that means there was less than a week window to get those signatures stored, which is why only ~50,000 people got 3.0 signatures on file.

  7. The Following User Says Thank You to L00i3 For This Useful Post:

    troy14 (2009-10-06)

  8. #7
    If you are not getting error 3200...you don't have your etc/host file edited correctly. That's why you can't downgrade. Also to jailbreak 3.1 you have to start on jailbroken 3.0 or 3.0.1.

    Double check the that you have read the instructions for the downgrade and double check that etc/host file

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •