Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 44

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: TinyTSS released

  1. #21
    MegaGoo: This works no matter what version you have on your phone. Now, whether it can help you restore back to 3.0.x is a completely different story.

    The app does what it claims to do; nothing more. All that apple is signing now is 3.1 blobs -- period. There is no way to go back in time and make them sign 3.0 or 3.0.1 blobs for your phone.

    Until the folks that told you to save those files come up with a tool that actually uses them, the ibec/ibss files you grabbed cannot be used for anything. This doesn't mean they're garbage. I would still hold on to them as there is hope that some of the others will come up with a tool that will use them.

    Quote Originally Posted by saurik
    However, and this is unfortunate: just because this information is "sufficient to jailbreak", doesn't mean it is convenient. Without someone writing a special jailbreak tool that uses these files as input you are pretty much stuck.

  2. #22
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,302
    Thanks
    349
    Thanked 1,175 Times in 724 Posts

    I'm on a mac, something is not working. Give me the steps to make it work please. I'm not even going to try and confuse the situation with what I've tried already.

    Where do I go when I get to here:

    Attached Thumbnails Attached Thumbnails -screen-shot-2009-09-20-3.20.08-pm.png  
    Last edited by one1; 2009-09-20 at 09:27 PM.

  3. #23
    You are close-- just type

    java -jar umbrella.jar -e 0000000000000000


    Just replace the zeros with your real ecid. ( note that the ecid needs to be in hex format which happens to be the exact format that usbviewer give you it to you)

  4. #24
    Dumb question.

    I am on 3.01. If I put my phone in recovery mode and use usbviewer to get my ECID, how do I get my iPhone back? Simply reboot it? I don't want to accidently do something that will force me to restore 3.1 while trying to get my blobs.

  5. #25
    Hold Power / Home button till unit resets. Then power on. Should boot normally.

  6. #26
    hey ... am I reading this correctly ??? is this about something that we, those who already in 3.1, and cannot use Saurik's method because we are not one of those 50000, to setup a similar Saurik server in our own computer, capture the ECID of our 3GS 3.1, and do a 3.0 restore ???? wow,, if that is the case, this will be great great great ! So many people is waiting for this !

  7. #27
    No 3.0 restore if you weren't hashed by Cydia while 3.0 or 3.0.1 was still a valid option in apple's eyes.

  8. #28
    I got Collecting all blobs but something wrong after that.... whats wrong

    Collecting all blobs ...
    java.net.ConnectException: Connection timed out : Connect
    at Java.net...

  9. #29
    goodman, that error message means that the server cannot be contacted.

    Did you check your hosts file?

    Go back to the blog and download the latest. The readme file has been updated and I fixed a couple bugs.

  10. #30
    Here's the error I get

    Exception in thread "main" java.lang.NoSuchMethodError: java.lang.String.getBytes(Ljava/nio/charset/Charset[B
    at com.semaphore.Umbrella.executeStage(Umbrella.java: 136)
    at com.semaphore.Umbrella.execute(Umbrella.java:119)
    at com.semaphore.Umbrella.execute(Umbrella.java:114)
    at com.semaphore.Umbrella.main(Umbrella.java:60)

  11. #31
    Default 3.1 blobs with 3.0 firmware?!
    Hi evry´one,

    Got my new iPhone 3gs crashed down installing a wallpaper package via cydia.
    (It has been jb and unlocked before)

    Problem: If I want to use ur method by letting my own pc act like the apple server, tinytss says that my blobs are from firmware 3.1 even though i´ve not installed 3.1!
    It should be propably 3.0 blobs, because this is the version which was running before the crash...

    Anyone got an idea?

    ThX!

  12. #32
    fuduz:

    Did saurik save your 3.0 ecid shsh files? If so, you can point your hosts file to his server and try a restore to 3.0

    OR

    you can run umbrella -v 3.0 -e (your_ecid)

    to save the ecid shsh files saurik may have for you.

    You can then use this same file with tinytss:

    tinytss 00.shsh

    and make sure:

    XXX.XXX.XXX.XXX gs.apple.com

    says

    127.0.0.1 gs.apple.com


    Then try an iTunes Shift+Restore on 3.0 (or 3.0.1 if those were the files saurik saved for you... which would also mean that you need to run umbrella -v 3.0.1 -e (your_ecid) instead of -v 3.0)

  13. #33
    Thx for reply...

    Saurik didn´t save my files ...unfortunately :/

    but I will try it again with the new commands!

    BTW: The version of iTunes doesn´t matter ?!

    -----------------------------------------------------------------------

    Surprisingly, all commands don´t creat a shsh file except the command "umbrella -v 3.1 -e (ecid)" ....and this shsh is from version 3.1 if u ask tinytss o.O
    Last edited by fuduz; 2009-09-21 at 07:41 PM. Reason: update

  14. #34
    I get the file (00.shsh) with this tool. but How i downgrade my 3GS grom 3.1 to 3.0? Why I get this file? For downgrade or?

  15. #35
    You cannot downgrade unless you have your 3.0 or 3.0.1 shsh file.

    As of sept 10 or sept 11 NO ONE was able to get their 3.0 or 3.0.1 ecid shsh files from apple.

    Saurik saved many people that clicked the button to allow him to make their lives easier. He essentially did exactly what the umbrella app does and saved your shsh files for 3.0 or 3.0.1 back before sept 10.

    Umbrella's purpose now is to save your 3.1 shsh files so that when a jb is released for 3.1, you NEVER have to worry about downgrading to 3.1 to keep your JAILBREAK.

    Note that this tool will never help you keep an unlock. Unlocks are tied to the baseband and currently NO exploits exist for downgrading basebands since bootloader 5.8... which no 3gs phones have.

  16. #36
    Everything is clear in readme except how to turn off Port 80. Will any one please help?

  17. #37
    Wonderful .. now 00.shsh and oo.shsh.saurik on file (on my own file) !! But still waiting for JB tool for 3GS 3.1. Its been like 2 weeks now since 'Lets rock and roll'. Still no news !

  18. #38
    Rvman: Unfortunately there is no 'simple' way to figure out what you have taking up port 80. You are going to have to do some 'process research' and find out if you have things like tomcat, apache, or other webservers running.

  19. #39
    Quote Originally Posted by goodman1501 View Post
    Wonderful .. now 00.shsh and oo.shsh.saurik on file (on my own file) !! But still waiting for JB tool for 3GS 3.1. Its been like 2 weeks now since 'Lets rock and roll'. Still no news !

    i tried once to get the 00.shsh file for 3.1 but i tried to generate the 3.0.1 and 3.0, it wont generate anymore.
    I tried also the "hard way" but on the DOS terminal, I saw something that says " connection refused"

    Please help.
    L
    Attached Thumbnails Attached Thumbnails -error2.gif  

  20. #40
    Will this handle grabbing blobs and signing for multiple phones. IE: my phone, the wife's, etc?

    Thanks!

Page 2 of 3 FirstFirst 123 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •