Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Iphone with 3.0 Just trying to restore

  1. #1
    Default Iphone with 3.0 Just trying to restore
    So I know this section is for downgrading... but seems like you guys probably have the most experience with this.

    I have a 3gs with FW 3.0, never had 3.01 or 3.1 on it. My ECID is on file according the the front page of Cydia. I followed Saurik's guide on restoring, but I get error 1604 every time I try it, any ideas? Or am I just SOL until a 3.1 jailbreak comes out?

    And if your curious why I want to restore... When I have 3g turned on on my phone, it gets no service. When I turn off 3g, I get full bars and edge, turn 3g back on, I get no service. I took my sim card out, put it in other phones, they all get 3g signals with full bars. Soooo if any of you guys know how to fix that... that would also be excellent since it would save me from this restore mess.

    Again, I know it's not exactly the right section for this... but I thought maybe someone might know about the 1604 error.



    Edit - Oh and I just had a though, perhaps I'm using the wrong ipsw... I'm using the one I got to use with redsnow when I originally jailbroke the phone. Is this one a special one just for jailbreaking? Where should I get the right ipsw to run a restore?
    Last edited by deathofallthings; 2009-09-18 at 08:07 AM. Reason: Automerged Doublepost

  2. #2
    I also need help. Have searched but could not find anything.

    I have jailbroken g3 on 3.0, I just want to restore the phone to 3.0. I have the 3.0 file, but cant get itunes to just restore it back to factory.

  3. #3
    Livin the iPhone Life SundayDuffer's Avatar
    Join Date
    Aug 2007
    Location
    Northern California
    Posts
    1,503
    Thanks
    32
    Thanked 181 Times in 164 Posts

    1604 error fix... try a different usb port or try it with another computer.

  4. #4
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Edit, already responded to.

  5. #5
    can anyone point me in the right direction?

  6. #6
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    OK, tell me more. You have a 3g phone right? And doing a shift+click restore in iTunes does nothing or what?

  7. #7
    right.....I was stuck at "plug into itunes"

    I ran my redsnow again, and selected my 3.0 ipsw" and it got me back.

    what I wanna do is restore back to 3.0 with no jailbreak"

  8. #8
    iPhone? More like MyPhone iGuru's Avatar
    Join Date
    Sep 2009
    Location
    Cheltenham, UK
    Posts
    188
    Thanks
    5
    Thanked 109 Times in 32 Posts

    Quote Originally Posted by deathofallthings View Post
    I have a 3gs with FW 3.0, never had 3.01 or 3.1 on it. My ECID is on file according the the front page of Cydia. I followed Saurik's guide on restoring, but I get error 1604 every time I try it, any ideas? Or am I just SOL until a 3.1 jailbreak comes out?

    And if your curious why I want to restore... When I have 3g turned on on my phone, it gets no service. When I turn off 3g, I get full bars and edge, turn 3g back on, I get no service. I took my sim card out, put it in other phones, they all get 3g signals with full bars. Soooo if any of you guys know how to fix that... that would also be excellent since it would save me from this restore mess.

    Edit - Oh and I just had a though, perhaps I'm using the wrong ipsw... I'm using the one I got to use with redsnow when I originally jailbroke the phone. Is this one a special one just for jailbreaking? Where should I get the right ipsw to run a restore?
    Which version of your ECID is on file? For example, it will say: "This devices 3.0 ECID SHSH is on file."
    If you have a 3.0 ECID SHSH you can only restore to 3.0, 3.1 ECID SHSH, you can only restore to 3.1, and so on.

    First things first, on your iPhone: Settings -> General -> Reset -> Reset Network Settings

    That may fix your 3G issue if you're lucky, but no guarantees.

    The ISPW you used with RedSn0w is not a special one. As long as it's called "iPhone2,1_3.0_7A341_Restore.ispw" then you are using the correct one.
    To use this you will need your 3.0 ECID SHSH on file with Cydia however.

    As for a few things to try for the 1604 error:

    Completely Remove iTunes, and "Apple Mobile Device Support" from Add/Remove Programs (assuming you are on Windows) - you did not mention if you were or not and then download the latest version of iTunes from here and re-install.

    Try using a different USB port on your computer. If your computer has USB ports built-in to the case, try using ones at the back for example.

    If all else fails, if you were trying to use Recovery Mode to restore try DFU, or if you were trying to use DFU use Recovery.

    Hope this helps.
    iGuru, aka macdotnub/mac.nub - Twitter: http://www.twitter.com/macdotnub
    Get your ECID SHSH file! (For 3GS Restore verification) http://bit.ly/JnDw2 (Thanks to semaphore!)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •