+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Problems with iPhone Camera

is a discussion within the

ZiPhone

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
I have recently used ZiPhone to update to 1.1.3 and installed my apps through installer and one was ScreenShot. I have heard that that causes problems in 1.1.3, which I
...
  1. #1
    My iPhone is a Part of Me MattMac's Avatar
    Join Date
    Dec 2007
    Location
    Nar Nar Goon, Victoria, Australia
    Posts
    741
    Thanks
    83
    Thanked 88 Times in 71 Posts

    Default Problems with iPhone Camera
    I have recently used ZiPhone to update to 1.1.3 and installed my apps through installer and one was ScreenShot. I have heard that that causes problems in 1.1.3, which I am experiencing.

    When I take a photo with the camera app the camera roll just shows blank images when they have just been taken but when I go back to the springboard then to the camera roll the blank pictures are gone. I installed ScreenShot through Installer on my iPhone. I don't know what i have to delete...

    If I replaced the camera app with a fresh copy would that maybe make it work?

    Also if I try and delete an existing photo it goes until I open the camera roll next.
    And iPhoto opens when I plug in my iPhone but it doesn't show the iPhone photos, just my albums... Are all these things connected?

    I never had these problems when I used dev teams unlock, but now that I restored to 1.1.3 to use ZiPhone I have many different problems...

    Thanks to anyone who can help, or will at least try!
    Thanks, Matt.

    Like anyone?

    Please...
    Last edited by MattMac; 02-21-2008 at 05:33 AM. Reason: Automerged Doublepost
    16GB iPhone 3G
    2.2 Pwned
    Dedicated Cydia User

    2.2 GHz Intel MacBook

    Mac OS X 10.5.5
    Bootcamp w/ Windows XP

  2. The Following User Says Thank You to MattMac For This Useful Post:

    fryfone (05-31-2008)

  3. #2
    My iPhone is a Part of Me MattMac's Avatar
    Join Date
    Dec 2007
    Location
    Nar Nar Goon, Victoria, Australia
    Posts
    741
    Thanks
    83
    Thanked 88 Times in 71 Posts

    Thanks everyone for their help, NOT.
    Lol, I figured it ouT. If anyone else has a similar problem then post and I'll help you out! =D
    16GB iPhone 3G
    2.2 Pwned
    Dedicated Cydia User

    2.2 GHz Intel MacBook

    Mac OS X 10.5.5
    Bootcamp w/ Windows XP

  4. #3
    Green Apple
    Join Date
    Sep 2007
    Posts
    32
    Thanks
    9
    Thanked 1 Time in 1 Post
    Default Same thing
    The same thing happen me also. The pictures just showed up as a white box. I also had problems with Notes. The notes would not save and the ones that were saved could not be deleted. Also had a problem with my mail app crashing.

    I had restored many times and jailbreaked with ziphone and it kept happening.

    Finally after last restore I activated as a "New Phone" instead of backing up. That was the trick.

    I am surprised more people have not posted about it.

    Allan

  5. #4
    My iPhone is a Part of Me MattMac's Avatar
    Join Date
    Dec 2007
    Location
    Nar Nar Goon, Victoria, Australia
    Posts
    741
    Thanks
    83
    Thanked 88 Times in 71 Posts

    I know hey, I haven't tried out notes yet but I think I'm going to. I don't want to have to make a new iPhone because I don't want to loose my messages and other settings... If you want to know the way I fixed it I'll tell you...

    I decided to try and export an image in sketches an it told me the settings were incorrect and I had to SSH into my phone and run the following command:

    chown mobile /var/mobile/Media/DCIM/100APPLE


    It fix everything for me, but 1.1.3 is becoming such a hassle... there are so many bugs with the jail process... but there are features I could no longer live without...

    Thanks for the response man. =]
    16GB iPhone 3G
    2.2 Pwned
    Dedicated Cydia User

    2.2 GHz Intel MacBook

    Mac OS X 10.5.5
    Bootcamp w/ Windows XP

  6. The Following 3 Users Say Thank You to MattMac For This Useful Post:

    dtmars (08-11-2008), Josheesh (05-11-2008), R0bbit (03-28-2008)

  7. #5
    Green Apple swpelchat's Avatar
    Join Date
    Jan 2008
    Location
    gulfport ms
    Posts
    74
    Thanks
    59
    Thanked 15 Times in 9 Posts

    hey matt i recently noticed that i was having the same problem with the images just showing up as blank when i take them. and you said that you figured it out could you please tell me how you fixed this problem please. much appreciated thank you.
    16gb iPhone4 black

    If I helped you in anyway please hit thank you.







  8. #6
    My iPhone is a Part of Me MattMac's Avatar
    Join Date
    Dec 2007
    Location
    Nar Nar Goon, Victoria, Australia
    Posts
    741
    Thanks
    83
    Thanked 88 Times in 71 Posts

    Quote Originally Posted by swpelchat View Post
    hey matt i recently noticed that i was having the same problem with the images just showing up as blank when i take them. and you said that you figured it out could you please tell me how you fixed this problem please. much appreciated thank you.
    Yeah no problem. You can use the method above like rabanjr did. Or you can run the following command using SSH or Terminal on your iPhone and that will fix your problem.
    "chown mobile /var/mobile/Media/DCIM/100APPLE"

    If you install sketches and just export an image it should say your settings are incorrect. Click more info and follow the instructions to fix your problem. But I would suggest restoring your iPhone and selecting "New Phone" after the activation.

    =] Matt.
    Last edited by MattMac; 02-28-2008 at 05:35 AM. Reason: Stuffed up =S
    16GB iPhone 3G
    2.2 Pwned
    Dedicated Cydia User

    2.2 GHz Intel MacBook

    Mac OS X 10.5.5
    Bootcamp w/ Windows XP

  9. #7
    Green Apple
    Join Date
    Feb 2008
    Posts
    31
    Thanks
    0
    Thanked 9 Times in 3 Posts

    ive cured it......SSH into iphone and issue this command:

    chown mobile /var/mobile/Media/DCIM/100APPLE

  10. #8
    Green Apple
    Join Date
    Jul 2007
    Posts
    45
    Thanks
    6
    Thanked 3 Times in 3 Posts

    what is actually happening here?

    i have the same issue with camera and notes.

  11. #9
    My iPhone is a Part of Me MattMac's Avatar
    Join Date
    Dec 2007
    Location
    Nar Nar Goon, Victoria, Australia
    Posts
    741
    Thanks
    83
    Thanked 88 Times in 71 Posts

    Quote Originally Posted by hebs View Post
    ive cured it......SSH into iphone and issue this command:

    chown mobile /var/mobile/Media/DCIM/100APPLE
    Man, don't take credit for what I have already done...
    16GB iPhone 3G
    2.2 Pwned
    Dedicated Cydia User

    2.2 GHz Intel MacBook

    Mac OS X 10.5.5
    Bootcamp w/ Windows XP

  12. The Following User Says Thank You to MattMac For This Useful Post:

    ld55 (03-17-2008)

  13. #10
    What's Jailbreak?
    Join Date
    Jan 2008
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Matt, Can you go step by step SSH? How do I SSH? I searched and searched do no what you mean ... I am very NOOB>
    Possibly you can point me to the correct discussion. Thank you.

    NEVER mind ... Between Youtube and Mac Guide ... I figured out how to SSH and Chown Mobile.

    Most of all Thanks to MAtt for the direction !!!
    Last edited by ld55; 03-17-2008 at 11:03 PM. Reason: Automerged Doublepost

  14. #11
    My iPhone is a Part of Me MattMac's Avatar
    Join Date
    Dec 2007
    Location
    Nar Nar Goon, Victoria, Australia
    Posts
    741
    Thanks
    83
    Thanked 88 Times in 71 Posts

    Thanks mate. Nice to know I could help.
    Hope it's all up and working for you.

    Matt
    16GB iPhone 3G
    2.2 Pwned
    Dedicated Cydia User

    2.2 GHz Intel MacBook

    Mac OS X 10.5.5
    Bootcamp w/ Windows XP

  15. #12
    What's Jailbreak?
    Join Date
    Feb 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    thanks man, it worked for me ...

    matt4iphones, thanks man, it worked for me ... no restore, no backups , just one click....
    Last edited by scorpion645; 03-28-2008 at 08:25 AM. Reason: Automerged Doublepost

  16. #13
    What's Jailbreak?
    Join Date
    Dec 2007
    Posts
    8
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by matt4iphones View Post
    Thanks everyone for their help, NOT.
    Lol, I figured it ouT. If anyone else has a similar problem then post and I'll help you out! =D
    could u please tell me how

  17. #14
    My iPhone is a Part of Me MattMac's Avatar
    Join Date
    Dec 2007
    Location
    Nar Nar Goon, Victoria, Australia
    Posts
    741
    Thanks
    83
    Thanked 88 Times in 71 Posts

    Inside the thread man.

    I had to SSH into my phone and run the following command:

    chown mobile /var/mobile/Media/DCIM/100APPLE
    You can either SSH into your phone or install Term-vt100 and run the command into there.
    Whichever is easier for you.

    Matt
    16GB iPhone 3G
    2.2 Pwned
    Dedicated Cydia User

    2.2 GHz Intel MacBook

    Mac OS X 10.5.5
    Bootcamp w/ Windows XP

  18. #15
    Green Apple
    Join Date
    Nov 2007
    Posts
    94
    Thanks
    6
    Thanked 4 Times in 4 Posts

    yepp...i had that too and posted it like weeks ago...(last week to be honest)...
    i just did a fresh install and of course clicked on new phone...the only thing that makes me unhappy...i lost all the nice chats with my gf...(at least 500 msg)...but well...

  19. #16
    What's Jailbreak?
    Join Date
    Apr 2008
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hi,i unlocked my iphone with ziphone 3.0.I have i serious problem and i am lookin for a solution.
    I open the camera but i see only black screen,probably camera doesn't work.Could you hlep me to fix this problem.I have my iphone 2 days but i can't enjoy it because of this!
    Please help!
    Thank you!

  20. #17
    Green Apple
    Join Date
    Nov 2007
    Posts
    33
    Thanks
    5
    Thanked 2 Times in 1 Post
    Quote Originally Posted by matt4iphones View Post
    I know hey, I haven't tried out notes yet but I think I'm going to. I don't want to have to make a new iPhone because I don't want to loose my messages and other settings... If you want to know the way I fixed it I'll tell you...

    I decided to try and export an image in sketches an it told me the settings were incorrect and I had to SSH into my phone and run the following command:

    chown mobile /var/mobile/Media/DCIM/100APPLE


    It fix everything for me, but 1.1.3 is becoming such a hassle... there are so many bugs with the jail process... but there are features I could no longer live without...

    Thanks for the response man. =]
    Did as instructed, but I get the error "Operation not permitted"

    Anyone else experience the same thing?

  21. #18
    Green Apple Josheesh's Avatar
    Join Date
    Jan 2008
    Location
    Alberta
    Posts
    48
    Thanks
    15
    Thanked 1 Time in 1 Post
    Thanks man! I guess it works for 1.1.4 also.
    YNWA

  22. #19
    What's Jailbreak?
    Join Date
    Feb 2008
    Posts
    16
    Thanks
    1
    Thanked 1 Time in 1 Post
    This also worked great for me!!!

    Navigate to var/mobile/Media and issue this command.
    chown -R mobile DCIM

    No need for restoring or backups or anything.

    Thanks for all the Help!!!

  23. #20
    Green Apple fryfone's Avatar
    Join Date
    Dec 2007
    Location
    Hawaii
    Posts
    63
    Thanks
    9
    Thanked 2 Times in 2 Posts

    Ok Im having the same problem and Im gettting the same "operation not permitted" as vishae is getting... ne one got any clues?

    got it working... you have been thanked!
    Last edited by fryfone; 05-31-2008 at 04:18 AM. Reason: Automerged Doublepost
    If it aint broke... you aint try'en hard enough

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts