+ Reply
Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Building a theme, Icons wont show.

is a discussion within the

WinterBoard

forums, a part of the

Skinning / Themes Discussion

section;
Im teaching myself how to develop themes for IOS 6, and its been pretty easy so far. I've only got the custom Wallpaper and Dock, but for some reason my
...
  1. #1
    Green Apple
    Join Date
    Apr 2013
    Location
    Texas
    Posts
    42
    Thanks
    0
    Thanked 4 Times in 2 Posts

    Default Building a theme, Icons wont show.
    Im teaching myself how to develop themes for IOS 6, and its been pretty easy so far.
    I've only got the custom Wallpaper and Dock, but for some reason my custom AppStore icon (only one I've tried) wont show up when I apply my theme.

    Im putting it under Bundles>com.apple.AppStore and naming [email protected]. I looked at another theme for reference, and everything is exactly the same.

    My AppStore icon is 114x114 at 326ppi (Im using paint.net, and the ppi worked for my dock and wallpaper)

    I'm not sure what Im doing wrong, but Im also brand new to this as this is the first theme I've ever attempted.

  2. #2
    .artwork assassin Jato_BZ's Avatar
    Join Date
    Jan 2012
    Location
    New Zealand
    Posts
    2,598
    Thanks
    2,567
    Thanked 4,302 Times in 1,609 Posts

    It's because it's 114x114 pixels. Native/Defaults app icons are 118x120 pixel canvas.

    Have a read thru here

    iOS6x Theme GUIDE

    You might find it very useful
    Twitter Id: @Jato_BZ
    Ask questions here or there, or follow/preview my theme build process...something different

  3. The Following User Says Thank You to Jato_BZ For This Useful Post:

    Sk37cH (09-22-2013)

  4. #3
    Green Apple
    Join Date
    Apr 2013
    Location
    Texas
    Posts
    42
    Thanks
    0
    Thanked 4 Times in 2 Posts

    Ive actually been using that guide. I've got the native camera app to work, but still not the AppStore. I tried the calculator and it didnt work either. After reading that guide I tried resizing the AppStore to 118x120 and it still didnt work. Same with the calculator.

    Its under "Bundles>com.apple.AppStore>[email protected]"

    Thats what that guide said to do. I dont get it.

  5. #4
    .artwork assassin Jato_BZ's Avatar
    Join Date
    Jan 2012
    Location
    New Zealand
    Posts
    2,598
    Thanks
    2,567
    Thanked 4,302 Times in 1,609 Posts

    Quote Originally Posted by SawyerBenjamin View Post
    Ive actually been using that guide. I've got the native camera app to work, but still not the AppStore. I tried the calculator and it didnt work either. After reading that guide I tried resizing the AppStore to 118x120 and it still didnt work. Same with the calculator.

    Its under "Bundles>com.apple.AppStore>[email protected]"

    Thats what that guide said to do. I dont get it.
    As long as the icon is name "[email protected]" and in "com.apple.AppStore" within your "Bundles" folder it should. Do u want to zip up that folder and I can test?
    Twitter Id: @Jato_BZ
    Ask questions here or there, or follow/preview my theme build process...something different

  6. The Following User Says Thank You to Jato_BZ For This Useful Post:

    Sk37cH (09-22-2013)

  7. #5
    Green Apple
    Join Date
    Apr 2013
    Location
    Texas
    Posts
    42
    Thanks
    0
    Thanked 4 Times in 2 Posts

    Yeah, that'd be awesome. My icons are pretty dumb just cause Im trying to figure it all out before I take it too seriously.
    I've got it zipped up. Idk how to send it you though. I'm brand new to the forum.

  8. #6
    .artwork assassin Jato_BZ's Avatar
    Join Date
    Jan 2012
    Location
    New Zealand
    Posts
    2,598
    Thanks
    2,567
    Thanked 4,302 Times in 1,609 Posts

    I'll send u a PM (private MSG)

    Ok I got it working. Your AppStore icon is named wrong.

    Needs to be:

    [email protected] NOT "[email protected]"

    The iOS is Case Sensitive.

    Try that and respring thru WB after naming correctly.

    Let me know

    Also turn off SummerBoard mode if its on in the WinterBoard Settings
    Last edited by Jato_BZ; 04-06-2013 at 08:45 PM.
    Twitter Id: @Jato_BZ
    Ask questions here or there, or follow/preview my theme build process...something different

  9. The Following User Says Thank You to Jato_BZ For This Useful Post:

    Sk37cH (09-22-2013)

  10. #7
    Green Apple
    Join Date
    Apr 2013
    Location
    Texas
    Posts
    42
    Thanks
    0
    Thanked 4 Times in 2 Posts

    Wow. I'll be sure to read a lot more carefully. Thanks!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts