+ Reply
Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Maps

is a discussion within the

Windows Specific Modding Discussion

forums, a part of the

Computer Modding Software

section;
I can't get Maps.app to work in 1.1.1. Everything else works, and I have Installer.app and everything. Completely jailbroken, but Maps.app does not work. It brings up the interface (basically)
...
  1. #1
    iPhone? More like MyPhone
    Join Date
    Sep 2007
    Posts
    105
    Thanks
    4
    Thanked 1 Time in 1 Post
    Default Maps
    I can't get Maps.app to work in 1.1.1. Everything else works, and I have Installer.app and everything. Completely jailbroken, but Maps.app does not work. It brings up the interface (basically) and then just straight up quits. I don't know why. Anybody have any suggestions that could help me fix this problem? Thanks.

    Could somebody please upload all of their Maps.app files so that I can compare them correctly and make any changes if necessary?
    Last edited by long10horns; 10-11-2007 at 07:23 PM.

  2. #2
    Green Apple mjdaul's Avatar
    Join Date
    Aug 2007
    Location
    Milwaukee, WI
    Posts
    90
    Thanks
    3
    Thanked 26 Times in 15 Posts

    mine works fine in 1.1.1, ill attatch it here for you, good luck
    Attached Files Attached Files

  3. #3
    iPhone? More like MyPhone
    Join Date
    Sep 2007
    Posts
    105
    Thanks
    4
    Thanked 1 Time in 1 Post
    I know that I am getting annoying, but I really would love to have my maps back. People have been having this problem for a while. I have seen at least one other time this has happened: http://www.modmyi.com/forums/sh...highlight=mapp I believe this was in 1.0.2. I had a jailbroken 1.0.2 then got a jailbroken 1.1.1 and my Maps.app would load up, but everything was like grayed out as if you could not press them. The only thing that looked normal was the Search bar. After a couple of seconds it brought me back to the Springboard. I tried restarting the phone, and then doing the Home+Power/Sleep Button method for restarting. Neither made Maps.app work. I went back to 1.0.2 and then upgraded back to another jailbroken 1.1.1. Same problem, I am still at the jailbroken 1.1.1 and having the troubles. Please help me. Any suggestions at all would be extremely appreciated. I know I am posting too many times, but this is important to me and I am trying to figure it out. I also made sure all the Maps.app files were set to 0755. Thanks in advance for any help!
    Last edited by long10horns; 10-12-2007 at 03:17 PM.

  4. #4
    Green Apple mjdaul's Avatar
    Join Date
    Aug 2007
    Location
    Milwaukee, WI
    Posts
    90
    Thanks
    3
    Thanked 26 Times in 15 Posts

    so, did you try using the maps app i attached in my previous post?

  5. #5
    What's Jailbreak?
    Join Date
    Nov 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    http://www.botgod.net/iMobileApps.zip , unzip and copy Maps.app and folder System/Library/FrameWorks/GMM.framework in to iPod Touch in System/Library/FrameWorks

  6. #6
    What's Jailbreak?
    Join Date
    Nov 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I followed the posted items and Im having zero luck. When i open Maps the Touch freezes then returns back to the home screen.. running 1.1.1

  7. #7
    What's Jailbreak?
    Join Date
    Nov 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I tried what loggerhead said and put the framework into the system/library/frameworks folder and Maps.app into the Applications folder... still just shows the initial screen and then quits? If anyone can help with this it would be great! Really would like this app and also notes.app on my iTouch.

    -------------------------------------

    Figured it out!

    Just need to set the permissions to both folders (Framework and the .app) to 755!

    This can be done easily when you are transferring files to your iTouch/iPhone.

    I'm using winscp and when you log into your iTouch/iPhone, copy the file over to the relevant folder and it will ask you if you want to copy the file. Go into options on this dialog box and there is a radio box saying 'permissions'. Click this and set the permissions to 755 instead of 664 (which is what i think is the default). Then it seems to work perfectly!

    Let me know if you need a more detailed explanation and i will try to include screenshots.
    Last edited by neilpateluk; 11-25-2007 at 03:37 PM. Reason: Automerged Doublepost

  8. #8
    Green Apple
    Join Date
    Sep 2007
    Location
    Gretna, LA
    Posts
    41
    Thanks
    2
    Thanked 0 Times in 0 Posts

    that's weird that it does that. I had that same problem before, but it was with my clock App. everytime i would try to add a world clock, it would crash back the home screen. I tried to recopy the app back on my phone, but no luck. I had to end up restoring my phone and then reinstalling jailbreak and everything. Then, it worked fine after that. Sorry, but that might be what you have to do. I know its a pain but it should fix it if you can't find another way.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts