Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: PPTP VPN Setup With Issue

  1. #1
    iPhone? More like MyPhone duceduc's Avatar
    Join Date
    Sep 2007
    Location
    Saitama, Japan
    Posts
    246
    Thanks
    2
    Thanked 10 Times in 9 Posts

    Default PPTP VPN Setup With Issue
    Hello. I am not sure where to put this thread as it involves mainly with my Linksys router, I'll put it here since I am using Windows OS.

    My first intention to setup a PPTP VPN, via my Linksys E2000 router with DD-WRT firmware, was to use an iPhone app while being connected to my home network from anywhere I have an internet connection. That is working. However I am finding out I cannot check my emails using my iPhone while it is connected to the VPN. But if I am not connected, I can check emails. My VPN client is my iPhone 4 running on iOS 6.1.2.

    What could be causing this? Here is my PPTP VPN setup within my router:
    Code:
    pptp server: enable
    broadcast support: enable
    force mppe encryption: enable
    dns1: 208.67.222.222
    dns2: 8.8.8.8
    wins2: 208.67.222.222
    server IP: 192.168.4.1
    client ip: 192.168.1.60
    Chap-secrets: username * password *
    My router IP is 192.168.1.1
    Other. Although these are enabled and set, it didn't make a difference if I shut them off or on. It works both ways. VPN passthrough: all 3 enabled ports forward: 1723 & 1792

  2. #2
    My iPhone is a Part of Me Scoops98's Avatar
    Join Date
    Jun 2009
    Location
    BC, Canada
    Posts
    830
    Thanks
    8
    Thanked 116 Times in 109 Posts

    Do you have "Send All Traffic" enabled in the VPN settings on your iPhone?

    What is "server IP: 192.168.4.1?" Why is that on different subnet to your router?
    Until the next time… And if I help you out, give me a "Thanks!" Thanks!

  3. #3
    iPhone? More like MyPhone duceduc's Avatar
    Join Date
    Sep 2007
    Location
    Saitama, Japan
    Posts
    246
    Thanks
    2
    Thanked 10 Times in 9 Posts

    Yes, send all traffic is checked on iPhone. I'd followed a guide to have set the vpn server on a different subnet so there will be no conflict issue. I have also assign an ip with the same subnet as my router, but I still can't access my emails.

  4. #4
    My iPhone is a Part of Me Scoops98's Avatar
    Join Date
    Jun 2009
    Location
    BC, Canada
    Posts
    830
    Thanks
    8
    Thanked 116 Times in 109 Posts

    That's a bit strange. All VPN servers I configure assign a range of IP address for VPN clients on the same subset as your local LAN. These IPs are excluded from the DHCP pool.

    Having "Send All Traffic" enabled means that all internet access routes through your Linksys before actually getting to the internet. Try disabling it.
    Until the next time… And if I help you out, give me a "Thanks!" Thanks!

  5. The Following User Says Thank You to Scoops98 For This Useful Post:

    duceduc (12-05-2013)

  6. #5
    iPhone? More like MyPhone duceduc's Avatar
    Join Date
    Sep 2007
    Location
    Saitama, Japan
    Posts
    246
    Thanks
    2
    Thanked 10 Times in 9 Posts

    Now that is a bit strange. All the guides I've read says to leave the 'send all traffic' checked. Never thought about unchecking it to verified if it works. It works! I suppose it's because the vpn server is my router and works a little differently.

    All is working now.

    Ok, spoke too soon. Now I can't access my internal network. Would you know how to write a rule to have my mails to work while being connected and still have the 'send all traffic' checked?
    Last edited by duceduc; 12-05-2013 at 05:27 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •