Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 59

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Carrier settings for iPhone

  1. #21
    LOL Contra hey how can i get edge to work on my iphone?

  2. #22
    Can someone post or email me the original Phone.plist, Phone.strings, Services.plist, and Services.strings files?

    Thanks!

  3. #23
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    5
    Thanks
    0
    Thanked 2 Times in 1 Post
    Default Here are the original 1.1.1 files, if you forgot to backup
    Here are the files. Read the guide for where to put them.
    Attached Files Attached Files

  4. #24
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,308
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Quote Originally Posted by divebald View Post
    Anyone have the settings for Rogers in Canada?
    APN: internet.com
    User: wapsuer1
    Password: wap

  5. #25
    Quote Originally Posted by Mrp7877 View Post
    just tried it on a 1.1.1 firmware. Doesn't work
    After copying the files and restarting the phone when you go to settings and click on phone icon it just sits there doing nothing.. It looks like the new files on 1.1.1 aren't plain text anymore.
    I was able to get this working on 1.1.1.

    However, when I copied over all 4 files, it created a sort of messy interface. It would say "CARRIER_SERVICES" at the top and have an "ACCOUNT" button at the bottom that would do nothing.

    So, what I did was swapped files in an out until I found a presentable configuration that I liked. In so doing, I discovered I only needed to modify the services.plist file. The other 3 files that were previously modified (services.strings, phone.strings and phone.plist) I left untouched from their 1.1.1 update. Leaving them untouched prevented the aesthetically ugly "CARRIER_SERVICES" from displaying at the top of the settings/phone/carrier services page. Instead it displays as simply "Carrier Services". Yes, much nicer.

    For services.plist I used the previous file written for T-Mobile by the author of this guide and added a couple modifications. I first changed the text for the 611 "CustCare" service to "T-Mobile Customer Service". Within services.plist it is written as CustCare... not sure why. I also simply removed the code that created the "ACCOUNT" button since I couldn't get it to work and had no idea how to fix it. It's supposed to launch a webpage, but it didn't do this even with unmodified 1.1.1 files. So I figured that was a bust and was better to just remove it. So I removed everything in the last <dict> to </dict> button set and that effectively removed the button.

    And now I have a clean interface and all the buttons work with their respective functions. I know that description probably isn't the best because I'm not a programmer and don't know the terminology. I just can sometimes look at code and see the similarities and then make basic alterations to suit my needs.

    Anyway, I hope I've helped someone.

    I would upload the modified services.plist file I used so that other T-Mobile users could use it, but I don't know how. LOL
    Last edited by chasev2; 10-24-2007 at 07:32 PM.

  6. The Following User Says Thank You to chasev2 For This Useful Post:

    pqa (10-30-2007)

  7. #26
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    5
    Thanks
    0
    Thanked 2 Times in 1 Post
    zip the file up (winzip or archive depending on os) and click on "attach" on the forum

  8. #27
    For Firmware 1.1.1 and T-Mobile the services.plist under /System/Library/PreferenceBundles/MobilePhoneSettings.bundle/ should look something like this:

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    	<key>id</key>
    	<string>com.apple.preferences.phone.services</string>
    	<key>items</key>
    	<array>
    		<dict>
    			<key>cell</key>
    			<string>PSGroupCell</string>
    		</dict>
    		<dict>
    			<key>action</key>
    			<string>dialNumber:</string>
    			<key>cell</key>
    			<string>PSTitleValueCell</string>
    			<key>label</key>
    			<string>Check Bill Balance</string>
    			<key>value</key>
    			<string>#225#</string>
    		</dict>
    		<dict>
    			<key>action</key>
    			<string>dialNumber:</string>
    			<key>cell</key>
    			<string>PSTitleValueCell</string>
    			<key>label</key>
    			<string>Directory Assistance</string>
    			<key>value</key>
    			<string>411</string>
    		</dict>
    		<dict>
    			<key>action</key>
    			<string>dialNumber:</string>
    			<key>cell</key>
    			<string>PSTitleValueCell</string>
    			<key>label</key>
    			<string>Display Phone Number</string>
    			<key>value</key>
    			<string>#686#</string>
    		</dict>
    		<dict>
    			<key>action</key>
    			<string>dialNumber:</string>
    			<key>cell</key>
    			<string>PSTitleValueCell</string>
    			<key>label</key>
    			<string>View My Minutes</string>
    			<key>value</key>
    			<string>#646#</string>
    		</dict>
    		<dict>
    			<key>action</key>
    			<string>dialNumber:</string>
    			<key>cell</key>
    			<string>PSTitleValueCell</string>
    			<key>label</key>
    			<string>View My Messages</string>
    			<key>value</key>
    			<string>#674#</string>
    		</dict>
    		<dict>
    			<key>cell</key>
    			<string>PSGroupCell</string>
    		</dict>
    		<dict>
    			<key>action</key>
    			<string>showMyAccount:</string>
    			<key>cell</key>
    			<string>PSButtonCell</string>
    			<key>label</key>
    			<string>MYACCOUNT</string>
    			<key>url</key>
    			<string>https://my.t-mobile.com/login/MyTmobileLogin.aspx</string>
    		</dict>
    	</array>
    	<key>title</key>
    	<string>Services</string>
    </dict>
    </plist>

  9. #28
    I can't seem to get the "My Account" url to work on my 1.1.1... I have Rogers here...

    Anyone else facing the same issue too?

  10. #29
    Quote Originally Posted by someone View Post
    I can't seem to get the "My Account" url to work on my 1.1.1... I have Rogers here...

    Anyone else facing the same issue too?
    Same here. The "My Account" URL wouldn't work even for AT&T before I modified the files. Because of that, I just ditched that button. Having just looked at spkane's services.plist file, I liked that he had a "display my number" button. So i took his file and changed the "My Account" button to dial t-mobile customer service instead.

    I just wanted functional buttons. My buttons don't have to be identical to the AT&T template.

  11. #30
    Anyone else notice the buttons no longer show the blue numbers to the right?

  12. #31
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,308
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Quote Originally Posted by shizzabrick View Post
    Anyone else notice the buttons no longer show the blue numbers to the right?
    I guess assuming you already know the numbers, and it's more "clean" just to show the function.

    Anyone have the original 4 files for 1.1.1 they can upload? Like a dummy, I simply copied all mine over thinking it would work.

  13. #32
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    5
    Thanks
    0
    Thanked 2 Times in 1 Post
    see my post on the second page

  14. The Following 2 Users Say Thank You to soandso For This Useful Post:

    Eurisko (10-26-2007), kneegrinder1000 (11-16-2007)

  15. #33
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,308
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Hey thanks.

  16. #34
    Quote Originally Posted by Eurisko View Post
    I guess assuming you already know the numbers, and it's more "clean" just to show the function.

    Anyone have the original 4 files for 1.1.1 they can upload? Like a dummy, I simply copied all mine over thinking it would work.
    Yea, in 1.1.1 you don't need to replace phone.plist, phone.strings or services.strings. You only need to replace services.plist.

  17. #35
    What's Jailbreak?
    Join Date
    Sep 2007
    Posts
    9
    Thanks
    1
    Thanked 6 Times in 1 Post
    Anyone figure out how to get the CARRIER_SERVICES to change yet?

  18. #36
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    1
    Thanks
    0
    Thanked 2 Times in 1 Post
    Quote Originally Posted by mjames View Post
    Anyone figure out how to get the CARRIER_SERVICES to change yet?
    Edit

    /System/Library/Frameworks/CoreTelephony.framework/Support/UnknownCarrier.plist

    to read

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>AllowEDGEEditing</key>
    <true/>
    <key>CarrierName</key>
    <string>Carrier-->T-Mobile</string>

    This is the same file where you can edit your APN for either wap.voicestream.com or internet2.voicestream.com

    Somehow that APN portion is tied to the preferences.plist file.

  19. The Following 2 Users Say Thank You to JDi For This Useful Post:

    kneegrinder1000 (11-16-2007), kwonkim (10-28-2007)

  20. #37
    Default Carrier Settings Not Accepting
    After i updated to 1.11, i used the winscp and changed the settings according to the forum but it isnt working properly.When i go into t-mobile services at the top it says Carrier Services and it should say t-mobile services and the my account doesnt work and the numbers are shown for like customer care and what not.What can i do to get everything fixed like it should be because it was fine for 1.02

  21. #38
    Quote Originally Posted by spkane View Post
    For Firmware 1.1.1 and T-Mobile the services.plist under /System/Library/PreferenceBundles/MobilePhoneSettings.bundle/ should look something like this:

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    	<key>id</key>
    	<string>com.apple.preferences.phone.services</string>
    	<key>items</key>
    	<array>
    		<dict>
    			<key>cell</key>
    			<string>PSGroupCell</string>
    		</dict>
    		<dict>
    			<key>action</key>
    			<string>dialNumber:</string>
    			<key>cell</key>
    			<string>PSTitleValueCell</string>
    			<key>label</key>
    			<string>Check Bill Balance</string>
    			<key>value</key>
    			<string>#225#</string>
    		</dict>
    		<dict>
    			<key>action</key>
    			<string>dialNumber:</string>
    			<key>cell</key>
    			<string>PSTitleValueCell</string>
    			<key>label</key>
    			<string>Directory Assistance</string>
    			<key>value</key>
    			<string>411</string>
    		</dict>
    		<dict>
    			<key>action</key>
    			<string>dialNumber:</string>
    			<key>cell</key>
    			<string>PSTitleValueCell</string>
    			<key>label</key>
    			<string>Display Phone Number</string>
    			<key>value</key>
    			<string>#686#</string>
    		</dict>
    		<dict>
    			<key>action</key>
    			<string>dialNumber:</string>
    			<key>cell</key>
    			<string>PSTitleValueCell</string>
    			<key>label</key>
    			<string>View My Minutes</string>
    			<key>value</key>
    			<string>#646#</string>
    		</dict>
    		<dict>
    			<key>action</key>
    			<string>dialNumber:</string>
    			<key>cell</key>
    			<string>PSTitleValueCell</string>
    			<key>label</key>
    			<string>View My Messages</string>
    			<key>value</key>
    			<string>#674#</string>
    		</dict>
    		<dict>
    			<key>cell</key>
    			<string>PSGroupCell</string>
    		</dict>
    		<dict>
    			<key>action</key>
    			<string>showMyAccount:</string>
    			<key>cell</key>
    			<string>PSButtonCell</string>
    			<key>label</key>
    			<string>MYACCOUNT</string>
    			<key>url</key>
    			<string>https://my.t-mobile.com/login/MyTmobileLogin.aspx</string>
    		</dict>
    	</array>
    	<key>title</key>
    	<string>Services</string>
    </dict>
    </plist>


    So, can anyone confirm this is working for 1.1.1 and T-Mobile?
    If so, thank you for posting it! And how do I actuall make this into a .plist file?

    Thanks in advance
    I have both Mac and Winblows

  22. #39
    I did the hack but now my call forwarding does not work. Any ideas?

  23. #40
    Hello everyone. I got this sorted for 1.1.1. at about 3.00am this morning. All functions working (call forwarding etc.) and displaying like 1.0.2.

    It took me a while to work it out but it is not to complicated.

    I have to go to work now but will publish the details here later today.

Page 2 of 3 FirstFirst 123 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •