+ Reply
Results 1 to 16 of 16

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: YouTube Mobile videos not working

is a discussion within the

Web Apps

forums, a part of the

3rd Party Apps For iPhone | iPod Touch

section;
Hey all, I've been noticing that people can view YouTube videos on the YouTube Mobile site ( YouTube - Broadcast Yourself. ) on their iPhones. For me, however, when I
...
  1. #1
    What's Jailbreak?
    Join Date
    Feb 2008
    Location
    Canada
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default YouTube Mobile videos not working
    Hey all,

    I've been noticing that people can view YouTube videos on the YouTube Mobile site (YouTube - Broadcast Yourself.) on their iPhones. For me, however, when I load up a YouTube video in Safari on my iPhone, it doesn't work. No thumbnail shows up, only a play button with the denied circle around it.

    Is anyone getting this? is there a fix? I jailbroke my iPhone, maybe I installed something that screws with YouTube?

    Before I go on a rampage and restore my phone and/or remove all apps and reinstall one at a time, anyone know if there's a fix for this?

    Thanks!

  2. #2
    What's Jailbreak?
    Join Date
    May 2009
    Posts
    20
    Thanks
    3
    Thanked 1 Time in 1 Post
    same problem i have

  3. #3
    What's Jailbreak?
    Join Date
    Feb 2008
    Location
    Canada
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I have tried YouTube mobile on other iPhone's (jailbroken and otherwise), I can confirm that YouTube mobile is working.

    Also found another problem: YouTube links (in non-Safari apps) don't open up into YouTube app.

    Will investigate more when I have time, but if anyone can shed any lights or clues, that would be awesome!

  4. #4
    Theme Creator Raptors's Avatar
    Join Date
    Mar 2009
    Posts
    2,441
    Thanks
    145
    Thanked 483 Times in 353 Posts

    newly added videos do not work, and some music channel do not work on mobile youtube "UniversalMusic" For example, do u have mobile cinema?!

  5. #5
    What's Jailbreak?
    Join Date
    Feb 2008
    Location
    Canada
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    mobile cinema? nope don't have it, its not in my cydia tho

  6. #6
    What's Jailbreak?
    Join Date
    Jun 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    same problem here. Anyone know what this is?

  7. #7
    ninja of MMi cricketlang's Avatar
    Join Date
    May 2008
    Location
    Draper, UT
    Posts
    2,124
    Thanks
    89
    Thanked 243 Times in 218 Posts

    uhhhh why arent we using the iphone app???
    The beatings will continue until morale improves.

  8. #8
    What's Jailbreak?
    Join Date
    Feb 2008
    Location
    Canada
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by cricketlang View Post
    uhhhh why arent we using the iphone app???
    I'm assuming you're asking why we aren't using the YouTube app on the iPhone rather than the YouTube mobile site.

    For me, I am using the YouTube mobile site, because in apps like Beejive IM, and even Mail, when I click on a YouTube link, I get sent to Safari rather than the YouTube app. It's that simple.

    But it is irrelevant whether we should be using the YouTube app instead of the YouTube mobile site. There is something about my iPhone setup which is breaking YouTube mobile (and possibly redirection to the YouTube app via non-Safari apps).

    I've tried turning off Mobile Substrate and all my extensions for it, but that didn't work. Next step for me is to look over the preferences plists and see if anything pertaining to YouTube can be found.

    Will post back if I find anything useful.

  9. #9
    ninja of MMi cricketlang's Avatar
    Join Date
    May 2008
    Location
    Draper, UT
    Posts
    2,124
    Thanks
    89
    Thanked 243 Times in 218 Posts

    links in beejive take you to safari which automatically redirects you to youtube app. any youtube video you view launches in the youtube app. its how the iphone was programed. the only youtube fix that i currently know of would be the one that comes with the pushfix for unlocked iphones. thats about it though.
    The beatings will continue until morale improves.

  10. #10
    What's Jailbreak?
    Join Date
    Feb 2008
    Location
    Canada
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by cricketlang View Post
    links in beejive take you to safari which automatically redirects you to youtube app. any youtube video you view launches in the youtube app. its how the iphone was programed. the only youtube fix that i currently know of would be the one that comes with the pushfix for unlocked iphones. thats about it though.
    Yeah I remembered that was the behavior my phone would give before. It doesn't do that anymore, Safari no longer redirects to the YouTube app for me. I'm not sure why.

    PushFix doesn't seem like it will fix my problem as my push is working fine. I'll give it a go tho, at this point any stabs in the dark is better than nothing.

  11. #11
    Green Apple Girrelephant Master's Avatar
    Join Date
    Mar 2008
    Location
    Los Angeles, CA
    Posts
    40
    Thanks
    6
    Thanked 4 Times in 4 Posts

    Same problem. I don't know what it is.

  12. #12
    What's Jailbreak?
    Join Date
    Feb 2008
    Location
    Canada
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I've figured out the problem. It appears that when you hide the YouTube app, the YouTube mobile site breaks.

    Can anyone else confirm this?

  13. #13
    ninja of MMi cricketlang's Avatar
    Join Date
    May 2008
    Location
    Draper, UT
    Posts
    2,124
    Thanks
    89
    Thanked 243 Times in 218 Posts

    confirmed...do not hide youtube app. also hiding the mail app will remove the mai, contacts and calendars in settings
    The beatings will continue until morale improves.

  14. #14
    Green Apple Girrelephant Master's Avatar
    Join Date
    Mar 2008
    Location
    Los Angeles, CA
    Posts
    40
    Thanks
    6
    Thanked 4 Times in 4 Posts

    Default Solution
    Quote Originally Posted by quaff View Post
    I've figured out the problem. It appears that when you hide the YouTube app, the YouTube mobile site breaks.

    Can anyone else confirm this?
    YES, I did a little research and then personally tested the theory that YouTube.app must be visible on your springboard in order for Safari to be able to open links. I would assume the same goes for open iCal files and having Calendar.app hidden.

  15. #15
    Livin the iPhone Life Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,265
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Great information y'all. I was wondering the same thing.
    [SIGPIC][/SIGPIC]

  16. #16
    What's Jailbreak?
    Join Date
    Aug 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Just wanted to confirm that i deleted the YouTube app from categories and it worked for me too..

    Thanks guys - good find

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts