Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Phone locked to Three, paid for unlock No Service

  1. #1
    Default Phone locked to Three, paid for unlock No Service
    Hi I got a phone locked to Three, I called up paid my 15.32 unlock fee, they have verified the phone not blocked and the IMEI number is fine. When I received the phone it said it needed activating when I put my non Three sim in, to get round this I jailbroke the phone which got me in, however since then No Service when any Sim is in. I Jailbroke with Evasi0n on ios 6.0.1 on iPhone 4. Having run through tech support they have said I should go to an Apple store and they will tell me why its not working, however I obviously don't want them to turn around and say "oh jailbroken - c ya". Is the problem the activating part or something more complicated, where should I go from here....?

  2. #2
    What baseband is on it?
    Follow me @LoganWesterman

    Need Your iPhone Unlock Click HERE or Here
    Needs Your iPhone Fixed Pm Me!
    Have a question about Jailbreaking Pm Simon, Annie, Or just about any other member on here

  3. #3
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,789
    Thanks
    7,000
    Thanked 15,559 Times in 7,112 Posts

    If you originally jailbroke it with redsnow then it is hactivated which will cause no service on a officially unlocked iPhone. You can either restore it to 6.1.3 then it should activate normally, or use redsnow again, choose jailbreak, then just choose the option to deactivate. That will put you back on activation screen where you can then activate normally with iTunes.

  4. The Following User Says Thank You to Simon For This Useful Post:

    circlemaker (07-04-2013)

  5. #4
    Modem Firmware is 04.12.02 - don't think that should be an issue - @Simon you sound like you know the what the deal is, I don't want to lose the untether so I'll go Redsn0w option again, thanks for the suggestion. I report back if its still being 'funny'

  6. #5
    I checked and Jbroke with Evasi0n not Redsn0w, I am a little reluctant to use Redsn0w as it well and truely bricked my 3GS when updating to 5.0.1 and now only turns on if I Redsn0w boot tethered, and as soon as you disconnect it loses all function....My question is, do I have to use Redsn0w to rejailbreak and then deactivate or is there an alternative which I can then use the Evasi0n JB which I know is a tried and tested option?

  7. #6
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,789
    Thanks
    7,000
    Thanked 15,559 Times in 7,112 Posts

    SAM from Cydia can also deactivate the phone so that it can be activated properly. I'm not sure it is 6.X compatible though.

    Using redsnow to deactivate wont be jailbreaking it btw. As long as you just choose that option all it will do is deactivate your phone.

  8. #7
    hmm....not exactly what I expected. Redsn0w 0.915b3 to get to deactivate, only way I could get there I could see was I had to select Jailbreak and Cydia option, clicked that option up comes 4 other options one of which to deactivate, I check that, it then does its thing and tells me it is now Jailbroken using tethered option, phone goes to black screen with text - ERROR! Please reboot device into normal operating mode, then perform a clean "slide to power off", then try Redsn0w again. Power off button doesn't turn off, white apple showing, doesn't boot up....What now?

    selecting "just boot" option seems to hang on the "Please wait while your build is being processed. Waiting for reboot". iPhone screen is black....
    Last edited by circlemaker; 07-08-2013 at 10:02 AM.

  9. #8
    just stuck in reboot loop now, iReb doesn't get it out, Redsn0w doesn't get it out, Evasi0n won't detect it. iTunes doesn't detect it to restore either. Redsn0w appears to f#cked two of my devices now

  10. #9
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,789
    Thanks
    7,000
    Thanked 15,559 Times in 7,112 Posts

    You don't pick the install cydia option. You select jailbreak then Only the deactivate one option. You shouldn't be booting tethered at all with redsnow.
    Wat version of redsnow have you been using?

  11. #10
    9.0.15b3 version as it wanted me to direct it to 6.0 iOS due to key error. What do I do now to get back in, do I go to redsn0w and point to deactivate via jailbreak? I got it into dfu and iTunes recognises it but won't let me restore backup or 6.0.1.

  12. #11
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,789
    Thanks
    7,000
    Thanked 15,559 Times in 7,112 Posts

    Forget redsnow for now, you may have messed somethig up by booting tethered and choosing cydia again.
    I suggest restoring the phone. If you want to stay on 6.0.1 so you can use evasion again use iFaith to make a custom stitched 6.0.1 firmware for your device. You can then restore to that custom 6.0.1 in iTunes. After the restore activate the phone properly with iTunes, this should activate your unlock. Then you can restore your backup if you want and jailbreak with evasion.

  13. The Following User Says Thank You to Simon For This Useful Post:

    circlemaker (07-08-2013)

  14. #12
    managed to get out of the loop and have ifaithed the shblobs am constructing new signed ipsw....from here i restore with itunes...i update whebn it works/doesn't work
    Last edited by circlemaker; 07-08-2013 at 03:59 PM. Reason: update

  15. #13
    ok good news iphone unlocked, backup restored, Evasi0n jailbreak done. Happy days, thanks for your help Simon

  16. #14

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •